Highlighted

AE 2017 or 2018 crashes on launch - font cache (not font dictionary)

Community Beginner ,
Dec 14, 2017

Copy link to clipboard

Copied

I've searched high and low for some documentation of this, with no luck. I can only find people talking about the font dictionary, and following the steps to resolve THAT problem haven't helped at all.

I have uninstalled and reinstalled AE 2018, then I uninstalled it again and installed the 2017 version. Same error. This happened after updating my apps to 2018 - perhaps a foolish mistake. Here are the errors I'm seeing, and (I think) the relevant parts of the crash report. Any help, anybody seen this before? This is really a problem...

Screen Shot 2017-12-14 at 11.15.53 AM.pngScreen Shot 2017-12-14 at 11.16.07 AM.png

Process:               After Effects [1258]

Path:                  /Applications/Adobe After Effects CC 2017/Adobe After Effects CC 2017.app/Contents/MacOS/After Effects

Identifier:            com.adobe.AfterEffects

Version:               14.2.1 (14.2.1)

Code Type:             X86-64 (Native)

Parent Process:        ??? [1]

Responsible:           After Effects [1258]

User ID:               503

Date/Time:             2017-12-14 11:40:03.677 -0600

OS Version:            Mac OS X 10.13.2 (17C88)

Report Version:        12

Anonymous UUID:        3170A4B9-F222-8DAF-1B5B-B75C41B21153

Time Awake Since Boot: 1500 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)

Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000038

Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11

Termination Reason:    Namespace SIGNAL, Code 0xb

Terminating Process:   exc handler [0]

VM Regions Near 0x38:

-->

    __TEXT                 0000000102b31000-0000000102b38000 [   28K] r-x/rwx SM=COW  ^  [/Applications/Adobe After Effects CC 2017/Adobe After Effects CC 2017.app/Contents/MacOS/After Effects]

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

0   com.adobe.dvaui.framework      0x00000001086b13d5 dvaui::skins::core::SkinSet::GetSkinWithMap(dvacore::utility::ImmutableString, std::map<dvacore::utility::ImmutableString, std::string, std::less<dvacore::utility::ImmutableString>, std::allocator<std::pair<dvacore::utility::ImmutableString const, std::string> > > const*) + 213

1   com.adobe.dvaui.framework      0x00000001083ce54a dvaui::skins::core::SkinInterface<dvaui::skins::core::Utilities>* dvaui::skins::core::SkinSet::GetSkin<dvaui::skins::core::Utilities>(std::map<dvacore::utility::ImmutableString, std::string, std::less<dvacore::utility::ImmutableString>, std::allocator<std::pair<dvacore::utility::ImmutableString const, std::string> > > const*) + 138

2   com.adobe.dvaui.framework      0x00000001086bdaae dvaui::skins::core::utilities::GetApplicationBackgroundColorID(boost::intrusive_ptr<dvaui::skins::core::SkinSet>) + 46

3   com.adobe.dvaui.framework      0x000000010878d66e dvaui::ui::OS_Dialog::Init(std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, dvacore::geom::PointT<float>, dvacore::geom::PointT<float> const&, bool, NSWindow*, bool, bool, bool, dvacore::utility::Flags<unsigned int> const&, boost::function<dvaui::ui::UI_DialogViewContainer* (bool, bool)>) + 542

4   com.adobe.dvaui.framework      0x000000010878dbcc dvaui::ui::OS_Dialog::OS_Dialog(std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, dvacore::geom::PointT<float>, dvacore::geom::PointT<float> const&, bool, dvaui::ui::UI_Node*, bool, bool, bool, bool, unsigned int, dvacore::utility::Flags<unsigned int> const&, boost::function<dvaui::ui::UI_DialogViewContainer* (bool, bool)>) + 572

5   com.adobe.dvaui.framework      0x00000001087421a5 dvaui::ui::UI_Dialog::UI_Dialog(dvaui::drawbot::SupplierInterface const*, std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, dvacore::geom::PointT<float>, dvacore::geom::PointT<float> const&, bool, dvaui::ui::UI_Node*, bool, bool, bool, bool, unsigned int, dvacore::utility::Flags<unsigned int> const&, boost::function<dvaui::ui::UI_DialogViewContainer* (bool, bool)>) + 245

6   com.adobe.dvaui.framework      0x00000001085af660 dvaui::dialogs::UI_MessageBox::UI_MessageBox(dvaui::drawbot::SupplierInterface const*, std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, int, dvaui::dialogs::UI_MessageBox::Button, dvaui::dialogs::UI_MessageBox::Icon, boost::intrusive_ptr<dvaui::ui::UI_Node>, unsigned int, float, float, boost::shared_ptr<boost::function<void (dvaui::ui::ConstMessage*)> >) + 192

7   com.adobe.dvaui.framework      0x00000001085b952d dvaui::dialogs::messagebox::Messagebox(dvaui::drawbot::SupplierInterface const*, std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, int, dvaui::dialogs::UI_MessageBox::Button, dvaui::dialogs::UI_MessageBox::Icon, boost::intrusive_ptr<dvaui::ui::UI_Node>, boost::shared_ptr<boost::function<void (dvaui::ui::ConstMessage*)> >, float, float) + 205

8   U.dylib                        0x0000000106b32195 Up_ReportErrorDialog(std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, unsigned short, std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, float) + 501

9   U.dylib                        0x0000000106b14d81 Up_ReportErrorUTF16(unsigned int, unsigned short, std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, bool, float) + 1089

10  U.dylib                        0x0000000106b128fb Up_Report16(unsigned int, unsigned short, std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, bool) + 1643

11  U.dylib                        0x0000000106b137a5 U_ReportError(unsigned int, unsigned short, std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&) + 213

12  com.adobe.AfterEffectsLib.framework 0x0000000102e04828 MainMain(bool, bool, bool, bool, bool, bool, unsigned short const*, bool, void**, int, int) + 1896

13  com.adobe.AfterEffectsLib.framework 0x0000000102e0408b EggMain(bool, bool, bool, bool, bool, bool, unsigned short const*, bool, int) + 59

14  com.adobe.AfterEffects        0x0000000102b33eab main + 2267

15  com.adobe.AfterEffects        0x0000000102b335c4 start + 52

Thread 0 crashed with X86 Thread State (64-bit):

  rax: 0x000000000000001d  rbx: 0x00007ffeed0cddf0  rcx: 0x00416f0000000000  rdx: 0x0000000000000000

  rdi: 0x0000000000000000  rsi: 0x00007ffeed0cddf0  rbp: 0x00007ffeed0cdde0  rsp: 0x00007ffeed0cdd80

   r8: 0x00006000000c9cd0   r9: 0x0000000000000040  r10: 0x0000000108c04108  r11: 0x00007fbcdd0f4560

  r12: 0x0000000108798900  r13: 0x00007fbcdb71ee80  r14: 0x0000000000000000  r15: 0x0000000000000000

  rip: 0x00000001086b13d5  rfl: 0x0000000000010246  cr2: 0x0000000000000038

 

Logical CPU:     6

Error Code:      0x00000004

Trap Number:     14

I solved the problem, so in case anybody else is searching for this issue, try this. (Note: Mac, OSX High Sierra)

First clear your caches by opening a terminal window and entering this:

sudo atsutil databases -remove

You'll be prompted to enter your password, do that.

Next, open Disk Utility (in Applications > Utilities), select the hard drive you boot from, and press the first aid button at the top of the window. Let that process run.

Finally, go back to your terminal window (or open a new one) and paste this in:

diskutil resetUserPermissions / `id -u`

Let that run. When it says it is done, you can close the terminal window.

Now try running After Effects again. At least in my case, no more font cache issues, works fine again.

Incidentally, this also resolved a problem I was having with an Indesign error about permissions, as well.

Views

1.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

AE 2017 or 2018 crashes on launch - font cache (not font dictionary)

Community Beginner ,
Dec 14, 2017

Copy link to clipboard

Copied

I've searched high and low for some documentation of this, with no luck. I can only find people talking about the font dictionary, and following the steps to resolve THAT problem haven't helped at all.

I have uninstalled and reinstalled AE 2018, then I uninstalled it again and installed the 2017 version. Same error. This happened after updating my apps to 2018 - perhaps a foolish mistake. Here are the errors I'm seeing, and (I think) the relevant parts of the crash report. Any help, anybody seen this before? This is really a problem...

Screen Shot 2017-12-14 at 11.15.53 AM.pngScreen Shot 2017-12-14 at 11.16.07 AM.png

Process:               After Effects [1258]

Path:                  /Applications/Adobe After Effects CC 2017/Adobe After Effects CC 2017.app/Contents/MacOS/After Effects

Identifier:            com.adobe.AfterEffects

Version:               14.2.1 (14.2.1)

Code Type:             X86-64 (Native)

Parent Process:        ??? [1]

Responsible:           After Effects [1258]

User ID:               503

Date/Time:             2017-12-14 11:40:03.677 -0600

OS Version:            Mac OS X 10.13.2 (17C88)

Report Version:        12

Anonymous UUID:        3170A4B9-F222-8DAF-1B5B-B75C41B21153

Time Awake Since Boot: 1500 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)

Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000038

Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11

Termination Reason:    Namespace SIGNAL, Code 0xb

Terminating Process:   exc handler [0]

VM Regions Near 0x38:

-->

    __TEXT                 0000000102b31000-0000000102b38000 [   28K] r-x/rwx SM=COW  ^  [/Applications/Adobe After Effects CC 2017/Adobe After Effects CC 2017.app/Contents/MacOS/After Effects]

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

0   com.adobe.dvaui.framework      0x00000001086b13d5 dvaui::skins::core::SkinSet::GetSkinWithMap(dvacore::utility::ImmutableString, std::map<dvacore::utility::ImmutableString, std::string, std::less<dvacore::utility::ImmutableString>, std::allocator<std::pair<dvacore::utility::ImmutableString const, std::string> > > const*) + 213

1   com.adobe.dvaui.framework      0x00000001083ce54a dvaui::skins::core::SkinInterface<dvaui::skins::core::Utilities>* dvaui::skins::core::SkinSet::GetSkin<dvaui::skins::core::Utilities>(std::map<dvacore::utility::ImmutableString, std::string, std::less<dvacore::utility::ImmutableString>, std::allocator<std::pair<dvacore::utility::ImmutableString const, std::string> > > const*) + 138

2   com.adobe.dvaui.framework      0x00000001086bdaae dvaui::skins::core::utilities::GetApplicationBackgroundColorID(boost::intrusive_ptr<dvaui::skins::core::SkinSet>) + 46

3   com.adobe.dvaui.framework      0x000000010878d66e dvaui::ui::OS_Dialog::Init(std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, dvacore::geom::PointT<float>, dvacore::geom::PointT<float> const&, bool, NSWindow*, bool, bool, bool, dvacore::utility::Flags<unsigned int> const&, boost::function<dvaui::ui::UI_DialogViewContainer* (bool, bool)>) + 542

4   com.adobe.dvaui.framework      0x000000010878dbcc dvaui::ui::OS_Dialog::OS_Dialog(std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, dvacore::geom::PointT<float>, dvacore::geom::PointT<float> const&, bool, dvaui::ui::UI_Node*, bool, bool, bool, bool, unsigned int, dvacore::utility::Flags<unsigned int> const&, boost::function<dvaui::ui::UI_DialogViewContainer* (bool, bool)>) + 572

5   com.adobe.dvaui.framework      0x00000001087421a5 dvaui::ui::UI_Dialog::UI_Dialog(dvaui::drawbot::SupplierInterface const*, std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, dvacore::geom::PointT<float>, dvacore::geom::PointT<float> const&, bool, dvaui::ui::UI_Node*, bool, bool, bool, bool, unsigned int, dvacore::utility::Flags<unsigned int> const&, boost::function<dvaui::ui::UI_DialogViewContainer* (bool, bool)>) + 245

6   com.adobe.dvaui.framework      0x00000001085af660 dvaui::dialogs::UI_MessageBox::UI_MessageBox(dvaui::drawbot::SupplierInterface const*, std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, int, dvaui::dialogs::UI_MessageBox::Button, dvaui::dialogs::UI_MessageBox::Icon, boost::intrusive_ptr<dvaui::ui::UI_Node>, unsigned int, float, float, boost::shared_ptr<boost::function<void (dvaui::ui::ConstMessage*)> >) + 192

7   com.adobe.dvaui.framework      0x00000001085b952d dvaui::dialogs::messagebox::Messagebox(dvaui::drawbot::SupplierInterface const*, std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, int, dvaui::dialogs::UI_MessageBox::Button, dvaui::dialogs::UI_MessageBox::Icon, boost::intrusive_ptr<dvaui::ui::UI_Node>, boost::shared_ptr<boost::function<void (dvaui::ui::ConstMessage*)> >, float, float) + 205

8   U.dylib                        0x0000000106b32195 Up_ReportErrorDialog(std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, unsigned short, std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, float) + 501

9   U.dylib                        0x0000000106b14d81 Up_ReportErrorUTF16(unsigned int, unsigned short, std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, bool, float) + 1089

10  U.dylib                        0x0000000106b128fb Up_Report16(unsigned int, unsigned short, std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&, bool) + 1643

11  U.dylib                        0x0000000106b137a5 U_ReportError(unsigned int, unsigned short, std::basic_string<unsigned short, std::char_traits<unsigned short>, dvacore::utility::SmallBlockAllocator::STLAllocator<unsigned short> > const&) + 213

12  com.adobe.AfterEffectsLib.framework 0x0000000102e04828 MainMain(bool, bool, bool, bool, bool, bool, unsigned short const*, bool, void**, int, int) + 1896

13  com.adobe.AfterEffectsLib.framework 0x0000000102e0408b EggMain(bool, bool, bool, bool, bool, bool, unsigned short const*, bool, int) + 59

14  com.adobe.AfterEffects        0x0000000102b33eab main + 2267

15  com.adobe.AfterEffects        0x0000000102b335c4 start + 52

Thread 0 crashed with X86 Thread State (64-bit):

  rax: 0x000000000000001d  rbx: 0x00007ffeed0cddf0  rcx: 0x00416f0000000000  rdx: 0x0000000000000000

  rdi: 0x0000000000000000  rsi: 0x00007ffeed0cddf0  rbp: 0x00007ffeed0cdde0  rsp: 0x00007ffeed0cdd80

   r8: 0x00006000000c9cd0   r9: 0x0000000000000040  r10: 0x0000000108c04108  r11: 0x00007fbcdd0f4560

  r12: 0x0000000108798900  r13: 0x00007fbcdb71ee80  r14: 0x0000000000000000  r15: 0x0000000000000000

  rip: 0x00000001086b13d5  rfl: 0x0000000000010246  cr2: 0x0000000000000038

 

Logical CPU:     6

Error Code:      0x00000004

Trap Number:     14

I solved the problem, so in case anybody else is searching for this issue, try this. (Note: Mac, OSX High Sierra)

First clear your caches by opening a terminal window and entering this:

sudo atsutil databases -remove

You'll be prompted to enter your password, do that.

Next, open Disk Utility (in Applications > Utilities), select the hard drive you boot from, and press the first aid button at the top of the window. Let that process run.

Finally, go back to your terminal window (or open a new one) and paste this in:

diskutil resetUserPermissions / `id -u`

Let that run. When it says it is done, you can close the terminal window.

Now try running After Effects again. At least in my case, no more font cache issues, works fine again.

Incidentally, this also resolved a problem I was having with an Indesign error about permissions, as well.

Views

1.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 14, 2017 0
Adobe Community Professional ,
Dec 15, 2017

Copy link to clipboard

Copied

Hello,

I guess the cause would be the permission of the folder. If you still remember the location of the cache folder you have set, you open File > Get info from Finder menu and change Privilege of everyone to "Read & Write".

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 15, 2017 0
Community Beginner ,
Dec 15, 2017

Copy link to clipboard

Copied

It makes sense, but the problem is I don't know where the folder is. It would be the default location, I think, but I can't find any documentation about where that would be.

I've also tried running it with with root permissions (using sudo) from terminal, to see if that helps:

sudo open -a /Applications/Adobe\ After\ Effects\ CC\ 2017/Adobe\ After\ Effects\ CC\ 2017.app/Contents/MacOS/After\ Effects

and the result is the same error message. This makes me suspect that the folder is *missing*, perhaps? But if it is, it seems like an uninstall/reinstall should fix it, and that hasn't been the case. So frustrating! Argh.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 15, 2017 0
Community Beginner ,
Dec 15, 2017

Copy link to clipboard

Copied

I solved the problem, so in case anybody else is searching for this issue, try this. (Note: Mac, OSX High Sierra)

First clear your caches by opening a terminal window and entering this:

sudo atsutil databases -remove

You'll be prompted to enter your password, do that.

Next, open Disk Utility (in Applications > Utilities), select the hard drive you boot from, and press the first aid button at the top of the window. Let that process run.

Finally, go back to your terminal window (or open a new one) and paste this in:

diskutil resetUserPermissions / `id -u`

Let that run. When it says it is done, you can close the terminal window.

Now try running After Effects again. At least in my case, no more font cache issues, works fine again.

Incidentally, this also resolved a problem I was having with an Indesign error about permissions, as well.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 15, 2017 3
JonahOS LATEST
Community Beginner ,
Apr 08, 2020

Copy link to clipboard

Copied

You are my hero. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 08, 2020 0
New Here ,
Feb 07, 2018

Copy link to clipboard

Copied

Struggled with this (frustrating) issue for days and finally found a solution that worked:

Solution:

I created a "Adobe" Folder in Library > Caches.

Original post - https://forums.adobe.com/message/10049029#10049029

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 07, 2018 1
Community Beginner ,
Oct 26, 2018

Copy link to clipboard

Copied

Was going crazy about this. Resetting permissions as per "correct answer" helped, thanks!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 26, 2018 0