Highlighted

AE2017: looping playback beachball

Community Beginner ,
Nov 03, 2016

Copy link to clipboard

Copied

With the new AE 2017, when I playback footage in the timeline with either Ram preview or spacebar,  playback loops indefinitely with a spinning beachball.

It seems to be related to animated shape layers and imported vector assets (.ai and .psd)

I can scrub just fine, and rendering seems to work... but when I preview, it gets stuck in a loop, and force quit is necessary each time.

I've done the usual resetting prefs, restarting computer, trying various files.. etc. To no avail.

I'm on a late 2015 5k Imac, AMD Radeon 2048, running Sierra 10.12.1

Anyone else seeing this issue?

Adobe Community Professional
Correct answer by Szalam | Adobe Community Professional

Everybody who is having this issue, please install the latest update that came out las: After Effects CC (November 2017) Bug-Fix Update Is Now Available

This update is 14.0.1 and is a bug fix for many disturbing issues especially for Mac users. It does not fix all the bugs that are new with the CC 2017 release (Known issues in After Effects CC 2017), but it does fix some issues that have been plaguing After Effects since the first parts of the new architecture showed up in the CC 2015 release.

If you can't see the update yet, you may need to wait a while until you see it as it can take up to 24 hours to populate an update across all the data centers. You may need to log out, relaunch the Creative Cloud app, and long in again.

Views

5.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

AE2017: looping playback beachball

Community Beginner ,
Nov 03, 2016

Copy link to clipboard

Copied

With the new AE 2017, when I playback footage in the timeline with either Ram preview or spacebar,  playback loops indefinitely with a spinning beachball.

It seems to be related to animated shape layers and imported vector assets (.ai and .psd)

I can scrub just fine, and rendering seems to work... but when I preview, it gets stuck in a loop, and force quit is necessary each time.

I've done the usual resetting prefs, restarting computer, trying various files.. etc. To no avail.

I'm on a late 2015 5k Imac, AMD Radeon 2048, running Sierra 10.12.1

Anyone else seeing this issue?

Adobe Community Professional
Correct answer by Szalam | Adobe Community Professional

Everybody who is having this issue, please install the latest update that came out las: After Effects CC (November 2017) Bug-Fix Update Is Now Available

This update is 14.0.1 and is a bug fix for many disturbing issues especially for Mac users. It does not fix all the bugs that are new with the CC 2017 release (Known issues in After Effects CC 2017), but it does fix some issues that have been plaguing After Effects since the first parts of the new architecture showed up in the CC 2015 release.

If you can't see the update yet, you may need to wait a while until you see it as it can take up to 24 hours to populate an update across all the data centers. You may need to log out, relaunch the Creative Cloud app, and long in again.

Views

5.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 03, 2016 0
New Here ,
Nov 03, 2016

Copy link to clipboard

Copied

I'm having the same problem on a mid 2014 MacBook Pro, 2.5 i7, NVIDIA GeForce GT 750M, Sierra 10.12.1

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2016 0
Explorer ,
Nov 03, 2016

Copy link to clipboard

Copied

The quickest thing to try here is to close the timeline window and then see if you can still reproduce the problem.

In some cases on Mac only with El Capitan or later there is an invalidate triggered by the OS that causes AE to redraw the entire timeline during each frame update which is usually the cause of this issue. If hiding the timeline works other workarounds are listed below for the time being.

1.      Reducing the vertical size of the Timeline panel is often enough. Some users who have experienced this problem dock a different panel under the Timeline, such as the Render Queue, and raise the vertical divider between them.

2.      Enabling Full Screen in the Preview panel, or maximizing the Composition panel during the preview (` key, or in the Composition panel menu), hides the Timeline panel.

3.      Hiding the preview-time indicator (the red line that moves across the Timeline panel during a preview) will almost always solve this, as it is the redraw of this UI element that triggers the problem, but it is tricky to do so. You need to zoom in on the Timeline and then move the view away from the area being previewed. This is also not convenient, and somewhat workflow-disruptive, since you can’t watch the PTI hit keyframes, audio waveforms, etc.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2016 2
Community Beginner ,
Nov 03, 2016

Copy link to clipboard

Copied

Well thats interesting. 

The behavior you describe seems to line up with my problem.  I'm testing it out and it seems to be correlating, but since AE totally locks up when its stuck in the loop, I can't use the workarounds you describe to verify. I can only keep a tiny timeline anytime I want playback.  Now I just have to teach myself to not reflexively preview things.

If this is a known bug, and it hasn't been addressed since El Captain, that doesn't bode well.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2016 0
Explorer ,
Nov 03, 2016

Copy link to clipboard

Copied

mrsclean -

efforts have been made to address the issue but apparently there are still cases where it can happen. this is a high priority issue for us to fix. upon launching the app with the default workspace this shouldn't happen.

although i understand the inconvenience - the best workaround is to keep a layout that will prevent this from happening - like number 1. if the timeline panel isn't the bottom most panel in the UI layout you shouldn't ever run into the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2016 0
Contributor ,
Nov 03, 2016

Copy link to clipboard

Copied

I'm sorry but I am SO freaking over this never-ending bug which Adobe haven't been able to fix for ages and which they should be allocating ALL resources to at this point, as entire studios that use 5k Retina iMacs are still having to use After Effects CC 2014 just to be able to have basic functionality!!!! Adobe should be ashamed and embarrassed at their ineptitude, and should offer refunds or compensation to all the AE users who have been basically beta testing for the last 2 years. To call this question "answered" is a joke.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2016 2
Explorer ,
Nov 03, 2016

Copy link to clipboard

Copied

I have been trying to solve this issue on my iMac.  Pressing the spacebar to preview some .ai vector animations results in a RAM preview that I can't stop.  In CC 2015.3, pressing the space bar again stops and starts playback, but not in CC 2017.  The preview renders the whole timeline and loops over and over at half speed.  I'm on a 5k iMac on El Capitan.  I got some better results by moving my cache folder to an external drive, even though it is a slower connection.  I got the beach ball crash over and over.  I was able to save my work with the kill -SEGV terminal command but man what a bummer.  Maybe CC 2018 will work on an iMac.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2016 0
Community Beginner ,
Nov 04, 2016

Copy link to clipboard

Copied

I was under the impression that these "work arounds" would be unnecessary as Adobe claimed these preview issues would be fixed in the new update.  Now it will playback a little smoother than before, but it gets stuck with the spinning wheel and can't be stopped, so annoying.  I'm not even trying to playback a comp with effects, just a raw .mov file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2016 3
New Here ,
Nov 07, 2016

Copy link to clipboard

Copied

Mac Pro 2013 fully loaded. Rather than fight this issue or force to update to OSX10.12 (apple's new billboard that communicates to all prousers with an elongated middle finger "we are a full blown phone gadget company now and you can F off") I simply uninstalled AE14 and reinstalled 13.15 and continued my delayed projects... and wait for adobe to fix this or just live here until I can migrate to 2nd or 3rd gen surface : \

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2016 2
Community Beginner ,
Nov 08, 2016

Copy link to clipboard

Copied

AE CC17 is totally crashing on preview, and I think it has to do with audio sample rates, the best workaround is to scrub graphics and port the project over to Premiere for audio timing or turn off audio and check "Cache before Playback" in the preview tab but then you have to wait until the whole comp is cached to see it....till they fix this.

Adobe please hurry

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2016 1
Explorer ,
Nov 08, 2016

Copy link to clipboard

Copied

Got the same bug on a late 2015 MBP 15"

I almost shot a coworker in the face because of how irritating this bug was.

Today I tried the render queue below the timeline trick and it seems like it worked. This is super annoying though. I don't remember AE 2014 being this buggy. RAM preview is glitchy on the audio and quite often doesn't play in realtime (even though the entire timeline just got cached), audio just changes the pitch because of some dropped frames or what do you call those.

Guys help us professionals get a proper stable release.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2016 1