Highlighted

aerender project path syntax using ssh into Windows 10

Explorer ,
May 27, 2020

Copy link to clipboard

Copied

I'm using ssh to execute aerender on a Windows 10 Pro machine. I'm telling aerender to access the project file over the network. When I enter this command into the ssh command prompt:

aerender -project "\\MACPRO\Work\Sessions\Deep in the Forest\End_Titles\DITF End Titles.aep" -comp "a more perfect union - Wendy Worthington" -rqindex 1 -reuse

 I receive this error:

aerender Error: After Effects error: Unable to call "openFast" because of parameter 1. Path is not valid. Path: "\\MACPRO\Work\Sessions\DITF_End_Titles.aep"  

I'm guessing this has to do with the project path syntax, but I'm not sure how to make it right. Any thoughts on how to make this work?

I was able to make it work by using the "net use" command first:

net use \\1.1.1.2

After that is authenticated, I'm able to use aerender with the project path "\\1.1.1.2\Work\Sessions\etc..."

TOPICS
Error or problem

Views

348

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

aerender project path syntax using ssh into Windows 10

Explorer ,
May 27, 2020

Copy link to clipboard

Copied

I'm using ssh to execute aerender on a Windows 10 Pro machine. I'm telling aerender to access the project file over the network. When I enter this command into the ssh command prompt:

aerender -project "\\MACPRO\Work\Sessions\Deep in the Forest\End_Titles\DITF End Titles.aep" -comp "a more perfect union - Wendy Worthington" -rqindex 1 -reuse

 I receive this error:

aerender Error: After Effects error: Unable to call "openFast" because of parameter 1. Path is not valid. Path: "\\MACPRO\Work\Sessions\DITF_End_Titles.aep"  

I'm guessing this has to do with the project path syntax, but I'm not sure how to make it right. Any thoughts on how to make this work?

I was able to make it work by using the "net use" command first:

net use \\1.1.1.2

After that is authenticated, I'm able to use aerender with the project path "\\1.1.1.2\Work\Sessions\etc..."

TOPICS
Error or problem

Views

349

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 27, 2020 0
Adobe Community Professional ,
May 27, 2020

Copy link to clipboard

Copied

Would you check the permission of the folder (everyone)?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 27, 2020 0
Explorer ,
May 27, 2020

Copy link to clipboard

Copied

Thanks for replying. I tried changing the permissions for the folder containing the project file to "Everyone (Read and Write)" and got the same error. I then set the volume to "ignore ownership" and also got the same error. 

 

The project file and output directory are hosted on a Mac, which is from where I'm performing the ssh commnads. 

 

Could my use of UNC paths be the issue? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 27, 2020 0
Explorer ,
May 28, 2020

Copy link to clipboard

Copied

I was able to make it work by using the "net use" command first:

net use \\1.1.1.2

After that is authenticated, I'm able to use aerender with the project path "\\1.1.1.2\Work\Sessions\etc..."

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 28, 2020 0