Highlighted

After Effect Composition turns black

New Here ,
Nov 04, 2014

Copy link to clipboard

Copied

Hello, I have a problem with my AE composition. I've been importing new layers to my AE composition, however suddenly the composition screen turns black. All the keyframes are still there and as I slide the button across the timeline, I can see the keyframes are still there. I tried undo-ing my steps to see if I made a mistake that rendered the screen all black, but no luck. I assume I might have accidentally clicked a function/view that triggers the screen to turn black, but I'm not sure what function that was. I also first thought I activated the wireframe view but as I switched it back to the normal view, still no luck.

If anybody could help me troubleshoot this problem, that would be great. Thank you so much I'd really appreciate it.

screenshot1.jpg

Topics

Preview

Views

37.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

After Effect Composition turns black

New Here ,
Nov 04, 2014

Copy link to clipboard

Copied

Hello, I have a problem with my AE composition. I've been importing new layers to my AE composition, however suddenly the composition screen turns black. All the keyframes are still there and as I slide the button across the timeline, I can see the keyframes are still there. I tried undo-ing my steps to see if I made a mistake that rendered the screen all black, but no luck. I assume I might have accidentally clicked a function/view that triggers the screen to turn black, but I'm not sure what function that was. I also first thought I activated the wireframe view but as I switched it back to the normal view, still no luck.

If anybody could help me troubleshoot this problem, that would be great. Thank you so much I'd really appreciate it.

screenshot1.jpg

Topics

Preview

Views

37.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Nov 04, 2014

Copy link to clipboard

Copied

That's a prretty small scren grab for diagnostic use.  I can't make out the layer names & such.  Only one question I have at the moment: what's in layers 1 through 28?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 04, 2014

Copy link to clipboard

Copied

Hi Dave, thank you for your reply. I have provided a larger screenshot for your convenience. Layer 1 through 28?

screenshot2.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 04, 2014

Copy link to clipboard

Copied

One more thing. This is what the comp looks like when I highlight all the layers. All the keyframes and animation are there but the layers are invisible, just some guides and bounding boxes.

screenshot3.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 04, 2014

Copy link to clipboard

Copied

I have a couple of questions. Did you import your Illustrator file as a composition retaining layer sizes or are all of those layers separate .ai files?

Here's another question: What happens if you solo a layer? How about purge all caches? What is your fast previews setting?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 05, 2014

Copy link to clipboard

Copied

Hi Rick, thank you for your reply.

I imported my illustrator file as a composition retaining layer size. However, I keep on updating and adding more layers in the illustrator file, so everytime I added a new layer in Illustrator, I imported it as a Footoage > Layer Options > Choose Layers and that's when I added the new layers from Illustrator to AE.

Nothing happened when I solo a layer and purged all caches. The following is my fast previews setting

screenshot4.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 05, 2014

Copy link to clipboard

Copied

Try starting a new composition and import your new AI file as a comp. See if your comp works then.

It's not usually a very good idea to add layers to an existing Illustrator document imported as a comp. I'd start a new AI file for your new assets.

Also, in your second screenshot I see a whole bunch of layers extending outside the comp boundary. This brings up a question about the canvas size in AI. Objects outside the canvas are cropped to the artboard so I must ask, did you change the artboard size?

I also see that you have not turned on transparency grid. What happens if you do that.

One last question about this asset

Screen Shot 2014-11-05 at 6.09.38 AM.png:

According to the info palette this layer is 1 X 1 pixel. That's a pretty useless layer size in a comp. If the middle bar layer isn't positioned precisely on the pixel grid then you'll end up with something that looks like this (the light tan - Note the position and the anchor point) :

Screen Shot 2014-11-05 at 6.26.45 AM.png

Notice what happens when I try and line up a one pixel high (or wide or both) illustrator layer with the pixel grid as compared with a 1 X 1 white solid.

Screen Shot 2014-11-05 at 6.30.12 AM.png

There's a bug in AE that causes odd number of pixel wide or high vector objects to be interpreted just slightly bigger. Note the anchor point in the previous example (0.8, 0.8). This tells you that AE is interpreting the layer size as 1.6 pixels by 1.6 pixels. That means nothing is going to line up ever. If you really intend your design to have a 1 pixel by any dimension shape and have it line up you must create that shape .7 points in AI. AE will interpret it as 2 pixels high or wide but it will display as one pixel and you will be able to line it up with the pixel grid....

Screen Shot 2014-11-05 at 6.44.10 AM.png

Screen Shot 2014-11-05 at 6.47.12 AM.png

I'm assuming that you already know about fixing the anchor point of odd sized layers so that they line up on the pixel grid. This is critical when creating very fine lines and detail that you want to use in a design. For example, if you had a shape layer that was 1 pixel by 1 pixel the anchor point would default to 0.5, 0.5 so you would have to change that to 0,0 or 1,1 to get the shape to line up on the pixel grid.

I still don't know why your project went black. Maybe there is a problem with a single new layer you created. Maybe there is a problem with a bunch of 1 X 1 pixel layers.

By the  way, I thought I should mention that if you convert your vector layer to a path you will get a path that is exactly 1 pixel by 1 pixel but position of the path will have to be adjusted to get it to line up with the pixel grid. The lesson here is that if you really want to use very thin lines in a design then  you should use the shape tools.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 03, 2015

Copy link to clipboard

Copied

Empty your cache in AE. Then restart your computer and open after Effects. Should be back to normal.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 26, 2016

Copy link to clipboard

Copied

Thanks! That was really helpful!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 17, 2016

Copy link to clipboard

Copied

Hey make sure caps lock is not on that will also give you the black screen, not sure if that was mentioned but I just noticed it.Screen Shot 2016-10-17 at 3.10.10 AM.png

caps lock off

Screen Shot 2016-10-17 at 3.11.52 AM.png

viola!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 11, 2017

Copy link to clipboard

Copied

I'm having the same problem, and none of the solutions here have helped, I've just ended up starting again but if anyone can help that would be great.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Dec 11, 2017

Copy link to clipboard

Copied

it couldn't just be something simple like those two choices at the top left could it?

Screen Shot 2017-12-11 at 9.18.27 pm.pngScreen Shot 2017-12-11 at 9.18.44 pm.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Dec 11, 2017

Copy link to clipboard

Copied

see how in the above picture the movie highlighted in blue has made the rest of everything disappear.  Ad tehn if I click on composition comp 1 it all comes back again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 11, 2017

Copy link to clipboard

Copied

no, it's still black unfortunetly

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Dec 11, 2017

Copy link to clipboard

Copied

caps lock is off? things go black if it's on sometimes I've noticed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Dec 11, 2017

Copy link to clipboard

Copied

and another time things were black becaues i'd accidentally deleted my content from adobe after effects window.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Dec 11, 2017

Copy link to clipboard

Copied

Try click the little checkerboard button at the bottom of the composition panel.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 11, 2017

Copy link to clipboard

Copied

I think I might have fixed it, I pressed the solo button for all my layers and now they're working. Thanks for your help

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 10, 2018

Copy link to clipboard

Copied

where is the solo button

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Apr 10, 2018

Copy link to clipboard

Copied

solo.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 19, 2018

Copy link to clipboard

Copied

I had the same problem. I tried several solutions but nothing worked. Finally I found out that there a composition a created that had that issue. Once I deleted it everything came back to normal.

So trace your steps backward. There's a recent composition you created that is causing u that nightmare

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 03, 2019

Copy link to clipboard

Copied

The very same has just happened to me, obviously this is a long standing issue. I have tried all these work arounds except trying it on a different machine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...