Highlighted

After Effects 2017 Crashes on Preview

Community Beginner ,
Nov 08, 2016

Copy link to clipboard

Copied

Ok, So I've seen a few of these and I have seen that this issue is partly due to the fact that I have an external audio system. If I switch to the Internal audio output I don't crash, but the preview doesn't play properly—it seems like it's cacheing but not rendering. I can scrub and do almost everything else but preview.

I'm on a Mac Pro running El Capitan

2 x 2.26 GHz Quad-Core Intel Xeon

40 GB of DDR3 ECC

an SSD Startup and cache on another drive

NVIDIA GeForce GTX 680 2048 MB

Never had a problem with AE before (Yes, I get it, I should have waited)

I've tried a bunch of things like deleting preferences and starting from scratch. When I did this, smaller video files would preview fine but larger (2K) would not play and crashes the system. I have plenty of room on several internal drives and I've tried cacheing on each of them—same issue.

Here's one of the error messages I get.

After Effects Alert

A copy of your project was saved at: /Volumes/Skinny5-1TB/SFA Sofi 2017/Sofi2017-textOverlays (converted)_5.aep.

Last log message was: <123145346899968> <GPU Render Pipeline> <5> Copied GPU frame to CPU {x:1298, y:0, w:1920, h:1080} -> {x:1298, y:0, w:1920, h:1080} (8bpp)

The main error I seem to get is this:

After Effects Alert

A copy of your project was saved at: /Volumes/Skinny5-1TB/SFA Sofi 2017/Sofi2017-textOverlays (converted)_1.aep.

Last log message was: <123145346363392> <prefetch> <5> RequestPrefetchedFrame frame not in async list!

Is there anything that I can do to get this to work or does all this just suck to a point where I just have to re-install the old version?

I guess Adobe is aware of the issue?

Views

13.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

After Effects 2017 Crashes on Preview

Community Beginner ,
Nov 08, 2016

Copy link to clipboard

Copied

Ok, So I've seen a few of these and I have seen that this issue is partly due to the fact that I have an external audio system. If I switch to the Internal audio output I don't crash, but the preview doesn't play properly—it seems like it's cacheing but not rendering. I can scrub and do almost everything else but preview.

I'm on a Mac Pro running El Capitan

2 x 2.26 GHz Quad-Core Intel Xeon

40 GB of DDR3 ECC

an SSD Startup and cache on another drive

NVIDIA GeForce GTX 680 2048 MB

Never had a problem with AE before (Yes, I get it, I should have waited)

I've tried a bunch of things like deleting preferences and starting from scratch. When I did this, smaller video files would preview fine but larger (2K) would not play and crashes the system. I have plenty of room on several internal drives and I've tried cacheing on each of them—same issue.

Here's one of the error messages I get.

After Effects Alert

A copy of your project was saved at: /Volumes/Skinny5-1TB/SFA Sofi 2017/Sofi2017-textOverlays (converted)_5.aep.

Last log message was: <123145346899968> <GPU Render Pipeline> <5> Copied GPU frame to CPU {x:1298, y:0, w:1920, h:1080} -> {x:1298, y:0, w:1920, h:1080} (8bpp)

The main error I seem to get is this:

After Effects Alert

A copy of your project was saved at: /Volumes/Skinny5-1TB/SFA Sofi 2017/Sofi2017-textOverlays (converted)_1.aep.

Last log message was: <123145346363392> <prefetch> <5> RequestPrefetchedFrame frame not in async list!

Is there anything that I can do to get this to work or does all this just suck to a point where I just have to re-install the old version?

I guess Adobe is aware of the issue?

Views

13.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 08, 2016 0
LEGEND ,
Nov 08, 2016

Copy link to clipboard

Copied

usoundadobe wrote:

I guess Adobe is aware of the issue?

Perhaps, but you never know.  As a rent-paying After Effects user, you have been unwittingly drafted into Adobe's Unpaid Beta Tester Program.  You'd be well-advised to submit a Bug Report:

Wishform - Adobe After Effects

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2016 1
Community Beginner ,
Nov 08, 2016

Copy link to clipboard

Copied

Hi,

The solution to your crashing scenario (under Mac SierraOS) is:

go to preferences > audio hardware > chose your default audio output

then go to settings button

then the new Apple Audio MIDI Setup application opens:

go to window > show audio devices (or press cmd 1)> choose After Effects 13.8.1 and on the right side of window

(choose - make a tick on use line of your audio device which you prefer and is already chosen as your

default audio output - if you are not sure you can make a tick on all of them)

In the Apple Audio MIDI Setup application also enable other audio outputs for other Adobe applications

like Premiere Pro 8.0, Adobe Encore DVD 6.0 and etc...

Now the Adobe After Effects CC 2017 shall not crash any more under RAM preview and shall function normally!

Best regards,

Gorazd

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2016 4
Explorer ,
Nov 08, 2016

Copy link to clipboard

Copied

there is a known issue with multi-channel audio devices. however, you should not need to use an aggregate device from a previous version to get this to work (but you may need to create one). if you could post a screen shot of the audio device from AudioMidi setup that you are using in AE when it is crashing that would be helpful.

there is likely a temporary workaround where you could create a new device in AudioMidi setup that just uses two output channels and then select that device in AE.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2016 0
New Here ,
Nov 09, 2016

Copy link to clipboard

Copied

I think I just found a work-around.

Go to Audio Midi Setup and create a "Multi-Output Device."  Tick whatever audio hardware us use to monitor (I have a AJA Kona card on my Mac for video/audio output.

Screen Shot 2016-11-09 at 3.44.01 PM.png

Then select the multi-output device in AE audio hardware setup.

Screen Shot 2016-11-09 at 3.44.21 PM.png

Works for my setup.  Hope it works for yours.

Joey

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2016 1
Explorer ,
Nov 10, 2016

Copy link to clipboard

Copied

Unfortunately this fix didn't work for me - MacPro (early 2008) / 32GB RAM / NVIDIA Quadro FX 4800 1536 MB / OSX 10.10.5 / AJA Kona3

However, I do not experience this problem on my PC. AE2017 seems to be overall less stable on the Mac platform.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2016 0
New Here ,
Jul 15, 2020

Copy link to clipboard

Copied

The Multi Output device method mentioned here by Joey01 fixed my repeated crashing issue on preview and rendering queue. After 35 crashes I was about to lose my mind. on the adobe after effects cc 2020 recent update in July.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2020 0
Community Beginner ,
Nov 09, 2016

Copy link to clipboard

Copied

You are a genius Gorazd!! How the heck did you figure that one out? Brilliant. So far, working flawlessly. Why would Adobe make AE audio so ridiculously convoluted. It's not even an audio program.

Anyway, I'm very grateful!

Thank you. And thansk to all who answered.

P

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2016 0
Adobe Employee ,
Nov 09, 2016

Copy link to clipboard

Copied

Patrick Sasso wrote:

Why would Adobe make AE audio so ridiculously convoluted. It's not even an audio program.

Under the hood, we share a lot of our core media-processing functionality with Audition and Premiere Pro. So, in some ways, it is! We also need to be able to support a lot of the same hardware.

This particular issue should be fixed very soon.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2016 0
Community Beginner ,
Nov 10, 2016

Copy link to clipboard

Copied

Thanks. I hope it's very very soon.

Right now the only way I can use AE is if I disconnect my audio device, which is very bad for me since I have disconnect and reconnect about 3 times a day to work on my projects properly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2016 0
New Here ,
Apr 12, 2017

Copy link to clipboard

Copied

Hello, I'm using After Effects CC17 14.1 on Windows 10 and am having the same issue, any idea if a similar workaround is possible?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 12, 2017 0
New Here ,
Jul 15, 2020

Copy link to clipboard

Copied

Thank you so much. I used the Multi Output method mentioned by Joey below and my crashing has stopped.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2020 0
New Here ,
Nov 16, 2016

Copy link to clipboard

Copied

I was having the same issue but none of the approaches were working for me.  So after some experimenting with this tool, everything was back up and running. Rogue Amoeba | Loopback: Cable-Free Audio Routing

If you have a multichannel audio mixer, you'll want to set "Channel Mapping" to manual in Loopback.  Here's my setup:

Screen Shot 2016-11-16 at 11.04.22 AM.png

After that's running, you can follow some of the earlier suggestions for changing audio input within AE and Midi Settings.  I'm not quite sure exactly what combination of magic toggles I pressed, but at least I'm back up and running!

Hope that helps.

Cheers

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2016 0
New Here ,
Nov 16, 2016

Copy link to clipboard

Copied

**UPDATE**

I found a free solution through this tool here: Release Signed Version for Yosemite/Mavericks/El Capitan · mattingalls/Soundflower · GitHub

It allows you to output 2-channels through a "Multi-Output Device".

In Audio Midi Setup, ensure both your audio interface and Soundflower (2ch) are checked.  With Soundflower being the Master Device.

Then make sure "Multi-Output Device" is set as the output in AE.

Screen Shot 2016-11-16 at 11.50.06 AM.png

Screen Shot 2016-11-16 at 11.47.08 AM.png

Hopefully we won't have to use these workarounds much longer!

Cheers

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2016 0
Adobe Community Professional ,
Nov 17, 2016

Copy link to clipboard

Copied

Everybody who is having this issue, please install the latest update that came out last night: After Effects CC (November 2017) Bug-Fix Update Is Now Available

This update is 14.0.1 and should be a bug fix for this and several other disturbing issues - especially for Mac users. It does not fix all the bugs that are new with the CC 2017 release (Known issues in After Effects CC 2017), but it does fix some issues that have been plaguing After Effects since the first parts of the new architecture showed up in the CC 2015 release.

If you can't see the update yet, you may need to wait a while until you see it as it can take up to 24 hours to populate an update across all the data centers. You may need to log out, relaunch the Creative Cloud app, and long in again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 17, 2016 0
New Here ,
Jun 20, 2017

Copy link to clipboard

Copied

Hello all,

Recently having this same issue on my 2015 15' Macbook and thought I might be able to offer some useful information.

After changing my audio settings per instruction above, still had crashes during previews AND rendering. I unplugged the firewire connecting the iMac i was using as an external monitor (to get rid of the other audio option) and i was able to preview, and render.

Something that I noticed was happening that would cause the crash: During the preview AND render, the project file would autosave right in the middle and it would crash. Maybe thats part of the bug? I also noticed that when adding it to the render queue and hitting render, the project would tab back to my main composition instead of the render queue tab and would proceed to render. About halfway through it would try to auto save then crash. So whatever glitch is happening with these new audio settings is forcing an auto save mid render or preview and crashing the program.

Hope this was helpful!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 20, 2017 0