Highlighted

After Effects 2017 preview lagging

Explorer ,
Nov 03, 2016

Copy link to clipboard

Copied

I've update AE to the newest version and the preview is lagging. I can't preview in real-time anymore (RAM stuck at 11/12 fps or something). Even a simple motion in the simplest composition doesn't play smooth.

Also when I start previewing (spacebar), I can't stop the preview without After Effects crashing or lagging (constant spinning wheel) and have to wait for it to respond or restart AE.

Audio preview is also a horror. Within 2 frames of playback the audio slows down and pitches down. These problems I never had with the previous version. I can't work on my projects without a normal preview and animating on a voiceover. What's going on here? Any thoughts?

I'm working on a MacBook Pro (Retina, 15-inch, Mid 2014)  - 2,5 GHz Intel Core i7 - 16 GB 1600 MHz DDR3

Adobe Community Professional
Correct answer by Szalam | Adobe Community Professional

Everybody who is having this issue, please install the latest update that came out last night: After Effects CC (November 2017) Bug-Fix Update Is Now Available

This update is 14.0.1 and might be a bug fix for this. It certainly fixes several other disturbing issues - especially for Mac users. It does not fix all the bugs that are new with the CC 2017 release (Known issues in After Effects CC 2017), but it does fix some issues that have been plaguing After Effects since the first parts of the new architecture showed up in the CC 2015 release.

If you can't see the update yet, you may need to wait a while until you see it as it can take up to 24 hours to populate an update across all the data centers. You may need to log out, relaunch the Creative Cloud app, and log in again.

Topics

Preview

Views

31.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

After Effects 2017 preview lagging

Explorer ,
Nov 03, 2016

Copy link to clipboard

Copied

I've update AE to the newest version and the preview is lagging. I can't preview in real-time anymore (RAM stuck at 11/12 fps or something). Even a simple motion in the simplest composition doesn't play smooth.

Also when I start previewing (spacebar), I can't stop the preview without After Effects crashing or lagging (constant spinning wheel) and have to wait for it to respond or restart AE.

Audio preview is also a horror. Within 2 frames of playback the audio slows down and pitches down. These problems I never had with the previous version. I can't work on my projects without a normal preview and animating on a voiceover. What's going on here? Any thoughts?

I'm working on a MacBook Pro (Retina, 15-inch, Mid 2014)  - 2,5 GHz Intel Core i7 - 16 GB 1600 MHz DDR3

Adobe Community Professional
Correct answer by Szalam | Adobe Community Professional

Everybody who is having this issue, please install the latest update that came out last night: After Effects CC (November 2017) Bug-Fix Update Is Now Available

This update is 14.0.1 and might be a bug fix for this. It certainly fixes several other disturbing issues - especially for Mac users. It does not fix all the bugs that are new with the CC 2017 release (Known issues in After Effects CC 2017), but it does fix some issues that have been plaguing After Effects since the first parts of the new architecture showed up in the CC 2015 release.

If you can't see the update yet, you may need to wait a while until you see it as it can take up to 24 hours to populate an update across all the data centers. You may need to log out, relaunch the Creative Cloud app, and log in again.

Topics

Preview

Views

31.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Nov 03, 2016

Copy link to clipboard

Copied

Long answer short -- DON'T USE THE SPACE BAR!  Do a proper RAM preview and see what happens.  If you don't know HOW to do a Proper RAM Preview, go look at the beginners' AE tutorials in this forum.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 09, 2016

Copy link to clipboard

Copied

'Long answer short -- DON'T USE THE SPACE BAR!  Do a proper RAM preview and see what happens.  If you don't know HOW to do a Proper RAM Preview, go look at the beginners' AE tutorials in this forum.'

This is the most patronising and aggressive response to a problem I have ever seen on this forum.

I am having the exact same problem and have been using After Effects for the past 15 years. It's not a 'beginners' issue in the slightest. After Effects has gone from being a rock solid and dependable program to an absolute mess ever since Creative Cloud subscription was pushed onto its user base.

Long answer short, don't be so damn patronising and defensive about one of the most unreliable pieces of 'professional' software that money can buy.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 10, 2016

Copy link to clipboard

Copied

This has been an issue for a couple of years with Macs. The issue boils down to how Apple changed how redraw rectangles are calculated when they intersect the region at the bottom of the application window between the rounded corners, which forced After Effects to invalidate how it was re-drawing the timeline and then draw a much bigger region than expected, which slowed down the refresh rate during previews...if that makes sense. And it's taking the AE team a few tries to find the correct fix. They have been working hard at this and I hope to see a fix for it soon.

There are so many people with this frustrating issue that when they finally get it fixed, I predict much joy. Although, the length of time it's taken them to figure out the problem is irking many people.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Nov 12, 2016

Copy link to clipboard

Copied

I see what you mean, but why am I not having any of these problems with AE cc 2014 on the same macbook pro? Looks like Adobe made some drastic changes which are not compatible with (every) computer. And it is indeed frustrating to say the least.

Hoping for a fix soon, because I do like the updates in AE cc 2017.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 12, 2016

Copy link to clipboard

Copied

felixs357207 wrote:

...why am I not having any of these problems with AE cc 2014 on the same macbook pro?

Good question!

The AE team made massively sweeping changes to AE's code in CC 2015 that fundamentally changed how AE works. This was to set the stage for a much more modern architecture. The UI and the renderer were separated for the first time in AE's 20+ year history. This was a great boon as it improved interactive speed while working with After Effects and it made them able to start working on a brand new renderer that will be less buggy and more modern than the old one with its multiprocessing hack.

However, there were some unintended consequences and many more bugs than expected. One of the bugs involved certain Macs (usually Macs with 4k or 5k screens) not being able to play back cached previews at the full frame rate.

The reason for this is rather complicated. The issue boils down to how Mac 10.11 changed how redraw rectangles are calculated when they intersect the region at the bottom of the application window between the rounded corners, which forced After Effects to invalidate how it was re-drawing the timeline and then draw a much bigger region than expected, which slowed down the refresh rate during previews. They've had a few tries at fixing the issue a bit - and the fixes have worked for some people, but not for everyone. I am hopeful for a full fix soon.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Nov 13, 2016

Copy link to clipboard

Copied

So basically growing pains for Adobe (and their users). Thanks for your insights. Luckily the older versions are still accessible and stable!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 15, 2016

Copy link to clipboard

Copied

Hi felixs357207​, where can we download the previous version of AE?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 15, 2016

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Nov 15, 2016

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 27, 2017

Copy link to clipboard

Copied

Dude, just ignore it. That guy never had any problem-solving answer to almost anything over the years I am observing and reading this forum. I developed good practice over time. Just read further and ignore.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 10, 2016

Copy link to clipboard

Copied

What a patronizing unhelpful and unprofessional response. I have been working with After Effects for the last 16 years, so its not a noob problem. Adobe needs to fix this and you should not patronize other users.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 03, 2017

Copy link to clipboard

Copied

David why do you bother replying to every single post when you never comment anything helpful?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 09, 2020

Copy link to clipboard

Copied

Absolutely terrible response. wow

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Nov 03, 2016

Copy link to clipboard

Copied

Thanks for responding, but that is not the issue. Every type of preview shortcut gives the same problems:

No real-time (even this simplest animation).

Stopping a preview gives me a spinning wheel, what results in waiting for the app to respond or even closing and restarting.

No normal audio preview.

These problems I don't have with the 2015.3 version (which I'm using again now).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Nov 03, 2016

Copy link to clipboard

Copied

Please see my reply for this issue in the thread here...

AE2017: looping playback beachball

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Nov 03, 2016

Copy link to clipboard

Copied

Thanks. Minimizing the timeline or doing a full screen preview does the trick (also for the audio). I'll use this workaround for now, but I'm hoping for a fix in the near future.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 15, 2016

Copy link to clipboard

Copied

Same issue with me! Wish I hadn't upgraded now!!! ;(

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 17, 2016

Copy link to clipboard

Copied

Everybody who is having this issue, please install the latest update that came out last night: After Effects CC (November 2017) Bug-Fix Update Is Now Available

This update is 14.0.1 and might be a bug fix for this. It certainly fixes several other disturbing issues - especially for Mac users. It does not fix all the bugs that are new with the CC 2017 release (Known issues in After Effects CC 2017), but it does fix some issues that have been plaguing After Effects since the first parts of the new architecture showed up in the CC 2015 release.

If you can't see the update yet, you may need to wait a while until you see it as it can take up to 24 hours to populate an update across all the data centers. You may need to log out, relaunch the Creative Cloud app, and log in again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 21, 2016

Copy link to clipboard

Copied

Update does not fix the issue for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Nov 21, 2016

Copy link to clipboard

Copied

If you are using 14.0.1 and still having problems with playback then please be specific: are you playing back cached frames? How exactly does your playback misbehaves?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Contributor ,
Jun 07, 2017

Copy link to clipboard

Copied

I'm on Windows 10 and I have the same issue with CC 2017, no problem with 2014.

This problem exist since CC 2015 and it has not been fixed it is a shame !!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jun 07, 2017

Copy link to clipboard

Copied

What kind of monitor do you have?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Contributor ,
Jun 07, 2017

Copy link to clipboard

Copied

I have a 4k BL2711U Benq monitor as my main display and a Eizo Coloredge CG246 has a preview monitor witch is plug on my graphic card DVI port and I use Mercury Transmit to preview.

My system is a PC with Windows 10

Mother Board Asus X99 Deluxe II

Processor Intel 5960x

64 Go of ram

Graphic card 980ti with last driver

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jun 07, 2017

Copy link to clipboard

Copied

Do you get real time playback of cached frames if Mercury Transmit is turned off and you're just viewing it on your main screen?

Are you using color management at all?

Have you tried disabling (or if it's already disabled, enabling) the Use Hardware to Accelerate...Panels option?

Do either of your screens happen to have a Multi-Stream Transport (MST) option? If so, try disabling it. Disabling it works to get RAM previews running at a solid speed on certain Dell 4K screens.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Contributor ,
Jun 07, 2017

Copy link to clipboard

Copied

"Do you get real time playback of cached frames if Mercury Transmit is turned off and you're just viewing it on your main screen?"

I will test that and get back.

"Are you using color management at all?"

You mean in AE ? Someting like Lumetri for examle ?

"Have you tried disabling (or if it's already disabled, enabling) the Use Hardware to Accelerate...Panels option?"

It is disable.

"Do either of your screens happen to have a Multi-Stream Transport (MST) option? If so, try disabling it. Disabling it works to get RAM previews running at a solid speed on certain Dell 4K screens."

My 4k monitor is a SST (Single Stream Transport)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jun 07, 2017

Copy link to clipboard

Copied

StephaneA_AfterEffects  wrote

"Have you tried disabling (or if it's already disabled, enabling) the Use Hardware to Accelerate...Panels option?"

It is disable.

If it's disabled, try enabling it.

StephaneA_AfterEffects  wrote

"Are you using color management at all?"

You mean in AE ? Someting like Lumetri for examle ?

Color management is not an effect applied like Lumetri. It's a way of working to try to keep consistent color. You can read more about it here.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Contributor ,
Jun 08, 2017

Copy link to clipboard

Copied

I've tried with Hardware Accelerate on/off, same thing I've got random lost of real time playback.

I don't use any color managment, "Working space" is set to "none" in the project settings.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jun 08, 2017

Copy link to clipboard

Copied

Do you have scaling set to something besides 100% in Windows? See this thread.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Contributor ,
Jun 08, 2017

Copy link to clipboard

Copied

I've read the theard, I'm not aware of an option to scale the windows in AE so I guess it is set to 100% since I didn't change it. Where is the option to change the size ?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jun 08, 2017

Copy link to clipboard

Copied

settingsscaling2-100598955-orig.png

Details here.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Contributor ,
Jun 08, 2017

Copy link to clipboard

Copied

My 4k display is set to 150% (as recommended by Microsoft) but I don't want to change this because if I do the desktop icons and text of Windows are way to small

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jun 08, 2017

Copy link to clipboard

Copied

Can you change it just to see if it helps AE? It would be a troubleshooting step and you can change it back later. Set all of your monitors to be 100%, launch AE, see if you can get real time playback of a cached preview, then close AE and change them back to whatever you prefer.

We'll see what we need to do from there.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Contributor ,
Jun 08, 2017

Copy link to clipboard

Copied

Ok. I try and let you know.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...