Highlighted

After Effects CC 17 Depth of Field not working??

New Here ,
Jun 17, 2017

Copy link to clipboard

Copied

Please Help! I've been working on a project In After Effects CC 2017 making a title template, I clicked the box to set my title template with the effects I already have on it to 3D, set the mode to screen and then duplicated the Title template, I then tried to push the duplicated layer in the Z Field back to have that 3D effect but when I do, it doesn't show my duplicated layer pushed back at all even though it shows I have two layers, and ive tried many other forum solutions like: pushing it back even further into Z-Field, changing the Renderer: from classic 3D to Cinema 4D, and Ray-traced 3D and still nothing, the only issues I can think of is maybe my graphics card isn't compatible for the 3D rendering cause when I go to Preferences and check my GPU Information nothing shows up in my OpenGL or my CUDA, and also my preview screen that displays my project shows in the top right corner "Display Acceleration: Disabled". Also I apologize in advance I am not amazing with After Effects I am still learning, so please if you can be specific with answers it would be greatly appreciated.

[Moved from the non-technical LOUNGE Forum to the Program forum... Mod]

[Here is the list of all Adobe forums... https://forums.adobe.com/welcome]

Views

12.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

After Effects CC 17 Depth of Field not working??

New Here ,
Jun 17, 2017

Copy link to clipboard

Copied

Please Help! I've been working on a project In After Effects CC 2017 making a title template, I clicked the box to set my title template with the effects I already have on it to 3D, set the mode to screen and then duplicated the Title template, I then tried to push the duplicated layer in the Z Field back to have that 3D effect but when I do, it doesn't show my duplicated layer pushed back at all even though it shows I have two layers, and ive tried many other forum solutions like: pushing it back even further into Z-Field, changing the Renderer: from classic 3D to Cinema 4D, and Ray-traced 3D and still nothing, the only issues I can think of is maybe my graphics card isn't compatible for the 3D rendering cause when I go to Preferences and check my GPU Information nothing shows up in my OpenGL or my CUDA, and also my preview screen that displays my project shows in the top right corner "Display Acceleration: Disabled". Also I apologize in advance I am not amazing with After Effects I am still learning, so please if you can be specific with answers it would be greatly appreciated.

[Moved from the non-technical LOUNGE Forum to the Program forum... Mod]

[Here is the list of all Adobe forums... https://forums.adobe.com/welcome]

Views

12.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 17, 2017 0
Most Valuable Participant ,
Jun 17, 2017

Copy link to clipboard

Copied

show us a full screenshot of your Ae interface so we can see what's going on

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2017 0
New Here ,
Jun 18, 2017

Copy link to clipboard

Copied

How do I post a screenshot from my Android device on this discussion?, I have the images of the A.e. interface but this is my first time using a forum and I don't see an Icon that let's me attach a file or screenshot from my gallery.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2017 0
Adobe Community Professional ,
Jun 18, 2017

Copy link to clipboard

Copied

Maybe I'm missing something and it is really difficult to help you without a screenshot of your interface. Anyway, the first thing to get DOF effect is to have a 3D Camera in your composition with the Depth of Field Option enabled. Once you do this, the nest step is to use the parameter Aperture in the camera settings to get DOF.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2017 0
New Here ,
Jun 18, 2017

Copy link to clipboard

Copied

I was actually able to insert the screenshots of the A.E. Interface from my laptop instead of my phone i just need an internet connection cause at the moment earlier i didn't have one, I did like you said and enabled DOF but the only thing i don't know is how to mess with the parameter aperture settings to get DOF, how do i use that?, but also here's the images hopefully this helps out.Capture4.PNGCapture 5.PNG

Capture 3.PNGCapture 2.PNGCapture 1.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2017 0
Adobe Community Professional ,
Jun 18, 2017

Copy link to clipboard

Copied

Hi

It is a bit technical to explain how the DOF work. Basically, you need to let the light to pass through the camera, so with a higher value in Aperture you will get more blur, but you need to set up Zoom and Focus Distance. In these two parameters have the same value, you will never get DOF. Try to move Focus Distance to activate DOF. But also, you need to have your layers with some variation in Z Space. If all your layers are located in the same Z Value and, they will be on focus except if you move your camera.

This is something that is not related to GPU or CPU

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2017 1
New Here ,
Jun 18, 2017

Copy link to clipboard

Copied

I adjusted the zoom, focus and aperture parameters like you said. everything else work fine when i create the camera and use the unified camera tool to rotate my templates around in the DOF, but when i try to move my second/duplicated template with some variations in Z-Space behind my first template it doesn't move behind it still to create that 3D look, instead they stay stuck together like they are one single layer. I've been watching a tutorial video on YouTube to the "T" on how to create the project i'm working on and the layer still doesn't move back in Z-Space. But when i create a different Composition and make a Text layer and duplicate everything to test out if it works the same way as the other project it actually works and i see the second template layer in the back of Z-Space the way it should be.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2017 0
Advisor ,
Jun 18, 2017

Copy link to clipboard

Copied

A couple of additional suggestions:

In your camera settings:

1. Reduce your f stop value. It's currently 5.6 - try 1.4 or lower.

2. Increase your blur level past 100% - try 1000%

Mike A.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2017 2
New Here ,
Jun 18, 2017

Copy link to clipboard

Copied

Thank you for the extra suggestions Mike, i did give it a shot with everything else i was suggested but still nothing unfortunately , I'm going to keep trying to see if i missed some things. If not i might just scrap the whole project and start over again and get back to you guys. I did respond back to to Jose Panadero's reply if you want to read that and see if you have any other suggestions that might help in this case still. it would be much appreciated.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2017 0
Adobe Community Professional ,
Jun 20, 2017

Copy link to clipboard

Copied

If you have the Collapse Transformations option turned on for your duplicated comp, it will pull the 3d values form the layers inside rather than taking the new value.

IF that's not it, the answer is likely that there is a 2d layer somewhere in your layer stack. 2d layers will break the rendering order of 3d layers. You will need to move that 2d layer out from between the 3d layers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 20, 2017 1
Community Beginner ,
Nov 23, 2020

Copy link to clipboard

Copied

Hello. I was having the same issue. I found a solution that worked. I copied the camera into each compositions where there are 3D elements. I noticed in my case, that the main composition was considiring sub comp as "flat" like it is a projection on a plane. Once i copied the camera into the sub comp, the depth of filed came back. It's totally counter-inuitive but it worked in my case.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
New Here ,
Apr 05, 2020

Copy link to clipboard

Copied

hi mike,

thankyou very much as per your recommendation i have reduced f stop value and and try to play with zoom level it worked normally

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 05, 2020 0
Adobe Employee ,
Jul 21, 2017

Copy link to clipboard

Copied

Hi ttkymott,

Did you ever get your depth of field issue working? If so, let us know how you pulled it off.

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 21, 2017 0
Participant ,
Mar 03, 2018

Copy link to clipboard

Copied

For all coming from google, make sure your camera view is in "Active Camera". If you use "Front" or any other, it may break the DoF.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 03, 2018 1