Highlighted

After Effects freezes for a wihle after clicking a psd layer.

Explorer ,
May 01, 2020

Copy link to clipboard

Copied

Hi erveryone,

 

I encountered a nasty performance bug.

 

I have some layered psd files imported into my project. But when I select one of those layers in my timeline, then whaterver I do next(say, move layers, preview, ect), it will freeze for a while(Not Responding).

 

record.gif

I have a gif here above. You can see that after selecting one of those layers(the coin layer), no matter what I do next, it would freeze for a while.

 

This would happen to every single psd layer I have in my comp. Ah, this is so fraustrating to work with.

 

And I have done some testing. This issue happens on CC 2019 and 2020. On CC 2018, I didn't see this happen.

 

Is anybody experiencing the same? And does anybody have a solution for this? Or I have to wait for the next release when this bug is fixed? 

 

Info:I'm on windows 10, After Effects 17.0.6.

 

Any reply would be appreciated!

Aaron

TOPICS
Error or problem, Freeze or hang, Performance

Views

158

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

After Effects freezes for a wihle after clicking a psd layer.

Explorer ,
May 01, 2020

Copy link to clipboard

Copied

Hi erveryone,

 

I encountered a nasty performance bug.

 

I have some layered psd files imported into my project. But when I select one of those layers in my timeline, then whaterver I do next(say, move layers, preview, ect), it will freeze for a while(Not Responding).

 

record.gif

I have a gif here above. You can see that after selecting one of those layers(the coin layer), no matter what I do next, it would freeze for a while.

 

This would happen to every single psd layer I have in my comp. Ah, this is so fraustrating to work with.

 

And I have done some testing. This issue happens on CC 2019 and 2020. On CC 2018, I didn't see this happen.

 

Is anybody experiencing the same? And does anybody have a solution for this? Or I have to wait for the next release when this bug is fixed? 

 

Info:I'm on windows 10, After Effects 17.0.6.

 

Any reply would be appreciated!

Aaron

TOPICS
Error or problem, Freeze or hang, Performance

Views

159

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 01, 2020 0
Most Valuable Participant ,
May 01, 2020

Copy link to clipboard

Copied

And what are the PSDs made of? If there are smart objects or you use fancy layer styles along with the new compositing engine introduced in PS v20 this could easily explain things IMO. This stuff doesn't even work right in PS. So start by checking these things over there in the first place. Switching to the legacy compositing engine and re-saving the files sometimes does wonderous things already...

 

Mylenium

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 01, 2020 0
Explorer ,
May 01, 2020

Copy link to clipboard

Copied

Hi Mylenium

 

Those psd files are from my clients. Every time they would give me the large source file psd(sometimes 1 psd file can be 3-5 GB large). But every time I will prepare those layers for After Effects(remove unnecessary layers, flat out shapes, layer styles and smart obejcts). So, those would be regular layers. I really put efforts on this. After this kind of work, the psd file size usually goes down to 200-400MB, or even smaller sometimes.

 

As for the new Ps v20 compositing engine you mentioned, I think this is not really what the problem is.

I have done some testing already. Import the same prepared psd file into Ae CC2018, 2019, and 2020, and I found this issue occurs only on CC2019 and 2020. On CC2018, it works smoothly. So I think this should be a bug for After Effects.

 

Hope some Adobe offical can notice this post so that this issue can be solved in the next release. This is really frastrating to work with.

 

Thx for your reply.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 01, 2020 0