Highlighted

After Effects is Distorting My Audio - HELP!!!

Community Beginner ,
Aug 26, 2017

Copy link to clipboard

Copied

I wanted to bass boost a song so I imported it into Audacity and added all the required effects needed to bass boost it. I've used Audacity many times to do this and I made sure that the Audio didn't travel into the red area. I then exported it as a WAV file at 41hz with 32-bit PCM. Then I imported this file into After Effects and made a cool music effect to go along with the song. I didn't mess with the audio but after I rendered I noticed that the audio had become really distorted on the bass parts of the song. So I went back into after effects and noticed that the audio was red lining under the audio tab. No matter what I do the audio still redlines. I've tried different formats, i've turned the gain down, i've checked the settings for after effects and all of the sound settings seem to match up correctly in Audacity with After Effects. I don't know if there is a problem with my Macbook audio settings or even my Audacity or After Effects settings. So I really need all the help I can get.

My system is a Macbook Air 2015 running the latest version of OSX and the latest After Effects and Audacity.

It has 8GB of RAM and an i5 at 1.6ghz.

My system has no problem running any of these programs and can handle Premiere Pro and After Effects at the same time.

I've also been rendering with Adobe Media Encoder if that helps.

All my programs are the Creative Cloud 2017 editions.

Screen Shot 2017-08-26 at 8.39.44 pm.pngScreen Shot 2017-08-26 at 8.39.23 pm.png

Above is the audio area when it is playing the bass parts of the song and the second image is what my video looks like, i've also tried lowering the gain wit the sliders next to the audio area.

Any help would be greatly appreciated as I badly need this video to work.

Thanks!!!

Adobe Community Professional
Correct answer by Rick Gerard | Adobe Community Professional

If you have creative cloud I would strongly suggest that you use Audition. I know that it is properly calibrated and produces video compliant files. I don't have experience with Audacity but suspect that may be part of the problem right there.

You should also spend a little time learning about equalization and audio production. It's not something you can just grab the knobs and tweak to your liking. There are rules that must be followed if the audio is going to playback on all devices as expected.

Views

11.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

After Effects is Distorting My Audio - HELP!!!

Community Beginner ,
Aug 26, 2017

Copy link to clipboard

Copied

I wanted to bass boost a song so I imported it into Audacity and added all the required effects needed to bass boost it. I've used Audacity many times to do this and I made sure that the Audio didn't travel into the red area. I then exported it as a WAV file at 41hz with 32-bit PCM. Then I imported this file into After Effects and made a cool music effect to go along with the song. I didn't mess with the audio but after I rendered I noticed that the audio had become really distorted on the bass parts of the song. So I went back into after effects and noticed that the audio was red lining under the audio tab. No matter what I do the audio still redlines. I've tried different formats, i've turned the gain down, i've checked the settings for after effects and all of the sound settings seem to match up correctly in Audacity with After Effects. I don't know if there is a problem with my Macbook audio settings or even my Audacity or After Effects settings. So I really need all the help I can get.

My system is a Macbook Air 2015 running the latest version of OSX and the latest After Effects and Audacity.

It has 8GB of RAM and an i5 at 1.6ghz.

My system has no problem running any of these programs and can handle Premiere Pro and After Effects at the same time.

I've also been rendering with Adobe Media Encoder if that helps.

All my programs are the Creative Cloud 2017 editions.

Screen Shot 2017-08-26 at 8.39.44 pm.pngScreen Shot 2017-08-26 at 8.39.23 pm.png

Above is the audio area when it is playing the bass parts of the song and the second image is what my video looks like, i've also tried lowering the gain wit the sliders next to the audio area.

Any help would be greatly appreciated as I badly need this video to work.

Thanks!!!

Adobe Community Professional
Correct answer by Rick Gerard | Adobe Community Professional

If you have creative cloud I would strongly suggest that you use Audition. I know that it is properly calibrated and produces video compliant files. I don't have experience with Audacity but suspect that may be part of the problem right there.

You should also spend a little time learning about equalization and audio production. It's not something you can just grab the knobs and tweak to your liking. There are rules that must be followed if the audio is going to playback on all devices as expected.

Views

11.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 26, 2017 0
Adobe Community Professional ,
Aug 26, 2017

Copy link to clipboard

Copied

Cropped screenshots are not very useful for diagnosing a problem. The first thing you should do is deselect or select all layers in your composition and then press the U key twice to find all the modified properties. In your case you want to check for additional audio tracks and audio adjustments. You should also select the layers that contain audio and press the U key twice to check the waveforms.

The Boosting audio can be tricky. There is a lot more to audio production than just listening to the speakers. I should strongly suggest that you dive into Audition to do your audio mixing and stay up a bit.

The Audio panel does not change the gain of a Audio levels of a layer unless a layer is selected. You need to check the levels values in the timeline. Changing the gain of the audio track will not change the height that Audio Spectrum or Audio Waveform generates.

I'm not sure what you want here. If the waveform in the timeline looks clipped then your audio is clipping. I would check the track in Audition. If you want a different look to the Audio Spectrum effect then you need to monkey with the settings in the Effects Control Panel.

BTW, the standard for video (and audio by the way) is 48 kHz 16 bit stereo PCM WAV uncompressed. You can use 32 bit if you like but 44.1 is only the standard for legacy CD production. AE prefers the audio in this format.

Also, when using audio to drive animation I will often do a custom mix  of the audio to isolate certain frequencies or levels and render that audio track just to drive the animation. A normal audio mix is used in the production for the sound, the special track is only used to generate data for the animation.

If you can't figure it out show us a full screenshot with the modified properties and the levels and waveform of your audio layer or layers revealed and maybe we can help. I suspect that the biggest problem is your bass boost.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2017 1
Community Beginner ,
Aug 26, 2017

Copy link to clipboard

Copied

Sorry for the cropped screenshots, I'm pretty sure there aren't any additional audio tracks or adjustments and I don't own Audition, this is why I use Audacity. When using the Audio Panel I made sure the layer was selected, but it still seemed to distort, even when turned down. By the way the video is fine i'm happy with that, it's the audio that I need help with. I'm also happy with the audio spectrum effect. I've also re-exported in Audacity with 48kHz 16 bit stereo PCM WAV uncompressed and that didn't seem to help anything. My bass boost sounds fine in Audacity and doesn't distort or even touch the red zone. What do you mean by Audio clipping? I just want the Audio to not distort at all so it will sound good inside the program and when I render.

Here is a full screenshot:

Screen Shot 2017-08-27 at 4.19.42 pm.png

This is what my after effects looks like as you can see the Audio Levels and The Audio Tab are both set to their default 0.

Moving them doesn't seem to change anything. The waveforms look good to me but I don't know what to look for.

Thanks for the help so far!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2017 0
Adobe Community Professional ,
Aug 27, 2017

Copy link to clipboard

Copied

Your waveform shows me that your audio levels are too high.

Your waveform:
Screen Shot 2017-08-27 at 5.54.33 AM.png

Properly produced music track:

Screen Shot 2017-08-27 at 5.53.28 AM.png

Notice that there is a lot more empty space between the left and right channels. You don't have a lot of hard clipping but levels are way too high for video production.

Recommended average level for digital audio is -18 to - 12. Your audio should never go above -6. It looks like you need to do a little studying on audio production. If you want to really drive up the bass and still get audio that will sound  good you need to learn how to use multi band compressor limiters. Audition is a good tool for this. I don't know much about Audacity but I can tell from looking at your waveform that your audio was not correctly mixed. There are also loudness (a technical audio characteristic) values to consider when mixing and equalizing audio. It looks to me like you need to do some studying.

Lowering the audio levels in the timeline should change the look of the waveform. Try setting the audio levels to -50  and the waveform display should be much lower. If it is not then you are probably not using the latest build for your version of AE, There were some bugs in earlier builds. Make sure you are running 14.2.1 if you are on CC 2017.

Changing the levels in the audio track will not effect the way Audio Spectrum generates it's display. The effect looks at the original audio track before you make any adjustments. The only way to change that rendering order is precompose the audio track after making the adjustments and then use the pre-comp as the source for your effect.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 27, 2017 1
Community Beginner ,
Aug 27, 2017

Copy link to clipboard

Copied

Ok, so i lowered the levels to -50 but it still distorts. The waveforms have dropped very low but i'm still getting distortion. I'll re-try boosting it in Audacity but this time i'll make sure nothing goes over -6 and aim for the sweet spot between -18 to -12. I am running the latest version of After Effects which is 14.2.1.34 on CC 2017.

Here is what the Audio and Waveforms look like at -50:

Although distortion is an issue i will try again with Audacity and see if that fixes it.

Screen Shot 2017-08-28 at 8.02.20 am.png

Thanks Rick Gerard

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 27, 2017 0
Adobe Community Professional ,
Aug 27, 2017

Copy link to clipboard

Copied

If you have creative cloud I would strongly suggest that you use Audition. I know that it is properly calibrated and produces video compliant files. I don't have experience with Audacity but suspect that may be part of the problem right there.

You should also spend a little time learning about equalization and audio production. It's not something you can just grab the knobs and tweak to your liking. There are rules that must be followed if the audio is going to playback on all devices as expected.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 27, 2017 1
Community Beginner ,
Aug 27, 2017

Copy link to clipboard

Copied

So Audition is the best way to go I guess. Makes sense that all Adobe programs work well and sync all their audio properly. I'll also watch some tutorials on working with audio in audition and also learn how to use multi band compressor limiters. I'm going to try Audacity one more time and then if that doesn't work I will make the switch to Audition. I will reply and tell you my results with both programs.

Thanks for the help so far.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 27, 2017 0
LEGEND ,
Aug 27, 2017

Copy link to clipboard

Copied

Yup -  you an NOT count on After Effects to deliver good audio.  I sucks at audio.  It bites at audio.  It blows at audio. You are far better off matching up video & audio in a different application.  Since you're probably on Creative Cloud, I'd recommend Premere Pro for the task.

And don't use compressed audio.  Adobe apps, despite what the marketing weasels say, can't handle compressed audio well.  Okay, Audition does.  But since you'd use it to convert an mp3 to wav or aiff anyway, you should already know that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 27, 2017 0
Community Beginner ,
Aug 27, 2017

Copy link to clipboard

Copied

ok

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 27, 2017 0
New Here ,
Aug 05, 2018

Copy link to clipboard

Copied

I know exactly what your problem is, just turn off the sound for all the other layers but the audio file. For some odd reason the layers are effecting the audio.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 05, 2018 0
New Here ,
Apr 03, 2020

Copy link to clipboard

Copied

I wish that was the case, but i have the same problem when the only layer in existence is the audio file....

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2020 0
New Here ,
Apr 26, 2020

Copy link to clipboard

Copied

I am assuming at that you found the problem, as I found my solution. I am just assuming that the audio frame rate is different than the composition rate. So if your compostion is 24 frames than the preview pannel needs to be set to the same. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 26, 2020 0
New Here ,
Apr 27, 2020

Copy link to clipboard

Copied

I don't understand how they could be different if the frame rate is set when you first create the project. Also where would that setting be? I've gone through all of them and can't see how you would change the frame rate for just a preview window. When my audio previews just by itelf it's fine, it's only in the composition that it won't ever sound correct...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 27, 2020 0
New Here ,
Sep 08, 2020

Copy link to clipboard

Copied

PatrikSweden71_0-1599597424478.png

When I checked the box for cache before playback, my problems disapeared.

Try that! 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 08, 2020 0