Highlighted

After Effects performance very easily bogged down on fast computer with ideal drive setup

New Here ,
Apr 29, 2020

Copy link to clipboard

Copied

Hi.

 

As far as I understand, I have a very decent PC for After Effects and yet I run into performance issues frequently. Sometimes I have to sit and wait for a 60 second 1080x1080px video to render for 15 minutes without any effects being applied.

 

I've also noticed that areas that have been rendered already are going missing when I get towards the end of the composition. IE: It's rendering what's coming up and purging footage that has already been rendered, making the program pretty useless.

 

Here's some more info about my PC

OS: Windows 10 (fully up to date)

CPU: Intel 7700k running at 4.5ghz

RAM: 32gb DDR4 (26gb assigned to After Effects)

GPU: GTX1080

Boot SSD: Samsung 970 Evo NVME SSD

Project Drive: Samsung 850 Pro SATA SSD

Cache Drive: Samsung 850 Evo SATA SSD

 

Here's what I've done to try and fix the problem

Check background processes and CPU usage

Purge After Effects cache and memory

Increased the amount of Texture Memory available for GPU rendering to 4096MB

Ensured Hardware Accelerate Composition, Layer and Footage Panels is ticked

Enabled Hardware Accelerated Decoding

Checked that my project is using the '8 bpc' colour setting

 

 

Here's a more detailed explanation of what I'm experiencing

First Problem:

I have a composition which contains six 1920x1080 30fps pieces of mp4 footage, each playing at the same time but masked. The composition size is 1080x1080, so it's rendering at that resolution. However it renders slower than 1 frame per second. The footage currently has no effects being applied.

 

Second Problem:

Footage that has already been rendered with either the green (RAM) or blue (CACHE) render marker is switching back to grey half way through rendering. I've already cleared the cache and ensured there is ample room so I have no idea why I'm seeing this behaviour.

 

Any help or advice would be appreciated!

Topics

Error or problem, Performance, Preview

Views

95

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

After Effects performance very easily bogged down on fast computer with ideal drive setup

New Here ,
Apr 29, 2020

Copy link to clipboard

Copied

Hi.

 

As far as I understand, I have a very decent PC for After Effects and yet I run into performance issues frequently. Sometimes I have to sit and wait for a 60 second 1080x1080px video to render for 15 minutes without any effects being applied.

 

I've also noticed that areas that have been rendered already are going missing when I get towards the end of the composition. IE: It's rendering what's coming up and purging footage that has already been rendered, making the program pretty useless.

 

Here's some more info about my PC

OS: Windows 10 (fully up to date)

CPU: Intel 7700k running at 4.5ghz

RAM: 32gb DDR4 (26gb assigned to After Effects)

GPU: GTX1080

Boot SSD: Samsung 970 Evo NVME SSD

Project Drive: Samsung 850 Pro SATA SSD

Cache Drive: Samsung 850 Evo SATA SSD

 

Here's what I've done to try and fix the problem

Check background processes and CPU usage

Purge After Effects cache and memory

Increased the amount of Texture Memory available for GPU rendering to 4096MB

Ensured Hardware Accelerate Composition, Layer and Footage Panels is ticked

Enabled Hardware Accelerated Decoding

Checked that my project is using the '8 bpc' colour setting

 

 

Here's a more detailed explanation of what I'm experiencing

First Problem:

I have a composition which contains six 1920x1080 30fps pieces of mp4 footage, each playing at the same time but masked. The composition size is 1080x1080, so it's rendering at that resolution. However it renders slower than 1 frame per second. The footage currently has no effects being applied.

 

Second Problem:

Footage that has already been rendered with either the green (RAM) or blue (CACHE) render marker is switching back to grey half way through rendering. I've already cleared the cache and ensured there is ample room so I have no idea why I'm seeing this behaviour.

 

Any help or advice would be appreciated!

Topics

Error or problem, Performance, Preview

Views

96

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Apr 29, 2020

Copy link to clipboard

Copied

Simple and short answer: Simply turn off GPU acceleration. Your computer may have plenty of RAM, but even the most beefy GPUs only have so much. Of course running out on that front may still invalidate caches just like having to decode compressed footage over and over may take its toll. You know, shuffling around buffers just clogs up the PCI bus and your seemingly convoluted drive setup won't do much to improve matters on that front, either. in the long run of course you may have to figure out what is causing this lag, but that's beyond simple advice on a forum. Figuring out driver and hardware conflicts can take days and weeks down to physically having to re-plug your hardware to different slots.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 30, 2020

Copy link to clipboard

Copied

Thanks for the advice. I'll test with GPU acceleration turned off. I don't believe the drive set up would affect performance. It should increase performance given that this is the recommended drive configuration. See quote below from Puget Systems. I've also tested the drives using Samsung's tool and can see that they're all running at their rated speed so there's no bottleneck happening with the drives (ie a SATA3 SSD plugged into a SATA2 port).

"What storage configuration works best in After Effects?

While you could get by with just a single drive, we recommend a two to four hard drive configuration depending on your budget and desired performance level:

  1. Primary Drive - OS/Software (SSD) - Includes your operating system and the base After Effects installation. An SSD is highly recommended as it will greatly improve how fast the OS and programs startup, but there is usually not much of a performance benefit to upgrade to a faster NVMe drive.
  2. Secondary Drive - Project Files (SSD/M.2 NVMe) - If possible, it is a good idea to separate your project files and disk cache onto a secondary drive. For most users a standard SSD will work fine, but in some situations a NVMe drive may be useful.
  3. Optional Tertiary Drive - Dedicated Media Cache/Scratch (SSD/M.2 NVMe) - Using a dedicated SSD for your disk cache can significantly improve performance when playing and scrubbing through compositions. Upgrading to an even faster NVMe drive can give some performance gains, most notably allowing the disk cache to be written on average around 20% faster.
  4. Optional Storage Drive (Platter) - For long term storage where the high speed of SSDs is typically not required, a larger traditional platter hard drive is a good choice as they are still much cheaper per GB than SSDs."

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 30, 2020

Copy link to clipboard

Copied

Also honestly I disagree with your opinion about me posting for advice on this forum. The whole point of this forum is to find people who are experiencing similar issues who may be able to offer assistance on the issue. Why else would this be the 'Adobe Support Community' forum?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...