Highlighted

After Effects random green frames with imported screen capture footage

Community Beginner ,
May 17, 2018

Copy link to clipboard

Copied

Hey guys,

I'm importing some screen capture footage recorded on mobile devices into After Effects (mp4), but there seems to be random green frames.. At first i thought it may be just  problem when previewing in AE, so I did a quick test render and the output file still shows these random green frames.

The footage plays back perfectly in any other app including Premiere, so I tried editing in Premiere then sending to AE via Dynamic Link but the random green frames still show in AE (and then the Dynamic Linked comp in Premiere). I also tried rendering in Premiere then importing the new rendered file into AE, but still the same issue.

I thought it was maybe an issue with the footage that the iPad had generated, but I also tried using an Android device and the same problem.

What could be causing this? Any ideas on how I can fix it?

At the moment it seems i'm restricted to editing this footage in Premiere as After Effects just does not seem to like this screen capture footage

Any help would be much appreciated.

I think mobile devices record with VFR (Variable framerate).

In AE, in project window, try "interpret footage" / "conform to framerate"

2018-05-17 15_30_32-.png

If it doesn't work, try exporting from premiere to Media Encoder as image sequence (png tga or tiff) and import as image sequence in AE

Hope this helps

TOPICS
Preview

Views

29.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

After Effects random green frames with imported screen capture footage

Community Beginner ,
May 17, 2018

Copy link to clipboard

Copied

Hey guys,

I'm importing some screen capture footage recorded on mobile devices into After Effects (mp4), but there seems to be random green frames.. At first i thought it may be just  problem when previewing in AE, so I did a quick test render and the output file still shows these random green frames.

The footage plays back perfectly in any other app including Premiere, so I tried editing in Premiere then sending to AE via Dynamic Link but the random green frames still show in AE (and then the Dynamic Linked comp in Premiere). I also tried rendering in Premiere then importing the new rendered file into AE, but still the same issue.

I thought it was maybe an issue with the footage that the iPad had generated, but I also tried using an Android device and the same problem.

What could be causing this? Any ideas on how I can fix it?

At the moment it seems i'm restricted to editing this footage in Premiere as After Effects just does not seem to like this screen capture footage

Any help would be much appreciated.

I think mobile devices record with VFR (Variable framerate).

In AE, in project window, try "interpret footage" / "conform to framerate"

2018-05-17 15_30_32-.png

If it doesn't work, try exporting from premiere to Media Encoder as image sequence (png tga or tiff) and import as image sequence in AE

Hope this helps

TOPICS
Preview

Views

29.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 17, 2018 3
Participant ,
May 17, 2018

Copy link to clipboard

Copied

I think mobile devices record with VFR (Variable framerate).

In AE, in project window, try "interpret footage" / "conform to framerate"

2018-05-17 15_30_32-.png

If it doesn't work, try exporting from premiere to Media Encoder as image sequence (png tga or tiff) and import as image sequence in AE

Hope this helps

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 17, 2018 1
Explorer ,
May 25, 2018

Copy link to clipboard

Copied

Guys,

I just had the same issue (randon green frames present themselves using screen capture footage. In addition, I also had random frames from elsewhere in the footage. I did the conform to framerate thing, and it did take care of the random green frames, but not from elsewhere. So, I opened up the screen capture footage in Quicktime and exported as a .mov and imported into AE. Voila! No random screens!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 25, 2018 2
New Here ,
Nov 14, 2019

Copy link to clipboard

Copied

Where can I download QuickTime 🥺

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 14, 2019 0
Community Beginner ,
May 29, 2018

Copy link to clipboard

Copied

Thanks for your reply. You're a star

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 29, 2018 0
Participant ,
May 29, 2018

Copy link to clipboard

Copied

Welcome John 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 29, 2018 0
Explorer ,
May 29, 2018

Copy link to clipboard

Copied

Oops, John. After further observation, I noticed the random green frames began showing up again. Sorry for jumping the gun.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 29, 2018 1
Explorer ,
May 30, 2018

Copy link to clipboard

Copied

Okay. I have figured out an alternative to the correct answer above which may be easier. Here's what I did on my Mac. Don't bother converting the footage into another format. Just keep it native .mp4 or .mov.

If you have these random green screens popup in your variable rate screen capture footage after importing to AE, do these steps:

  1. Right-click on the footage within your AE project window.
  2. scroll down to "interpret footage"
  3. Select Main
  4. At the bottom of the dialogue box that comes up, select "more options"
  5. Under variable frame rate mode, select "smooth video motion".
  6. That's it!
  7. Now, your audio will be effed up, but, you can extract that audio from your screen capture if you absolutely need it, and place into your project as an audio file by itself. Some timing adjusts may need to occur in your project timeline.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 30, 2018 12
LEGEND ,
May 30, 2018

Copy link to clipboard

Copied

Or --

since you're working with professional applications that expect professionally-made footage --

DON'T DO SCREEN CAPTURES IN VARIABLE FRAME RATES

And use good capture codecs, too!  Or actually LEARN something about After Effects!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 30, 2018 1
Community Beginner ,
May 30, 2018

Copy link to clipboard

Copied

Thanks  sholderman1

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 30, 2018 0
Explorer ,
May 30, 2018

Copy link to clipboard

Copied

I agree wholeheartedly, Dave, DON'T USE VARIABLE FRAME RATE VIDEO (UGH! like iPhone footage for example). During this process, we actually found a screen capture software by Debut that let's you specify the frame rate! We will obviously choose 30FPS!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 30, 2018 1
New Here ,
Jun 15, 2019

Copy link to clipboard

Copied

sholderman You are Genius!!! THANX A LOT

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 15, 2019 0
New Here ,
Jul 09, 2019

Copy link to clipboard

Copied

So.. some of us are just trying to take footage from work in progress app development to present. maybe you can recommend a capture program for iOS and Android that app devs can use to grab footage to present to clients, or internally instead of responding with some condescending answer. If you aren't gonna contribute knowledge, why would you reply to just lambaste? Is your life that sad?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2019 4
Community Beginner ,
Jul 16, 2019

Copy link to clipboard

Copied

I'm sure the work around will work great...once I am able to check the "More Options" box...any idea as to why I can't click on it? It is currently grayed out for me and no manner of checking/unchecking seems to release the button for me.

Screen Shot 2019-07-16 at 8.43.25 AM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 16, 2019 0
Community Beginner ,
Jul 16, 2019

Copy link to clipboard

Copied

I did find a thread that suggested to try this fix before adding the video to a timeline/comp. But a quick test of this suggestion did nothing to change the state of the "More Options..." button.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 16, 2019 0
Community Beginner ,
Jul 16, 2019

Copy link to clipboard

Copied

I resolved the issue -- the files my client provided were .webm and in converting to a usable format in VLC, my videos were turned into .m4v. After Effects apparently does not like these files much. I simply edited the files names to .mp4 and after reloading each file, they were able to be set to "smooth motion".

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 16, 2019 0
New Here ,
Jul 16, 2019

Copy link to clipboard

Copied

Thanks @sholderman1 . I have solved this problem in your way.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 16, 2019 0
New Here ,
Oct 21, 2019

Copy link to clipboard

Copied

shut the fuċk up dave all you do on here is talk shįt

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 21, 2019 2
New Here ,
Oct 30, 2019

Copy link to clipboard

Copied

Your are a genius!!! I have searched this solution a lot, thanks!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 30, 2019 0
New Here ,
Dec 06, 2019

Copy link to clipboard

Copied

I think you need to calm down. You can't expect everyone to have a good PC or even have a capture card for that matter. If you want to talk about "Proffesional Footage" then why have ya'll been suggesting Quicktime? Why not a beefier software like OBS or Camtasia. 

Personally I think OBS is the best. I use it with my elgato capture card to record 600+ fps gameplay. 

 

The fact is it does not matter how you capture your screen. 

 

Record with a variable frame rate or not it doesnt matter. Changing the footage to smooth video motion will fix this problem without any stupid Quicktime workaround. Infact quicktime gives you the option to save as audio only in the event that changing your footage to smooth video motion ruins your audio.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 06, 2019 1
New Here ,
Feb 14, 2020

Copy link to clipboard

Copied

This is actually the only comment that helped. Thanks @Lenio!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 14, 2020 1
New Here ,
Feb 20, 2020

Copy link to clipboard

Copied

I don’t understand why you have to be aggressive, not the first time you do this. Please revisit this behavior.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2020 0
New Here ,
Aug 06, 2020

Copy link to clipboard

Copied

THANK YOU SO MUCH

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2020 0
New Here ,
Aug 19, 2020

Copy link to clipboard

Copied

god bless you! realy i dont know how to say thank you because of this big help ! i asked about it from many people but no one knows. any way thanks a lot

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 19, 2020 0
New Here ,
Jun 25, 2018

Copy link to clipboard

Copied

I had this issue with a screen recording from my boss' iPhone.

Initially, I tried removing the green frames individually (very very time consuming), but they always reappeared in the final render.

I then found a tutorial that suggested using Handbrake to set a constant frame rate and encoding the footage. It worked beautifully. Remember to set the frame rate to your composition's frame rate. And remember to ensure that variable frame rate is turned off before you record. Full instructions can be found here: How To Record Tutorials with QuickTime Player.

Best of luck.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2018 2
Evolross LATEST
New Here ,
Sep 10, 2020

Copy link to clipboard

Copied

I did some QuickTime screen captures on a 4K monitor. Even just capturing a rectangle of less than half made the files not work correctly in AE. I had to re-open the "Saved" screen captures in QuickTime and Export → 1080p. Then they worked fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 10, 2020 0