Highlighted

After Effects uses all my RAM then crashes.

Community Beginner ,
Nov 18, 2017

Copy link to clipboard

Copied

Since I updated to AE CC 2018, I'm no longer able to render or prerender small files.
After Effects will start out with the render process and overtime my RAM usage will go up until it hits 90% (Starts at 14%).
At 90% AE will tell me that it's out of memory and after what feels like a thousand error messages it will tell me to shut down the program to prevent information loss.

I can't work with this program in any way anymore, it worked way better AND faster on my old PC with only 8GB of RAM....

Specs: Ryzen 1700x; Radeon RX Vega 64; 32GB RAM; And it's painfully slow..

TOPICS
Crash

Views

13.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

After Effects uses all my RAM then crashes.

Community Beginner ,
Nov 18, 2017

Copy link to clipboard

Copied

Since I updated to AE CC 2018, I'm no longer able to render or prerender small files.
After Effects will start out with the render process and overtime my RAM usage will go up until it hits 90% (Starts at 14%).
At 90% AE will tell me that it's out of memory and after what feels like a thousand error messages it will tell me to shut down the program to prevent information loss.

I can't work with this program in any way anymore, it worked way better AND faster on my old PC with only 8GB of RAM....

Specs: Ryzen 1700x; Radeon RX Vega 64; 32GB RAM; And it's painfully slow..

TOPICS
Crash

Views

13.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 18, 2017 1
Community Beginner ,
Nov 18, 2017

Copy link to clipboard

Copied

Hmmm, doesn't sound good. What's your RAM setting in Ae and Pr?

Edit --> Preferences --> Memory

There you can assign half or almost all of your RAM to Ae, Pr and a few other Adobe programs. Just be sure to increase the number for the Adobe programs, not for "reserved for other applications"...

Ae_crashes_01.jpg

Ae_crashes_02.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 18, 2017 0
Adobe Community Professional ,
Nov 18, 2017

Copy link to clipboard

Copied

Hi, How much space you have in disk for cache

You can do the following settings to avoid the issue -

First of all clear All Memory & Disk Cache by going to menu Edit > Purge > All Memory & Disk Cache...

Make sure enable disk cache is checked and try to choose the location on SSD or any other drive than the drive which have After Effects & OS installed and also empty the disk cache & Media cache.

Screen Shot 2017-11-19 at 12.35.14 AM.png

In the preferences > Memory tab set the RAM reserved for other applications to a lower number if your not using any dynamic link with PS or PR. Use higher number if your using dynamic linking or other with other softwares simultaneously. You can also check the option to Reduce cache size.

Screen Shot 2017-11-19 at 12.35.28 AM.png

If this does not resolve the issue, do let us the OS your working with & composition settings like resolution, Frame rate, type of 3D render etc.

Vishu Aggarwal

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 18, 2017 0
Community Beginner ,
Nov 18, 2017

Copy link to clipboard

Copied

Those are all the settings I started out with.
For some reason I can't render anything at this point, it's just going to render the first frame.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 18, 2017 0
Community Beginner ,
Nov 18, 2017

Copy link to clipboard

Copied

I let it for almost 10 minutes now and you can clearly see it just doesn't work, the program doesn't crash however it just doesn't start working.

AE Render.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 18, 2017 0
Adobe Community Professional ,
Nov 18, 2017

Copy link to clipboard

Copied

Did you try rendering using Adobe Media Encoder?? if not please try Adobe Media Encoder.

And are you using any three-party plugins.

Vishu Aggarwal

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 18, 2017 0
Community Beginner ,
Nov 19, 2017

Copy link to clipboard

Copied

Good point, I'll give uninstalling Digital Anarchys Flicker Free a try!

Rendering in AME works for 3 frames and then stops the same way like it does in AE.
Second time trying: Not able to Export -> Add to AME Queue (Program starts up, but that's all)
BUT this time after unchecking my "Remove Grain" Effect it seems to render just fine in AE?
No changes were done to PlugIns until this step and since my PC is kinda powerful, could it be a problem with CC 2018?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 19, 2017 0
Community Beginner ,
Nov 19, 2017

Copy link to clipboard

Copied

EDIT: I rendered the Video without the Remove Grain Effect to then import it back into AE and put the effect on the footage again.

The Remove Grain Effect in the first footage was applied to an adjustment layer underneath a mask to only affect the night sky as seen in my picture above.
The trees and mountains were masked out and above the Adjustment Layer maybe that got AE into some problems?
I'll just try the whole thing manually with masking out the night sky from 2 already rendered clips (should work right? )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 19, 2017 0
Adobe Community Professional ,
Nov 19, 2017

Copy link to clipboard

Copied

I did a basic test by applying Remove Grain effects on adjustment layer & keep one video below the adjustment layer & one video masked with pen tool above the adjustment layer. Render settings set to Quicktime with codec animation & also test in H.264 & AE rendered the clip fine.

I did this test on Mac OS 10.13.1 with AE 2018 (ver 15.0).

" I'll just try the whole thing manually with masking out the night sky from 2 already rendered clips (should work right? "

Not sure, there can we many know things sometimes cause issues like video Codec, frame-rate, settings in Remove Grain effect, etc. Give it a try may be in your case masking caused a issue.

Vishu Aggarwal

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 19, 2017 0
New Here ,
Jul 09, 2020

Copy link to clipboard

Copied

When using after effects for some time system freezes and results in (BSOD) Blue screen of death and restarts itself.it has happened 25 times since  using after effects for some time.my system RAM is 8 GB.And have 256gb SSD.please tell me what is the problem

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2020 0
Adobe Employee ,
Dec 19, 2017

Copy link to clipboard

Copied

Solve this issue yet, FabianV? Let us know.

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2017 0
New Here ,
Jul 16, 2018

Copy link to clipboard

Copied

I do have the same issue and it's not resolved yet, using 80% of ram, 20% of CPU and 200GB of cache on SSD drive.

recently most of my projects do have the same problem, yet some of them uses 100% CPU and some of them uses only 2cors of CPU, i can't figure it out but mostly projects of shape layers or 3D layers render only using ram

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 16, 2018 0
Adobe Community Professional ,
Jul 16, 2018

Copy link to clipboard

Copied

Any 3rd party plugins?

If this issue is reproducible then I suggest you send a Bug Report (BR) and include the assets along with the AEP - commit to a Collect Files routine. Then double check the issue is reproducible after Collect Files before sending in the BR and the AEP+assets.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 16, 2018 0
New Here ,
Jul 18, 2018

Copy link to clipboard

Copied

thank you for your response,

please excuse me for being late to reply as i was experimenting with the new update.

no there were no 3rd party plugins, it was only a 4K comp with a slightly larger PSD file in 3D, pre-rendered backgrounds and  texts in 3d animated with blur, opacity and position. video codec: cineform.

i have managed to render this file in two stages. the PSD file and the backgrounds in one render and then the texts in an other render. using adobe media encoder doesn't help at all. not all of the projects are crashing but slow rendering is also a huge problem too.

but the fact that this is not the only project i have a problem with it not using the CPU but only the ram is bothering me.

!

1.jpg

2.jpg

3.jpg

4.jpg

i can't upload the project as i don't have the permission to share the files of the project.

Thank you again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 18, 2018 1
Community Beginner ,
Jan 21, 2019

Copy link to clipboard

Copied

Set ram in ae to a three quarters of what you have , set disk cash to half of what’s available .  Don’t have project and cash disk on same drive , make cash a Ssd

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 21, 2019 0