Highlighted

After effects warning: Can't write to font cache directory

Community Beginner ,
Mar 17, 2020

Copy link to clipboard

Copied

Hello,

 

I can't open any version of After effects anymore on my machine. I have version 17.0.5, 16.1.3 and 13.1.4 installed. They worked fine yesterday, today i get and error while the startup screen loads:

 

After effects warning: Can't write to font cache directory

And after that:

After effects error: string memory leak (83 :: 2)

After effects can't continue: unexpected failure during application startup

 

All my other programs (Premiere, Illustrator etc.) work fine, and I have not changed anything to my setup. The only thing I changed yesterday is upgrading to the newest Illustrator version. Going back to the older version did not change anything.

 

I've tried reinstalling, rebooting and checking for any corrupt fonts.

I'm running Windows 10.

 

After Effects is my main tool and i can't do any work without it. Can someone point me in the right direction?

 

Thanks!

 

Michiel

Topics

Crash, Error or problem

Views

906

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

After effects warning: Can't write to font cache directory

Community Beginner ,
Mar 17, 2020

Copy link to clipboard

Copied

Hello,

 

I can't open any version of After effects anymore on my machine. I have version 17.0.5, 16.1.3 and 13.1.4 installed. They worked fine yesterday, today i get and error while the startup screen loads:

 

After effects warning: Can't write to font cache directory

And after that:

After effects error: string memory leak (83 :: 2)

After effects can't continue: unexpected failure during application startup

 

All my other programs (Premiere, Illustrator etc.) work fine, and I have not changed anything to my setup. The only thing I changed yesterday is upgrading to the newest Illustrator version. Going back to the older version did not change anything.

 

I've tried reinstalling, rebooting and checking for any corrupt fonts.

I'm running Windows 10.

 

After Effects is my main tool and i can't do any work without it. Can someone point me in the right direction?

 

Thanks!

 

Michiel

Topics

Crash, Error or problem

Views

907

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Mar 18, 2020

Copy link to clipboard

Copied

Hi Michiel,

 

Thanks for reaching out. It looks like a permissions related issue to me.

Try providing the permissions to the folder at the following locations:

C:\Users\Username\AppData\Local\Adobe

C:\Users\Username\AppData\Roaming\Adobe

Here are the steps to provide permissions: https://www.windowscentral.com/how-take-ownership-files-and-folders-windows-10

 

Let us know if it brings any change.

 

Thanks,

Nishu

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 18, 2020

Copy link to clipboard

Copied

Hello Nishu,

 

Thanks for your help. I have tried to change the permissions but this did not solve my problem.

I have found a simple solution, for some reason I have to run all my After Effects versions as 'administrator'.

Browse to your after effects folder.

C:\Program Files\Adobe\Adobe After Effects CC 2019\Support Files

Right click on AfterFx.exe, choose 'Run as administrator'.

 

I don't understand why this has suddenly changed, or why this is specific only for After Effects. But it works.

Hopefully it helps anyone else who has this problem. 

 

Michiel

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 18, 2020

Copy link to clipboard

Copied

I'm having the same issue.   I've been very vocal about this on other threads.  This is a huge problem and Adobe is doign NOTHING to solve it.  I'm going to lose a client over this issue in already hard times.   Adobe needs to figure out what the hell their last update did to after effects and the premire bridge.  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 18, 2020

Copy link to clipboard

Copied

Did my solution solve your problem?

It is completely unclear to me how this has happened overnight.
Maybe it is the result of an automatic update by Windows?

 

Michiel

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 18, 2020

Copy link to clipboard

Copied

There was an automatic adobe after effects update two nights ago is the
only thing I've traced it back too.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Mar 24, 2020

Copy link to clipboard

Copied

Hi Michiel,

I am not sure if Windows update can cause this. Would you mind letting us know if your user account is managed by your organization or you are working on your home computer?

 

Thanks,

Nishu 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 24, 2020

Copy link to clipboard

Copied

Hello Nishu,

 

I am working from my studio computer, so the account is managed by myself. 

Running the program as administrator solved it for me, but I have no clue how this error could have happened after a simple reboot. I am always running the same (and only) account on this machine.

If there is anything I can do to help solve the issue for other users, let me know.

 

Michiel

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jun 20, 2020

Copy link to clipboard

Copied

I'm also having the same problem and none of the solution presented here have worked for me.

 

I've tried completely uninstalling AE and then deleting all AE sub folders but AE still gives the same error message

 

After effects warning: Can't write to font cache directory

 

How do we fix this???

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jun 22, 2020

Copy link to clipboard

Copied

Those solution don't work.  In fact, I just got off the phone with Adobe Support and after remotely accessing my machine I was told the only solution was a complete uninstall of ALL my Adobe products followed by a complete reinstall.  I declined that option because I was also told NONE of my presets could be saved and I plan to replace this computer soon anyway.  It's clear that the actual problem is the latest Adobe updates have massively corrupted the Windows registry.  What's even more upsetting than the lost time is Adobe's engineers cannot offer a better solution that burning everything down and starting over

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
HettyFFF LATEST
New Here ,
Jun 29, 2020

Copy link to clipboard

Copied

Please Adobe, solve this problem? It is now the end of June, none of the here mentioned solutions (already a complain during a long period...) works. I got this problem only now for the first time, after an automatic update of a few days ago. I cannot use After Effects, that's pretty disturbing (to say the least). Uninstalling en reinstalling won't help either. Windows10. Other programs work fine. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 28, 2020

Copy link to clipboard

Copied

Exact same problem with Mac OsX.
Suddenly none of my three versions are unable to launch at all. All other Adobe programs working fine. Uninstalled all AE's and re-installed and nothing happened.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...