Highlighted

Audio in AE not switching between speakers and headphones

Community Beginner ,
Jan 30, 2019

Copy link to clipboard

Copied

Audio in AE not switching between speakers and headphones.

(iMacPro mcOS Mojave 10.14.1, Adobe After Effects CC2018 15.1.2)

When using After Effects in the past and previewing a comp the audio would automatically switch between speakers and headphones if and when I plugged in the headphone jack.  When using the iMacPro 'normally' - viewing YouTube clips online or playing a Quicktime movie or using iTunes for example - the audio automatically switches from speakers to headphones when you plug the headphones in - as you would expect. But this does not happen when in After Effects.  I now have to go to After Effects Preferences, Audio Hardware, and change the Default Output Settings settings from speakers to headphones. But then if I unplug the headphones jack, the audio output does not automatically switch back to the speakers as it used to (and should). So I have to go back into the Preferences Audio Hardware and switch it back to speakers! This is crazy and never used to be a problem.

I have look into all preference settings both for the iMac and in After Effects and spoken to some IT colleagues with no joy. As I have tried all I can think of, and the problem does not present itself when using the iMac's usual functions, it seems to me like it might be an issue between the latest version of CC After Effects and the Mac's latest Operating System (CC2018 15.1.2 and the iMacPro's OS Mojave 10.14.1). But I can find no mention of the problem when searching online.

Can anyone help?

Views

15.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Audio in AE not switching between speakers and headphones

Community Beginner ,
Jan 30, 2019

Copy link to clipboard

Copied

Audio in AE not switching between speakers and headphones.

(iMacPro mcOS Mojave 10.14.1, Adobe After Effects CC2018 15.1.2)

When using After Effects in the past and previewing a comp the audio would automatically switch between speakers and headphones if and when I plugged in the headphone jack.  When using the iMacPro 'normally' - viewing YouTube clips online or playing a Quicktime movie or using iTunes for example - the audio automatically switches from speakers to headphones when you plug the headphones in - as you would expect. But this does not happen when in After Effects.  I now have to go to After Effects Preferences, Audio Hardware, and change the Default Output Settings settings from speakers to headphones. But then if I unplug the headphones jack, the audio output does not automatically switch back to the speakers as it used to (and should). So I have to go back into the Preferences Audio Hardware and switch it back to speakers! This is crazy and never used to be a problem.

I have look into all preference settings both for the iMac and in After Effects and spoken to some IT colleagues with no joy. As I have tried all I can think of, and the problem does not present itself when using the iMac's usual functions, it seems to me like it might be an issue between the latest version of CC After Effects and the Mac's latest Operating System (CC2018 15.1.2 and the iMacPro's OS Mojave 10.14.1). But I can find no mention of the problem when searching online.

Can anyone help?

Views

15.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 30, 2019 1
Adobe Community Professional ,
Jan 30, 2019

Copy link to clipboard

Copied

First,, AE 15.1.2 isn't the latest version so the latest version is the AE CC2019 16.0.1

Second i test it on my iMac AE 15.1.2 (Mojave) with a wired Headphone and it's work perfect without any issue.

but i'm  little confusing since you must have only one output setting which is the built in option

Screen Shot 2019-01-30 at 6.06.37 PM.png

so did you have any external sound interface or so ?

because switching between headphone and internal speaker it's a OS proceeder and not related to AE

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 30, 2019 1
Community Beginner ,
Jan 30, 2019

Copy link to clipboard

Copied

Hi OussK,

Thanks for your response.

In my After Effects Audio Hardware > Default Output I do not have the 'Built-in Output' as an option (as in the picture you supplied).  I only have an 'iMac Pro Speakers' option when the headphones are not plugged in, and when I plug them in I have a second option 'External Headphones', but still no 'Built-in Output' option. (I have no external sound interface by the way.)

Also - in the Mac's System Preferences > Sound settings > Output, there is no 'Internal Speakers - built in' option, only the option 'iMac Pro Speakers - built in', and when the headphones are plugged in they come up as a second choice as External Headphones (this is the same when you select the 'speaker icon in the drop down menu).

Even though I have no external sound interface, maybe the Mac/OS is somehow seeing the iMac Pro Speakers as external speakers?

I'm starting to think it is an iMac Pro issue (where the 'iMac Pro Speakers' somehow mean you no longer get the 'Built-in Output' as a setting.

P

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 30, 2019 0
Community Beginner ,
Jan 30, 2019

Copy link to clipboard

Copied

Screenshot 2019-01-30 at 17.09.55.png

Also - I just found the above online and I think it explains the issue.  Read it and see what you think. Thought I was going mad!

Pete

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 30, 2019 0
Adobe Community Professional ,
Jan 30, 2019

Copy link to clipboard

Copied

Yes it look like it's a iMac Pro issue, so hope if the iMac pro owner can confirm this, really i don't own this model.

anyway did you test the latest AE version (16.0.1) if it have the same issue?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 30, 2019 2
Community Beginner ,
Jan 30, 2019

Copy link to clipboard

Copied

I will update to the latest AE version and the latest Mac OS Mojave.  But unfortunately I have to wait for my IT department to do that.

Thanks for your help and suggestions. Much appreciated.

I will let you know how I get on.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 30, 2019 0
Participant ,
Mar 20, 2019

Copy link to clipboard

Copied

Same problem here and I'm on the latest AE version and on Windows.

Every time I switch my headphones (Bluetooth) on or off I have to go into settings and change the Default output.

Frustrating.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 20, 2019 1
Participant ,
Mar 20, 2019

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 20, 2019 0
Community Beginner ,
Apr 26, 2019

Copy link to clipboard

Copied

Same problem here. Windows 10, updated all Adobe Suite when it came out a short time ago. I'm use a Steinberg UR242 interface and have updated drivers and firmware. This is a really irritating issue but I can't find a fix for it anywhere.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 26, 2019 0
New Here ,
Jun 17, 2019

Copy link to clipboard

Copied

this solved it for me: https://reid.io/ytHm3P

Make sure you set external headphones as the first preference in the Aggregate Device.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2019 4
New Here ,
Dec 10, 2019

Copy link to clipboard

Copied

Thank you so much for posting this! This issue was driving me crazy but this Aggregate Device work-around solved it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 10, 2019 0
New Here ,
Feb 24, 2020

Copy link to clipboard

Copied

7 months on and still super helpful. 

Thanks for posting this. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2020 0
New Here ,
Apr 29, 2020

Copy link to clipboard

Copied

Thank you for posting this. I'm on a new 2020 MBP 16in with Catalina (<--- not a fan). Been having this issue since day one and finally got fed-up enough to dig for a solution.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 29, 2020 0