Highlighted

Black Background when rendering with Media Encoder?

New Here ,
Jun 09, 2020

Copy link to clipboard

Copied

I am working with the latest AE version 17.0.2. Whenever I add a comp for rendering (mp4) to the media encoder , the background is black. When I render it, the clip shows only certain elements (w/ alpha channel) but without the background layer. I can never change that behaviour, no matter how many white solids I add to the comp.

I noticed that with several reboots of both software and computer the clip looks suddenly normal again and I can render it. What is the problem? Can somebody l help me?

Would be grateful for any advice!

TOPICS
Dynamic link, Error or problem, FAQ, How to, Import and export

Views

543

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Black Background when rendering with Media Encoder?

New Here ,
Jun 09, 2020

Copy link to clipboard

Copied

I am working with the latest AE version 17.0.2. Whenever I add a comp for rendering (mp4) to the media encoder , the background is black. When I render it, the clip shows only certain elements (w/ alpha channel) but without the background layer. I can never change that behaviour, no matter how many white solids I add to the comp.

I noticed that with several reboots of both software and computer the clip looks suddenly normal again and I can render it. What is the problem? Can somebody l help me?

Would be grateful for any advice!

TOPICS
Dynamic link, Error or problem, FAQ, How to, Import and export

Views

544

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 09, 2020 0
Adobe Community Professional ,
Jun 09, 2020

Copy link to clipboard

Copied

If you set the background color of a comp and render an MP4, the background will always be black. 

 

If you want a solid color you have to put some pixels on the bottom layer. The easiest way to do that is to add a colored solid. If you have any questions or doubts about rendering the background color just turn on the transparency grid in the Comp Panel. If you can see the checkerboard anywhere then that area will render as black when you render an H.264 file. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 09, 2020 1
New Here ,
Jun 09, 2020

Copy link to clipboard

Copied

Thanks for your reply. The thing is, I already added white color solids to the bottom layer of the comp and it still does not render or display it. Then, all of a sudden, after several reboots of the software and computer, it shows and renders the correct picture. Did anyone come across that kind of mistake, too?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 09, 2020 0
Adobe Community Professional ,
Jun 09, 2020

Copy link to clipboard

Copied

If you make a change in a comp and it does not display in the Comp Panel - purge everything using the edit menu.

 

If you add a comp to the Media Encoder a unique copy of that comp stored in the Media Encoder cue. If you make changes to the comp in After Effects, save the changes, then go to the Media Encoder and duplicate the existing comp and render it none of the changes will appear in the new video because the original comp from the first Add to Media Encoder action will be used. You must add the comp to the AME again.

 

Your problem sounds more like the memory and disk cache did not clear when you made the changes.

If you add a solid to the bottom of a comp and the layer is set to be a guide layer it will not render and you will still have transparency. 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 09, 2020 0