Highlighted

cached preview needs 2 or more frames to play back

New Here ,
May 31, 2016

Copy link to clipboard

Copied

Okay i know that this question has been asked probably a million times by now, but since the adobe support is absolute trash it looks like I'm going to have to ask again here to see if i can get any help regarding this issue. I keep getting an error saying "after effects error: cached preview needs 2 or more frames to play back".

No matter what i seem to try it keeps coming up. I cant figure out at all why it is doing it. I've done literally everything i can think of, and Ive done multiple reinstalls, however no matter what i try it keeps happening. At first when i do a reinstall nothing will happen, i can have maybe one comp and it'll work fine, but the minute i go above one comp/precomp the error pops up, and then will continue to appear on every single project regardless of the size after that.

Im starting to regret getting involved with this program, as this error or bug makes the program virtually unusable.

Does anyone have any sort of solution to this issue?

Adobe Community Professional
Correct answer by Szalam | Adobe Community Professional

For persistent causes of this issue, today's bug fix update should solve it.

See the Adobe blog post for more information: A June 2017 Update to After Effects CC Is Now Available | Creative Cloud blog by Adobe

Please let us know if it works for you!

TOPICS
Error or problem

Views

39.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

cached preview needs 2 or more frames to play back

New Here ,
May 31, 2016

Copy link to clipboard

Copied

Okay i know that this question has been asked probably a million times by now, but since the adobe support is absolute trash it looks like I'm going to have to ask again here to see if i can get any help regarding this issue. I keep getting an error saying "after effects error: cached preview needs 2 or more frames to play back".

No matter what i seem to try it keeps coming up. I cant figure out at all why it is doing it. I've done literally everything i can think of, and Ive done multiple reinstalls, however no matter what i try it keeps happening. At first when i do a reinstall nothing will happen, i can have maybe one comp and it'll work fine, but the minute i go above one comp/precomp the error pops up, and then will continue to appear on every single project regardless of the size after that.

Im starting to regret getting involved with this program, as this error or bug makes the program virtually unusable.

Does anyone have any sort of solution to this issue?

Adobe Community Professional
Correct answer by Szalam | Adobe Community Professional

For persistent causes of this issue, today's bug fix update should solve it.

See the Adobe blog post for more information: A June 2017 Update to After Effects CC Is Now Available | Creative Cloud blog by Adobe

Please let us know if it works for you!

TOPICS
Error or problem

Views

39.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 31, 2016 0
Adobe Community Professional ,
May 31, 2016

Copy link to clipboard

Copied

What, exact, version and build number of AE are you using? Is it 13.7.2? What OS?

Can you show us a screenshot of your full preview panel?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 31, 2016 0
New Here ,
Jun 01, 2016

Copy link to clipboard

Copied

I'm on the latest mac os

after effects version 13.7.2.3

you'll see the composition I'm trying to preview is literally only 2 audio files, and every time i try to preview it i get that

after effects error: cached preview needs 2 or more frames to play back. Driving me absolutely insane.

Screen Shot 2016-06-01 at 12.45.58 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2016 0
Explorer ,
Jun 01, 2016

Copy link to clipboard

Copied

I've been having the exact same problem like clockwork. I finally went and trashed all of my adobe ae cache files and preferences (note: not CLEAR CACHE as in from the AE preferences but actually deleted from the mac Library). Sucked because I needed to then reconfigure everything else again but so far it seems to have cleared up the issue.

My suspicion is some how old preferences (there were folders for at least five different versions in my Library folder) were getting confused. I recall when I upgraded to the most recent version of AE it said it had preference discrepancies and asked me which I wanted to use. I don't remember what I choose but apparently it wasn't the right one.

Hope this helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2016 1
Adobe Community Professional ,
Jun 01, 2016

Copy link to clipboard

Copied

Can we see the rest of your settings in the preview panel?

Also, can we see a screenshot of your memory settings?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2016 0
New Here ,
Jun 01, 2016

Copy link to clipboard

Copied

Screen Shot 2016-06-01 at 1.07.06 PM.pngScreen Shot 2016-06-01 at 1.05.28 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2016 0
New Here ,
Jun 01, 2016

Copy link to clipboard

Copied

where can i find this folder?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2016 0
Explorer ,
Jun 01, 2016

Copy link to clipboard

Copied

The preference folder? It's in your Library (which is hidden so you'd have to be able to unhide it) /Library/Preferences/Adobe/After Effects/

I use a tool called MainMenu to be able to see hidden files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2016 0
Contributor ,
Dec 01, 2016

Copy link to clipboard

Copied

Same Problem

Screen Shot 2016-12-01 at 11.12.39 AM.png

Screen Shot 2016-12-01 at 11.13.04 AM.jpg

Screen Shot 2016-12-01 at 11.13.48 AM.png

Screen Shot 2016-12-01 at 11.14.22 AM.png

Screen Shot 2016-12-01 at 11.14.54 AM.png

Screen Shot 2016-12-01 at 11.15.02 AM.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 01, 2016 0
Most Valuable Participant ,
Dec 01, 2016

Copy link to clipboard

Copied

first, update your application. you should be using 14.0.1

does this happen after you restart the application, computer?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 01, 2016 0
Contributor ,
Dec 01, 2016

Copy link to clipboard

Copied

Updated to this version:

Screen Shot 2016-12-01 at 12.36.09 PM.png

Happened with both Num-0 using my settings from above and this time it initially happened using space bar.

Screen Shot 2016-12-01 at 12.36.57 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 01, 2016 0
Most Valuable Participant ,
Dec 01, 2016

Copy link to clipboard

Copied

a few suggestions for this unpredictable annoying bug from recent history:

1. preferences -> Media and Disk Cache -> Empty Disk Cache

2.Preferences > Memory, and make sure "Reduce Cache size when system is low on memory" is NOT checked.

3. reset your preferences: Reset After Effects Preferences

4. try to see if Chrome browser in the background changes anything (no joke)

5. try updating your GPU driver

try this video there is maybe a gem in there: Quick Tip: Fixing cached preview needs 2 or more frames to playback. - YouTube

if something does fix it, please let us know. this is one of the annoying bugs out there that keeps coming back.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 01, 2016 5
New Here ,
Apr 13, 2017

Copy link to clipboard

Copied

I fixed the issue with solution:

1. preferences -> Media and Disk Cache -> Empty Disk Cache

2.Preferences > Memory, and make sure "Reduce Cache size when system is low on memory" is NOT checked.

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 13, 2017 1
Community Beginner ,
Apr 25, 2017

Copy link to clipboard

Copied

Hey dude. Do all things from this topic and from other. Still same problem, ram preview doesnt work. In any project same results. I get windows 10, i7 4.0 mghz 16 ram. help plizzzzz

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 25, 2017 0
Adobe Community Professional ,
May 02, 2017

Copy link to clipboard

Copied

What, exact, version of AE are you using?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 02, 2017 0
New Here ,
May 22, 2017

Copy link to clipboard

Copied

Hi,

Still having trouble - getting the same error message and have gone through settings mentioned above. I am working with the latest verion (14.2.0.198) any updates on why this is occuring?

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 22, 2017 0
New Here ,
Nov 11, 2019

Copy link to clipboard

Copied

ooooh man, it doesn't work for me 🥺 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 11, 2019 0
New Here ,
Apr 13, 2017

Copy link to clipboard

Copied

I have a same problems, I don't know how to fix it, I try it all of your solution, still not work, please help, thanks

Screen Shot 2017-04-14 at 3.13.54 AM.pngScreen Shot 2017-04-14 at 3.14.12 AM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 13, 2017 0
Adobe Community Professional ,
Apr 14, 2017

Copy link to clipboard

Copied

Does it play back if you delete the Element effect from that layer?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 14, 2017 0
New Here ,
Aug 03, 2017

Copy link to clipboard

Copied

Yes I was also getting the same error as "After Effects error: cached preview needs 2 or more frames to playback".

But I read a lot about this error and what other people talk about it. Actually the solution for this error is different for everyone.You have to check all the possibilities such as :

1. preferences -> Media and Disk Cache -> Empty Disk Cache

2.Preferences > Memory, and make sure "Reduce Cache size when system is low on memory" is NOT checked.

The above solutions are already discussed in the same forum.

For getting the error fixed please check out below mentioned points :

  • Check your system configuration because running heavy projects in after effects may lead to this error. For detail information about this please check After Effects System Requirements .

  • For improving the performance of the After Effects you can take a look at Improve performance in After Effects . After reading this page you will definitely get ample amount of knowledge about how to deal with After Effects while working on heavy projects.

I hope this will help you

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 03, 2017 0
New Here ,
May 29, 2017

Copy link to clipboard

Copied

I have some problem like you and has fixed it. Use this tutorial from Elisenda:

I fixed the issue with solution:

1. preferences -> Media and Disk Cache -> Empty Disk Cache

2.Preferences > Memory, and make sure "Reduce Cache size when system is low on memory" is NOT checked.

And then you must increase RAM Available for adobe in Memory menu, i increase to 6 Gb and then the problem is solved.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 29, 2017 1
Adobe Community Professional ,
Jun 13, 2017

Copy link to clipboard

Copied

For persistent causes of this issue, today's bug fix update should solve it.

See the Adobe blog post for more information: A June 2017 Update to After Effects CC Is Now Available | Creative Cloud blog by Adobe

Please let us know if it works for you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 13, 2017 0
New Here ,
Jul 07, 2017

Copy link to clipboard

Copied

I found 16 different ways to fix this error.

1. Purge RAM

2. Empty Disk Cache

3. Change RAM Reserved for Other Applications

4. Close Out Unnecessary Applications

5. Change Preview Quality

6. Increase Disk Cache Size

7. Uncheck ‘Reduce Cache Size When System is Low on Memory’

8. Change Disk Cache Location

9. Save and Close After Effects

10. Clean Database and Cache

11. Set Work Area to the Appropriate Duration

12. Set Your Region of Interest

13. Optimize Your Effects

14. Organize Your Project

15. Render Instead of Previewing

16. Optimize Your Machine.

I actually wrote a pretty extensive blog post about how to do each one of these steps. Hopefully it helps! https://www.schoolofmotion.com/blog/cached-preview

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 07, 2017 2
Adobe Community Professional ,
Jul 07, 2017

Copy link to clipboard

Copied

That's a very useful post!

One thing though: You should probably update your blog post to mention that most causes of this error message are fixed in the recent update to AE.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 07, 2017 0