Highlighted

Cached Preview needs 2 or more frames to playback?

Community Beginner ,
Feb 04, 2017

Copy link to clipboard

Copied

Hi, I have been struggling with this After Effects for 2 days now and badly need to fix this.

When I try to preview what I am working on in my composition by pressing my space bar and clicking on the play button, I get this pop up message: "Cached Preview needs 2 or more frames to playback". When I click OK, I usually get the following pop-up: "Fresh layer cache check-out failed".

I cannot seem to get more than one frame in green or blue (cached). I have already tried Purging the memory, cleaning the database & cache and emptying my disk cache. I have also tried working on my other after effects files ( which all worked fine a few days ago) and they all have trouble previewing. I also tried working on earlier versions of After Effects and that either did not change my situation or could not open my files (not compatible versions, which is confusing to me because I have switched versions in the past when having a problem in AE and never had files not open because of version compatibility).

My max disk cache size is 75, which has always worked fine for me, with 12 GB RAM available for AE.

My "Reduce cache size when system is low on memory" is NOT checked and I have no other programs running.

Screen Shot 2017-02-04 at 4.11.04 PM.png

Screen Shot 2017-02-04 at 4.30.17 PM.png

Running latest version of After Effects 2017, 14.0.1.5

It's my first time posting a question on here so if I'm missing any useful info, please let me know.

I see a lot of people asking this same question on forums and have tried many of the tricks and tips, even the strange or very general ones, cleaned up a ton and restarted the computer and the program many times. None of the forums questions seemed to have been answered with a clear answer though, so hoping someone can help me as the Adobe chat will only open in two days and I have clients waiting for their work.

Thank you

Correct answer by charlie20 | Community Beginner

Hi Kevin, I did not get an answer from Adobe no.

The only solution I have is obviously to empty disc cache, cache memory, etc, the basics. Also downloading new version, previous version, and redoing those clearing steps over and over. It eventually stopped giving me that message. Not sure it's the best solution however as it is frustrating and time consuming.

Views

5.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Cached Preview needs 2 or more frames to playback?

Community Beginner ,
Feb 04, 2017

Copy link to clipboard

Copied

Hi, I have been struggling with this After Effects for 2 days now and badly need to fix this.

When I try to preview what I am working on in my composition by pressing my space bar and clicking on the play button, I get this pop up message: "Cached Preview needs 2 or more frames to playback". When I click OK, I usually get the following pop-up: "Fresh layer cache check-out failed".

I cannot seem to get more than one frame in green or blue (cached). I have already tried Purging the memory, cleaning the database & cache and emptying my disk cache. I have also tried working on my other after effects files ( which all worked fine a few days ago) and they all have trouble previewing. I also tried working on earlier versions of After Effects and that either did not change my situation or could not open my files (not compatible versions, which is confusing to me because I have switched versions in the past when having a problem in AE and never had files not open because of version compatibility).

My max disk cache size is 75, which has always worked fine for me, with 12 GB RAM available for AE.

My "Reduce cache size when system is low on memory" is NOT checked and I have no other programs running.

Screen Shot 2017-02-04 at 4.11.04 PM.png

Screen Shot 2017-02-04 at 4.30.17 PM.png

Running latest version of After Effects 2017, 14.0.1.5

It's my first time posting a question on here so if I'm missing any useful info, please let me know.

I see a lot of people asking this same question on forums and have tried many of the tricks and tips, even the strange or very general ones, cleaned up a ton and restarted the computer and the program many times. None of the forums questions seemed to have been answered with a clear answer though, so hoping someone can help me as the Adobe chat will only open in two days and I have clients waiting for their work.

Thank you

Correct answer by charlie20 | Community Beginner

Hi Kevin, I did not get an answer from Adobe no.

The only solution I have is obviously to empty disc cache, cache memory, etc, the basics. Also downloading new version, previous version, and redoing those clearing steps over and over. It eventually stopped giving me that message. Not sure it's the best solution however as it is frustrating and time consuming.

Views

5.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 04, 2017 0
Adobe Employee ,
Mar 03, 2017

Copy link to clipboard

Copied

Hi CharlieG,

Did you ever get assistance from Adobe Support for your issue? Please let us know the outcome so that we know you're OK and for the benefit of others.

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 03, 2017 0
Community Beginner ,
Mar 04, 2017

Copy link to clipboard

Copied

Hi Kevin, I did not get an answer from Adobe no.

The only solution I have is obviously to empty disc cache, cache memory, etc, the basics. Also downloading new version, previous version, and redoing those clearing steps over and over. It eventually stopped giving me that message. Not sure it's the best solution however as it is frustrating and time consuming.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 04, 2017 0
Adobe Employee ,
Mar 06, 2017

Copy link to clipboard

Copied

Thanks for the feedback Charlie G.

Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 06, 2017 0
New Here ,
Mar 09, 2017

Copy link to clipboard

Copied

Hi Kevin,

I'm having exactly the same problem as Charlie. I have reinstalled AE and purged the memory and image cache a hundred times.

I am running the latest version of AE from my creative cloud account and this is my system information:

System.png

This is my AE memory allocation:

Memory.png

As I was typing this message AE crashed on me with the attached selection of error messages.

Error6.pngError5.pngError4.pngError3.pngError2.pngError1.png

Please can you help?

Many thanks

Peter

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 09, 2017 0
Adobe Employee ,
Mar 09, 2017

Copy link to clipboard

Copied

Hi Peter,

What kind of footage and effects are you using?

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 09, 2017 0
New Here ,
Mar 09, 2017

Copy link to clipboard

Copied

Thanks for getting back to me.

This time it was just text within AE. Previously it was simple 2D

Illustrator imports.

No effects.

Peter

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 09, 2017 0
Adobe Community Professional ,
Mar 13, 2017

Copy link to clipboard

Copied

What renderer is your composition set to use?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 13, 2017 0
New Here ,
Mar 16, 2017

Copy link to clipboard

Copied

I'm not even rendering yet. This is under RAM preview.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 16, 2017 0
Adobe Community Professional ,
Mar 16, 2017

Copy link to clipboard

Copied

peterw24682225  wrote

I'm not even rendering yet. This is under RAM preview.

Previews in AE are rendered and stored in RAM. Heck, even just to see something in your composition panel, AE needs to render something.

Therefore, what renderer your composition is using matters immensely.

There are three options: Ray-traced (a way to create 3d geometry from AE-native layers - technically obsolete, but still present for compatability reasons), Cinema 4D (for creating 3d geometry from native AE layers - like the ray-traced renderer, but without the GPU requirements), and the classic renderer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 16, 2017 0
New Here ,
Mar 16, 2017

Copy link to clipboard

Copied

Sorry, I see what you mean.

The answer to you question is: Classic

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 16, 2017 0
New Here ,
Mar 22, 2017

Copy link to clipboard

Copied

I'm having the trouble again. Any news on a fix?

Many thanks,

Peter

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 22, 2017 0
New Here ,
May 05, 2017

Copy link to clipboard

Copied

plzz can you help me i was trying to edit an video but when i just start my after effect and put my files on it its saying Schermafbeelding 2017-05-05 om 19.52.44.pngplzz can you help me idk what the problem is??

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 05, 2017 0
Adobe Community Professional ,
May 08, 2017

Copy link to clipboard

Copied

In your case, it might be something screwy in that particular video file. Try transcoding it with the Adobe Media Encoder into a production codec (like Cineform or DNxHD) and then import the new file into After Effects. Please let us know if it works.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 08, 2017 0
Adobe Community Professional ,
Jun 13, 2017

Copy link to clipboard

Copied

For persistent causes of this issue, today's bug fix update should solve it.

See the Adobe blog post for more information: A June 2017 Update to After Effects CC Is Now Available | Creative Cloud blog by Adobe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 13, 2017 0
New Here ,
Jun 16, 2017

Copy link to clipboard

Copied

I'm having the exact same problem as the original poster, exact situation and I've tried all the same potential fixes. Nothing works. New update didn't help at all. It's been happening every now and then with a variety of projects actually, it's infuriating. The only thing I can think of is it's happening with a comp with Red Giant Universe on it, but it's happened before without it, and doesn't get fixed if I remove it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 16, 2017 0
New Here ,
Jun 17, 2017

Copy link to clipboard

Copied

Fixed it! Preferences > Memory, and make sure "Reduce Cache size when system is low on memory" is NOT checked. Worked for me anyway when absolutely nothing else did.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2017 1
New Here ,
Jul 19, 2017

Copy link to clipboard

Copied

I am also only using text with After Effects and getting the error, with the classic renderer. However, I can avoid the error message if I begin my preview from 00:00:01 instead of 00:00:00.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 19, 2017 0
New Here ,
Jan 24, 2020

Copy link to clipboard

Copied

Try to stretch your Work Area more than 2 frames.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 24, 2020 0