Highlighted

Content Aware Fill Aborted

New Here ,
Aug 19, 2020

Copy link to clipboard

Copied

I have this project where it is a bunch of picutres one frame after eachother to mimic a video. They have a little bit different arm motion in them, so i want to use the puppet tool and content aware fill behind the subject so i can adjust the arms to make them flow a lot better. When i mask around the subject I want to place the content aware fill behind i keep getting this message: "After Effects Warning: All target frames are blank. The content-Aware Fill layer generation for comp(___) has been aborted."

 

I am not sure what is causing this to happen as in the fill target box I can see what is supposed to be filled in. 

TOPICS
Error or problem

Views

43

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Content Aware Fill Aborted

New Here ,
Aug 19, 2020

Copy link to clipboard

Copied

I have this project where it is a bunch of picutres one frame after eachother to mimic a video. They have a little bit different arm motion in them, so i want to use the puppet tool and content aware fill behind the subject so i can adjust the arms to make them flow a lot better. When i mask around the subject I want to place the content aware fill behind i keep getting this message: "After Effects Warning: All target frames are blank. The content-Aware Fill layer generation for comp(___) has been aborted."

 

I am not sure what is causing this to happen as in the fill target box I can see what is supposed to be filled in. 

TOPICS
Error or problem

Views

44

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 19, 2020 0
Adobe Community Professional ,
Aug 19, 2020

Copy link to clipboard

Copied

It sounds like your workflow is seriously flawed. 

 

You can't animate any of the transform properties of a layer that has Puppet Pin applied. The mesh is generated when you set the first pin and if the layer moves, the mesh doesn't. You have to Pre-compose.

 

Content-Aware Fill only works with Video. It will not work with still images, it requires a hole in the layer,  and it requires some fairly consistent pixels inside and outside of the hole you create with a mask or a track matte. If you are trying to fill in some kind of hole made in a layer when you apply CAF then you will need to pre-compose that layer and let CAF work on the hole.

 

If your image sequence is a is sequenced layers and the video arms are moving then Puppet Pin cannot be used to control the movement of the arms. The moving arms will foul that up.

 

If I had some arms that I wanted to move with Puppet Pin, the arms would be the only thing on the layer, nothing on the layer would move until I added puppet pin, and the background would be on a separate layer.

 

If I am misunderstanding your project then we need screenshots showing what you are trying to do on the layers. Select the layers, press the u key twice, then drag or embed the screenshot to the forum so we can understand what you are trying to do.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 19, 2020 0
New Here ,
Aug 20, 2020

Copy link to clipboard

Copied

I have found a way to get around this. I am duplicating the picture layer, masking out my subject, using the puppet tool on that cut out, and then using the clone stamp to remove the subject out of the behind duplicated layer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 20, 2020 0