Highlighted

Disappearing object after pressing "Aplly Export" from Mocha to AE

New Here ,
Jun 21, 2020

Copy link to clipboard

Copied

I have a strange problem. Namely, I need to paste the inscription on the surface.
The object is in PNG.

I go to MOCHA. There is a path and there are no problems so far.

I'm going back to AE.
I press Create Track Data. Points are shown where they belong.

Export Option -> Corner Pin.

And now it begins.
Layer Export is ... I choose a file in PNG.

All data regarding surface movement is where it should be, only the object 
disappears somewhere beyond the screen. I was thinking about what was happening to him. It turns out that
I have to add another "transform" option to it and manually
move it out of the screen where it is supposed to be. Anyone know maybe what's going on?
TOPICS
Error or problem, How to, User interface or workspaces

Views

52

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Disappearing object after pressing "Aplly Export" from Mocha to AE

New Here ,
Jun 21, 2020

Copy link to clipboard

Copied

I have a strange problem. Namely, I need to paste the inscription on the surface.
The object is in PNG.

I go to MOCHA. There is a path and there are no problems so far.

I'm going back to AE.
I press Create Track Data. Points are shown where they belong.

Export Option -> Corner Pin.

And now it begins.
Layer Export is ... I choose a file in PNG.

All data regarding surface movement is where it should be, only the object 
disappears somewhere beyond the screen. I was thinking about what was happening to him. It turns out that
I have to add another "transform" option to it and manually
move it out of the screen where it is supposed to be. Anyone know maybe what's going on?
TOPICS
Error or problem, How to, User interface or workspaces

Views

53

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 21, 2020 0
Adobe Community Professional ,
Jun 21, 2020

Copy link to clipboard

Copied

Try reseting or setting at 00, 00 (X and Y axis) the Anchor Point in layer after create track data.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 21, 2020 0
Adobe Community Professional ,
Jun 22, 2020

Copy link to clipboard

Copied

I am not sure I completely follow your workflow. The current workflow for Corner Pin tracking in Mocha:

  • Add Mocha AE to a layer, click on the MOCHA icon to open Mocha
  • Add a spline, adjust the surface, track, verify the track is good and the surface behaves properly, and if there are more than layers it is a good idea to name the layers in Mocha
  • Save and return to AE
  • Select Create Track Data and choose the appropriate Layer from the popup
  • Select the proper export option and choose a layer that is the same size as the comp with no Layer/Transform property changes and apply.

I suspect the last step is where the error is. If your layer is not the same size as the comp, which should also be the same size as the footage you track, the layer will fly off into the wrong position.

 

If your Replacement PNG file is not the same size as the comp use the Transform effect to Fit the PNG file to the comp, pre-compose moving all attributes to the new comp, then export the Mocha Data to the nested comp.

 

If that does not fix the problem we need screenshots that show all the modified properties of all the layers that are giving you problems. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2020 0