Highlighted

Error with a proxy: "Cached Preview needs 2 or more frames to playback."

Participant ,
Nov 02, 2020

Copy link to clipboard

Copied

I have what I think is a pretty straightforward test project. I have two comps with one nested in the other. The containing comp has footage under the graphics precomp. The precomp is 3D layer.

Screen Shot 2020-11-02 at 6.51.01 PM.png

I am reading the User Guide cover-to-cover, and on page 95 I'm learning about pre-rendering comps. The guide says, "An alternative to replacing the composition with the movie is to use the rendered movie as a proxy for the nested composition."

 

I'm curious about the alternative, and there are no links or instructions. I found the section on proxies (starting on pg 126), and I learned how to make one. So I performed these steps...

1) I right-clicked on the "graphics" comp in the Composition panel and selected Create Proxy > Movie...

2) This put the file in the Render Queue and I clicked "Render."

 

Now this happens when I try to play the video from the containing comp with the proxy enabled...

Screen Shot 2020-11-02 at 6.56.55 PM.png

What is happening, and how do I fix this?

 

My system today:

Mac Pro 3.33GHz 12-core (mid-2010)

32 GB RAM

Sapphire Pulse Radeon 580 RX (8 GB VRAM)

macOS Mojave 10.14.5

Version 17.5.1 Build 47 fixes the bug!

TOPICS
How to

Views

108

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Error with a proxy: "Cached Preview needs 2 or more frames to playback."

Participant ,
Nov 02, 2020

Copy link to clipboard

Copied

I have what I think is a pretty straightforward test project. I have two comps with one nested in the other. The containing comp has footage under the graphics precomp. The precomp is 3D layer.

Screen Shot 2020-11-02 at 6.51.01 PM.png

I am reading the User Guide cover-to-cover, and on page 95 I'm learning about pre-rendering comps. The guide says, "An alternative to replacing the composition with the movie is to use the rendered movie as a proxy for the nested composition."

 

I'm curious about the alternative, and there are no links or instructions. I found the section on proxies (starting on pg 126), and I learned how to make one. So I performed these steps...

1) I right-clicked on the "graphics" comp in the Composition panel and selected Create Proxy > Movie...

2) This put the file in the Render Queue and I clicked "Render."

 

Now this happens when I try to play the video from the containing comp with the proxy enabled...

Screen Shot 2020-11-02 at 6.56.55 PM.png

What is happening, and how do I fix this?

 

My system today:

Mac Pro 3.33GHz 12-core (mid-2010)

32 GB RAM

Sapphire Pulse Radeon 580 RX (8 GB VRAM)

macOS Mojave 10.14.5

Version 17.5.1 Build 47 fixes the bug!

TOPICS
How to

Views

109

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 02, 2020 0
Adobe Community Professional ,
Nov 02, 2020

Copy link to clipboard

Copied

Creating proxy must not affect the render preview, anyway try to show us your render preview settings, also try to reduce the quality of your preview to half or quarter and see if this can help you 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 02, 2020 0
Participant ,
Nov 02, 2020

Copy link to clipboard

Copied

OussK, thank you for your reply.

 

Isn't the purpose of a proxy to make render previews faster?

 

As you suggested, I changed the preview quality to half and quarter. With half, I still get the "Cached Preview needs 2 or more frames to playback" error message, but with quarter the preview works. Why would reducing the preview quality eliminate this particular error message?

 

Here are my preview settings (let me know if you meant something else)...

Screen Shot 2020-11-02 at 8.46.10 PM.pngScreen Shot 2020-11-02 at 8.46.02 PM.pngScreen Shot 2020-11-02 at 8.45.56 PM.png

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 02, 2020 0
Adobe Community Professional ,
Nov 03, 2020

Copy link to clipboard

Copied

Which version of After Effects are you running?

 

Does the 2-frame error message go away if the Proxy is disabled?

 

Have you tried to purge the RAM cache from the Edit pull down menu?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2020 0
Participant ,
Nov 03, 2020

Copy link to clipboard

Copied

Hi Warren. Thanks for your help!

 

I'm running the latest version, which is v17.5.0.

 

Yes, the error message goes away when I disable the proxy.

 

I didn't try purging the RAM cache from the Edit menu. Just tried it. I get the "2-frame" error unless I either disable the proxy or switch to a quarter resolution Preview.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2020 0
Adobe Community Professional ,
Nov 03, 2020

Copy link to clipboard

Copied

To answer an earlier question, yes, Comp Proxies are supposed to make previews faster as AE is just loading the frame from the rendered proxy file rather than rendering the frame of the layered Comp and loading it into RAM.

 

So, something is causing an unexpected 2-Frame playback error.   (It, of course, should only appear if you've set the Work Area to one frame.)

 

I was thinking it could be a version 14.5 bug, but I just tried setting a Comp Proxy on my end and it's working as expected.

 

It looks like you're using the Lossless with Alpha Output Module (which is usually fine when setting Comp Proxies that need to maintain the Comp transparency).  You could try Apple ProRes4444 with Alpha instead.  Or, if you don't need transparency, you could try Lossless instead or switch to Apple ProRes422 HQ.  It might also be worth trying Apple ProRes422 Proxy which is the lightest weight of the ProRes options, but while it will have good picture quality it has a low peak signal-noise ratio (PSNR) and Comp Proxies should be disabled when rendering high-resolution output with ProRes422 Proxy.

 

You could also try disabling the Comp Proxy in the Project panel, import the rendered movie file, and then place it in front of the nested Comp that it's a proxy for in the containing Comp (also, hide the visibility of the nested Comp).  Then, see how that behaves when you do your preview.

 

In addition to purging memory in After Effects, you can also purge memory in Terminal.  Sometimes relaunching AE and/or restarting can resolve the 2-Frame error message when it appears when it shouldn't.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2020 0
Participant ,
Nov 03, 2020

Copy link to clipboard

Copied

Thank you again for your response!

The export settings I used were what came up automatically when I selected "Create Proxy > Movie...". It's a draft-quality QuickTime Animation movie, which seems appropriate since the precomp is only text and shape layers:

Screen Shot 2020-11-03 at 4.14.50 PM.png

 

I tried your suggestion and imported the rendered movie file. Because it's a half-resolution draft, I had to scale it up 200%. That was no problem, but then repositioning it with the same movement was not so easy. More importantly, even with the Preview resolution set to full I am now able to easily Preview from the timeline using this method. And the moment I enable the proxied precomp, I get the 2-frame error message again.

Screen Shot 2020-11-03 at 4.24.34 PM.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2020 0
Adobe Community Professional ,
Nov 03, 2020

Copy link to clipboard

Copied

If the nested Comp is animated, make a duplicate in the Timeline and then hold Option while you drag and drop the Comp Proxy mov file to the Comp.  This will replace the duplicate nested Comp with the movie.

 

You are, obviously (and unfortunately), experiencing unexpected behavior with Preview when a Proxy is enabled.

 

For what it's worth, Comp Proxies can be low-resolution to speed up work on a slower computer (or even faster computer one) or high resolution to speed high resolution renders when it gets to crunch time.

 

I would still try a ProRes422 Proxy clip.  You can set this in the Render Queue under Post Render Actions or just render it and use the File pulldown menu.

 

Post-render actions
https://helpx.adobe.com/ca/after-effects/user-guide.html/ca/after-effects/using/basics-rendering-exp...

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2020 0
Participant ,
Nov 03, 2020

Copy link to clipboard

Copied

Thanks so much for the tip on Option dragging the proxy movie to replace the comp. I didn't realize it would work so well since I still have to scale it up, but it actually works very well. Scaling it up 200% makes it fit perfectly.

 

I tried ProRes422 Proxy, but it doesn't stop the 2-frame error. It also has the problem of not having an RGB+Alpha option so there's a black background instead of transparency.

I was already using the "Set Proxy" Post-Render action, but that's for pointing it out.

I'm not sure whether I should mark your response as correct since you've given me a decent workaround or just keep this open in case we someday find the proper solution to zap the bug. For now I think I'll keep it open, but I really appreciate your contributions!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2020 0
Participant ,
Nov 03, 2020

Copy link to clipboard

Copied

(That was supposed to say, "... thanks for pointing it out.")

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2020 0
Adobe Community Professional ,
Nov 04, 2020

Copy link to clipboard

Copied

I'd say use the workaround, but keep this support thread open.  Someone may come along with "I clicked _____ and it worked again!"  Or, something like that.

 

Another thing to try is moving your Preferences file to the desktop.  If you haven't done this before, use the "Reveal Preferences in Finder" button in the General Preferences to go to that file.  Close After Effects, then move the file to the Desktop.  Launch AE and then try enabling the Proxy again.

 

 

 

-Warren

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2020 1
Participant ,
Nov 04, 2020

Copy link to clipboard

Copied

Thank you! I just tried moving the Prefs. No change. Just for the record.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2020 0
Participant ,
Nov 18, 2020

Copy link to clipboard

Copied

Version 17.5.1 Build 47 fixes the bug!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 18, 2020 0