Highlighted

Exporting WebM with a transparent background and glow

Community Beginner ,
Mar 18, 2019

Copy link to clipboard

Copied

So, I made alerts for my Twitch channel awhile back that were perfect, but now I can't remember how I exported them. I want a WebM that when exported it supports varying levels of opacity of transparency so that it exports looking like this:

export like this.png

Not like this:

ends up like this.png

I need it to be WebM so that's it supported by the website I'm uploading my alerts to (Streamlabs).

I'm using Adobe Media Encoder to export it, here are the settings I thought would work:

export settings 1.png

Let me know how I can make this work.

Just to clarify: I want the background to be transparent and have a glow still on some objects.

I just want to vouch this fix. Got a webm with alpha. File was still a bit bigger than expected. (3.2mb) on a 2 second transition, but I am sure I could have tweeked it. My assumption here is the author has not updated the adobe exchange to the latest version and some change in the version is hiding the alpha checkbox. By going back to v14.3 and using legacy install from creators website I was able to get the desired result. Thank you for the fix. I'll stay on this version until I know there is an update to the plug-in.SharedScreenshot.jpg

Views

33.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Exporting WebM with a transparent background and glow

Community Beginner ,
Mar 18, 2019

Copy link to clipboard

Copied

So, I made alerts for my Twitch channel awhile back that were perfect, but now I can't remember how I exported them. I want a WebM that when exported it supports varying levels of opacity of transparency so that it exports looking like this:

export like this.png

Not like this:

ends up like this.png

I need it to be WebM so that's it supported by the website I'm uploading my alerts to (Streamlabs).

I'm using Adobe Media Encoder to export it, here are the settings I thought would work:

export settings 1.png

Let me know how I can make this work.

Just to clarify: I want the background to be transparent and have a glow still on some objects.

I just want to vouch this fix. Got a webm with alpha. File was still a bit bigger than expected. (3.2mb) on a 2 second transition, but I am sure I could have tweeked it. My assumption here is the author has not updated the adobe exchange to the latest version and some change in the version is hiding the alpha checkbox. By going back to v14.3 and using legacy install from creators website I was able to get the desired result. Thank you for the fix. I'll stay on this version until I know there is an update to the plug-in.SharedScreenshot.jpg

Views

33.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 18, 2019 1
Adobe Community Professional ,
Mar 18, 2019

Copy link to clipboard

Copied

you must select the Include alpha channel from the video settings

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 18, 2019 1
Community Beginner ,
Mar 21, 2019

Copy link to clipboard

Copied

But that's the thing. I tried that, but that second picture is what happens when I export it, even with include alpha channel checked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 21, 2019 0
Adobe Employee ,
Mar 21, 2019

Copy link to clipboard

Copied

WebM format doesn't support Alpha channels. So, use any format that supports alpha like Quicktime and then convert it to WebM.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 21, 2019 0
Community Beginner ,
Mar 21, 2019

Copy link to clipboard

Copied

I figured that's what I did last time. Do you have any recommendations on free websites/programs for converting video files?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 21, 2019 0
Adobe Employee ,
Mar 22, 2019

Copy link to clipboard

Copied

Use Format Factory for Windows or Handbrake.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 22, 2019 0
Community Beginner ,
Jul 08, 2019

Copy link to clipboard

Copied

A tad misleading this statement.

Alpha Channel - wiki

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 08, 2019 0
New Here ,
Aug 05, 2019

Copy link to clipboard

Copied

Of course it does. That's the format used for rendering for example on streaming platforms and alpha channel is mandatory for most projects.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 05, 2019 0
Community Beginner ,
Feb 13, 2020

Copy link to clipboard

Copied

That button doesn't seem to exist in AME 2020... All video examples I can find have that check box Media Encoder 2020 for WebM it's not there? So seems you can't export WebM with alpha using this plugin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2020 0
New Here ,
Apr 17, 2020

Copy link to clipboard

Copied

It appears this might be a bug in 2020, I've found other threads saying the option vanished with the 2020 update.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 17, 2020 0
New Here ,
Oct 09, 2020

Copy link to clipboard

Copied

instal this and the bug desapears
https://www.fnordware.com/WebM/

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2020 0
Community Beginner ,
Apr 08, 2019

Copy link to clipboard

Copied

I had similar issues with .webm exports. Or so I thought until recently. For me at least it was a simple oversight, not with the file itself but how I previewed the export. What software are you using to preview your file, and are you certain it properly supports .webm preview?

Here's the same file previewed in VLC and OBS.

VCL:
Skjermbilde 2019-04-08 kl. 13.34.07.png

OBS:

Skjermbilde 2019-04-08 kl. 13.33.50.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 08, 2019 5
New Here ,
Aug 05, 2019

Copy link to clipboard

Copied

That is proper answer! Browsers and streaming platforms read this format very differently than normal media player.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 05, 2019 2
Adobe Community Professional ,
Feb 13, 2020

Copy link to clipboard

Copied

Sounds like the correct answer is to view the WebM file with alpha in OBS Open Broadcaster Software.

 

There are other examples of this.  When rendering to DNxHD with alpha, it will not show correctly in QuickTime Player classic, but will show correctly in Avid Media Player. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2020 0
New Here ,
Sep 17, 2019

Copy link to clipboard

Copied

I'm using Adobe CC 2019 and I don't have the WebM as an option in Media Encoder 😞

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2019 0
New Here ,
Sep 25, 2019

Copy link to clipboard

Copied

To do this you can download the webm plugin for either premiere or AME here: https://www.fnordware.com/WebM

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2019 0
Adobe Community Professional ,
Apr 17, 2020

Copy link to clipboard

Copied

It is a 3rd party option.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 17, 2020 0
New Here ,
Jun 23, 2020

Copy link to clipboard

Copied

In Premiere I've tried to convert my AVI to Quicktime and then to WEBM and it still doesnt work. 

Yes I've clicked include Alpha.  It still comes out as a blobby mess or the one that looks ok has a black background still in OBS (streamlabs OBS). I'm using 2020 and I really have no idea how to get it to work.

 

Kinda can't do anything creative with my Twitch channel at all at the moment. I see so many amazing Alerts from streamers and i'm stuck using GIFs (how old are GIFs? lol). 

 

Tried doing it directly from AE as well - Webm and Quicktime then convert and AVI then convert and MP4 and convert... Nothing works. I'm always making sure I tick include alpha and RGB+Alpha. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 23, 2020 0
Adobe Community Professional ,
Jun 23, 2020

Copy link to clipboard

Copied

You would need to reach out to fnord who publishes WebM.  Although, as best as I can tell, their website has no support option.

 

GIFs are the first image file format supported by early web browsers.  I wouldn't know the official date of introduction without looking it up, but I first started making them back in the mid-1990s.  Getting a GIF to look good for Windows was a headache, but so was any graphics file format with limited color depth.  Macs have always supported millions of colors or more, but some Windows machines supported as few as 8 colors total at the time.

 

Of course, long before that, we had ASCII graphics!

Screen Shot 2020-06-23 at 11.37.37 AM.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 23, 2020 0
Community Beginner ,
Aug 14, 2020

Copy link to clipboard

Copied

In case someone is revisiting for 2020 this with the Adobe Me update 14.3.1 this happened again.

I reverted back to  Me v14.3 uninstalled and i actually took off the adobe exchange version of the plugin and went to the same maker's site directly and used the legacy installer. This made it much easier to uninstall and reinstall till I saw the checkbox again, since the newest updates to adobe makes it really annoying to find the exchange unlike before from the CC desktop app like it used to when it was the smaller version.

Also YES, webm does support alpha channels, I've done this for multiple streamers including rebrands of my own streeam 5 times using webm it DOES support alpha, so i'm sorry Vinay_D you need to update your responce as it's giving false information on the codec. Even with the base settings of being in 4.2.0 rather than 4.4.4 all my exports when using the Include Alpha. Also as far as "use a format that supports it." Webm for Streaming is the lightest and results in lowest latency for streaming in terms of data transfer for streaming a lot of the other alpha supporting codecs are too high in file size to transfer and will cause skipped frames and or just laggy stream. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 14, 2020 1
New Here ,
Aug 19, 2020

Copy link to clipboard

Copied

Out of curiosity, how do you roll back to the 14.3 from 14.3.1? I'm having the same issue, exporting to webm, but cant get the alpha channel to work because i need webm for streams

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 19, 2020 0
New Here ,
Aug 25, 2020

Copy link to clipboard

Copied

You go to the cloud app. Click the three dot menu next to Me and select other versions. Click the version you want and it will uninstall the current and replace it.SharedScreenshot.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2020 1
New Here ,
Aug 25, 2020

Copy link to clipboard

Copied

I just want to vouch this fix. Got a webm with alpha. File was still a bit bigger than expected. (3.2mb) on a 2 second transition, but I am sure I could have tweeked it. My assumption here is the author has not updated the adobe exchange to the latest version and some change in the version is hiding the alpha checkbox. By going back to v14.3 and using legacy install from creators website I was able to get the desired result. Thank you for the fix. I'll stay on this version until I know there is an update to the plug-in.SharedScreenshot.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2020 1
Community Beginner ,
Sep 02, 2020

Copy link to clipboard

Copied

Thank you! Everyone on this thread is a lifesaver. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 02, 2020 0