Highlighted

FOOTAGE IMPORTING DIFFERENT COLOR AMOUNTS IN DIFFERENT VERSIONS OF AFTER EFFECTS

Community Beginner ,
Jun 18, 2020

Copy link to clipboard

Copied

Hey all!
 
I'm rendering out a piece of footage in After Effects CC17 (17.1.0) and I'm having an issue when I bring it back into the software.
 
My render settings are:
Apple Pro Res 4444 +Alpha
Trillions of Colors
Straight
(Comp rendering from is 16bpc)
 
When the render is complete and I bring it back into After Effects, the Project window says the footage is "Millions of Colors + (Straight)"
 
In addition, the footage looks like it has banding in it which doesn't appear in the raw composition it was made from. I can only assume this is related to the way the footage is imported into the software?
 
The odd thing is that I take the EXACT same rendered footage into After Effects CC16 (16.1.3) And I'm getting what I'm looking for: The Project window correctly interprets the footage as "Trillions of Colors + (Straight)" and there;s no banding to speak of.
 
I have attached screenshots as a reference.
 
Anyone have any idea what's going on here? Help is greatly appreciated!cc16_Previewcc16_Previewcc16_Project_Windowcc16_Project_Windowcc17_Previewcc17_Previewcc17_Project_Windowcc17_Project_Window
 

Topics

Import and export, Performance, Preview, User interface or workspaces

Views

83

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

FOOTAGE IMPORTING DIFFERENT COLOR AMOUNTS IN DIFFERENT VERSIONS OF AFTER EFFECTS

Community Beginner ,
Jun 18, 2020

Copy link to clipboard

Copied

Hey all!
 
I'm rendering out a piece of footage in After Effects CC17 (17.1.0) and I'm having an issue when I bring it back into the software.
 
My render settings are:
Apple Pro Res 4444 +Alpha
Trillions of Colors
Straight
(Comp rendering from is 16bpc)
 
When the render is complete and I bring it back into After Effects, the Project window says the footage is "Millions of Colors + (Straight)"
 
In addition, the footage looks like it has banding in it which doesn't appear in the raw composition it was made from. I can only assume this is related to the way the footage is imported into the software?
 
The odd thing is that I take the EXACT same rendered footage into After Effects CC16 (16.1.3) And I'm getting what I'm looking for: The Project window correctly interprets the footage as "Trillions of Colors + (Straight)" and there;s no banding to speak of.
 
I have attached screenshots as a reference.
 
Anyone have any idea what's going on here? Help is greatly appreciated!cc16_Previewcc16_Previewcc16_Project_Windowcc16_Project_Windowcc17_Previewcc17_Previewcc17_Project_Windowcc17_Project_Window
 

Topics

Import and export, Performance, Preview, User interface or workspaces

Views

84

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 18, 2020

Copy link to clipboard

Copied

This is caused by inconsistent color management between machines.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jun 18, 2020

Copy link to clipboard

Copied

Hi Rick! Thanks for responding!

 

The thing is that I'm doing this test on a single machine that has both versions of After Effects installed on it....

 

Also is there a reason that one version would say "Millions" while the other says "Trillions"?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jun 18, 2020

Copy link to clipboard

Copied

You can set the options for the color picker display in the Info Panel. 

Screenshot_2020-06-18 20.42.58_7E3LQt.png

Any setting other than Auto Color Display will override how the values displayed in any color picker popup panel When the Info Panel is set to Auto the values in the color picker are driven by the Color settings in Project Preferences (Shift + Alt/Option + Ctrl/Cmnd + k). 

 

Any expressions you use for color require a 4 digit RGBA array and the values are always decimal (float/32 bit). White would be [1, 1, 1, 1]. Red with a 50% transparency setting would be [1, 0, 0, .5]. Not all editable color properties in After Effects support alpha channels but a four-digit array is still the way to go unless it throws an error.

 

I hope this clears things up.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...