Highlighted

Full HD Movie is pixelated after compositing???

Community Beginner ,
Jun 26, 2011

Copy link to clipboard

Copied

Hi, Im new to the forums but have been using After Effects for a while now...

I just got a HD Camcorder and shot a movie with some friends. I composited in AE CS5 and then rendered/exported it as a H.264 file. I viewed the movie in Windows Media Player, Quicktime, iTunes, and VLC, and the quality is below Full HD, it is less than Standard Definition.

CAMERA:

1920x1080

30fps

AE SETTINGS:

1920x1080

30fps

around 9mins of footage
COMPUTER:
Win 64-bit
4GB RAM
nvidia 1GB (Graphics)
i5 (2.53Ghz)
I then viewed movie in AE, RAM preview, it looks stunning!
So I cant work out whether it is the format (H.264 or MP4), the rendering settings, the media players or it wont view in FullHD due to my hardware? Any help would be MUCH appreciated.

Views

19.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Full HD Movie is pixelated after compositing???

Community Beginner ,
Jun 26, 2011

Copy link to clipboard

Copied

Hi, Im new to the forums but have been using After Effects for a while now...

I just got a HD Camcorder and shot a movie with some friends. I composited in AE CS5 and then rendered/exported it as a H.264 file. I viewed the movie in Windows Media Player, Quicktime, iTunes, and VLC, and the quality is below Full HD, it is less than Standard Definition.

CAMERA:

1920x1080

30fps

AE SETTINGS:

1920x1080

30fps

around 9mins of footage
COMPUTER:
Win 64-bit
4GB RAM
nvidia 1GB (Graphics)
i5 (2.53Ghz)
I then viewed movie in AE, RAM preview, it looks stunning!
So I cant work out whether it is the format (H.264 or MP4), the rendering settings, the media players or it wont view in FullHD due to my hardware? Any help would be MUCH appreciated.

Views

19.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 26, 2011 0
Most Valuable Participant ,
Jun 26, 2011

Copy link to clipboard

Copied

You forgot to set render quality to "Best" and instead left it at "Current", which uses your current comp preview resolution which rather obviously was not set to full...

Mylenium

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2011 0
Community Beginner ,
Jun 26, 2011

Copy link to clipboard

Copied

Thanks for the help, but yes my Render Settings are set to best.

Does my bitrate effect the quality of the picture???

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2011 0
Adobe Community Professional ,
Jun 26, 2011

Copy link to clipboard

Copied

Of course it does.  Please post all your output and render settings.  Or a screen grab of those settings.  It's far easier for us to discuss what you're doing if we don't have to guess what you're doing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2011 0
Community Beginner ,
Jun 26, 2011

Copy link to clipboard

Copied

BTW, Thank you for your help. I havent worked with HD before...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2011 0
Adobe Community Professional ,
Jun 26, 2011

Copy link to clipboard

Copied

Post a screen grab of your output settings if you would like further thoughts, if Mylenium's suggestion doesn't solve the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2011 0
Community Beginner ,
Jun 26, 2011

Copy link to clipboard

Copied

FORMAT:  H.264

VIDEO OUTPUT (default settings):

Channels: RGB

Color: Premultiplied (Matted)

Codec: MainConcept H.264 Video

Profile: Main

Level: 5.1

Bitrate Encoding: VBR, 1 Pass

Target Bitrate [Mbps]: 3

Max. Bitrate [Mbps]: 3

SIZE:

1920 x 1080 (100%)

AUDIO OUTPUT:

48 kHz/Stereo

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2011 0
Adobe Community Professional ,
Jun 26, 2011

Copy link to clipboard

Copied

Your biggest problem is that you are trying to compress to H264 directly from After Effects. You bit rate is way too low for HD. H264 is also suitable for Web distribution but it's a lousy codec to send to a DVD or Blu Ray compressor. For that you should be using a lossless output.

The best way to go is to open up your AE project directly in Adobe Media Encoder and pick a default setting for your desired audience. If you want HD for the web then use Apple TV or You Tube HD. You'll end up with a variable bit rate between 5 and 7 or 8 and 9, and 2 pass compression. If you want to go directly to BluRay then use that option, but personally I find that compressing for Blu Ray works a lot better if you do it in Encore.

If you're wanting to archive the video or use it in another production then pick a lossless or nearly lossless format like Apple ProREZ or Black Magic, or even a PhotoJpg QT or AVI set to 90% quality.

You cannot expect single pass compression at a data rate of 3 Mbps to give you a quality image in an HD frame size. It just can't be done. That's barely an acceptable data rate for SD.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2011 0
Community Beginner ,
Jun 26, 2011

Copy link to clipboard

Copied

So that would explain it, my bitrate, what do you think the bitrate should be.

Im done in production it is at its final stage, and lossless is terrible, because the AVI file was around 100GB...

The only reason Im doing this in H.264 format is because thats what my camcorder uses and I thought it was a good format to use for HD.

I dont want to put it on disc, however wish to store it on my hard drive and eventually upload it to Youtube,'

I will try Encoder! Ill get back to you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2011 0
Community Beginner ,
Jun 26, 2011

Copy link to clipboard

Copied

great, Media Encoder won't open?!?

It stops loading at ImporterRED.prm

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2011 0
Adobe Community Professional ,
Jun 26, 2011

Copy link to clipboard

Copied

Try rebooting your system. If AME still won't launch try a re-install. Do you have a suite or just AE?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2011 0
Community Beginner ,
Jun 27, 2011

Copy link to clipboard

Copied

AME still doesn't open when I updated it... but it's ok. Thanks for everyone's help, I changed some render settings and it looks perfect, got them from a YouTube video!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 27, 2011 0
Community Beginner ,
Jun 27, 2011

Copy link to clipboard

Copied

These were my new settings for anyone having the smae problem..

FORMAT:  H.264 (Include BOTH Project Link & Source XMP Metadata)

VIDEO OUTPUT (default settings):

Channels: RGB

Color: Premultiplied (Matted)

Codec: MainConcept H.264 Video

Profile: High

Level: 5.1

Bitrate Encoding: CBR

Bitrate [Mbps]: 8

SIZE:

1920 x 1080 (100%)

AUDIO OUTPUT:

48 kHz/Stereo

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 27, 2011 1
New Here ,
May 04, 2020

Copy link to clipboard

Copied

@Blackrider_99, much thanks for posting this. Was having the same problem and using your settings worked perfectly!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 04, 2020 0
New Here ,
Jul 19, 2011

Copy link to clipboard

Copied

First, before you open AE.

Press Command+Option+Shift together and press after effects icon to open.

This actually will reset all your previous settings to default.

Create new composition and without touching any settings import your camera footage H.264 format.

After effects will create by it self the right settings.

Don't go into project settings. Leave them as they are.

Go to Edit/Templates/Output Module

Defaults (Make sure they are the following)

Movie Default: H.264

Frame Default: Lossless

RAM Preview: Lossless

Pre-Render Default: Lossless

Movie proxy Default Lossless

Settings

Settings Name H.264

Save all and close

Do your editing to your footage, color correction or whatever has to be done, than...

When you add your composition to Render Queue down low to Output Module press the yellow text H.264

When the Output Module setting box is opened on your right side at the video output section it says FORMAT OPTIONS.

Press it than go to Mbs/bitrate settings and move the sliders to about 27 or 30.

Maximum Bitrate 27

Target Bitrate     27

Close it and you re good to go.

Render a few frames from your working are to make sure the problem has been solved first. If yes than render the whole thing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 19, 2011 0
Enthusiast ,
Jul 21, 2011

Copy link to clipboard

Copied

Compressing h264 at 30mbit/sec is ridiculously high.

Follow the earlier suggestion and render to an uncompressed or lightly compressed interim format. And try Handbrake. It's an incredibly efficient h264 encoder. It has a visual quality slider that's super easy to use. You don't have to worry about bitrates or profiles or levels or any of that stuff. The default of Quality 20 is fine for most material.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 21, 2011 1
New Here ,
Oct 05, 2015

Copy link to clipboard

Copied

Handbrake gave me vastly superior results. Thanks for the tip!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2015 0