Highlighted

Illustrator File is blurry in After Effects

Community Beginner ,
Jul 30, 2020

Copy link to clipboard

Copied

So I have this ancient logo for my agency that was made eons ago. I am trying to bring it into After Effects to do some animating with it but it just comes out blurry. I've tried continuously rasterize (in Ae) and document raster effect settings @300ppi (in Ai) but neither one helped. Any advice you can offer is greatly appreciated

Adobe Community Professional
Correct answer by Rick Gerard | Adobe Community Professional

Raster Effects turn vectors into pixels so CR will not help that layer from AI. Simple as that. 

 

Try this:

  • Open the AI file in Illustrator
  • Set the document settings to pixels or points (they are the same when it comes to AE)
  • Check the artboard size and make sure it is at least the same size as your comp frame like 1920 X 1080
  • Position the logo in its hero position in AI and scale it up so that it looks the way you want it to in AE
  • Go to the View menu and turn on Pixel Preview
  • Set the AI Magnification to 100% and check, then 200% and check
  • If all is OK then save the file and import it into AE

You won't see much difference in the Raster settings from 300 to 72, especially when the view is set to 400% or more but you will see the aliased edges of the vector paths, and that's what they will look like in AE. All artwork prepared for video in AI should have Snap to pixel turned on and you should always test it with Pixel Preview turned on at 100% and 200%. 

Screenshot_2020-07-31 14.12.40_pHqtGW.pngScreenshot_2020-07-31 14.11.27_gP0lp3.pngScreenshot_2020-07-31 14.10.43_kjBEMk.png

 

If this were my project I would make the artboard at least fit the comp, make the logo bigger than it needs to be, and if possible, duplicate every layer with A raster effect, put it on a separate layer above the original, and delete the raster effects, then import as a comp and see if you can't do a better job of creating drop shadows or other raster effects in AE.

 

 

TOPICS
FAQ, How to, Import and export

Views

33

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Illustrator File is blurry in After Effects

Community Beginner ,
Jul 30, 2020

Copy link to clipboard

Copied

So I have this ancient logo for my agency that was made eons ago. I am trying to bring it into After Effects to do some animating with it but it just comes out blurry. I've tried continuously rasterize (in Ae) and document raster effect settings @300ppi (in Ai) but neither one helped. Any advice you can offer is greatly appreciated

Adobe Community Professional
Correct answer by Rick Gerard | Adobe Community Professional

Raster Effects turn vectors into pixels so CR will not help that layer from AI. Simple as that. 

 

Try this:

  • Open the AI file in Illustrator
  • Set the document settings to pixels or points (they are the same when it comes to AE)
  • Check the artboard size and make sure it is at least the same size as your comp frame like 1920 X 1080
  • Position the logo in its hero position in AI and scale it up so that it looks the way you want it to in AE
  • Go to the View menu and turn on Pixel Preview
  • Set the AI Magnification to 100% and check, then 200% and check
  • If all is OK then save the file and import it into AE

You won't see much difference in the Raster settings from 300 to 72, especially when the view is set to 400% or more but you will see the aliased edges of the vector paths, and that's what they will look like in AE. All artwork prepared for video in AI should have Snap to pixel turned on and you should always test it with Pixel Preview turned on at 100% and 200%. 

Screenshot_2020-07-31 14.12.40_pHqtGW.pngScreenshot_2020-07-31 14.11.27_gP0lp3.pngScreenshot_2020-07-31 14.10.43_kjBEMk.png

 

If this were my project I would make the artboard at least fit the comp, make the logo bigger than it needs to be, and if possible, duplicate every layer with A raster effect, put it on a separate layer above the original, and delete the raster effects, then import as a comp and see if you can't do a better job of creating drop shadows or other raster effects in AE.

 

 

TOPICS
FAQ, How to, Import and export

Views

34

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 30, 2020 0
Most Valuable Participant ,
Jul 31, 2020

Copy link to clipboard

Copied

Without a screenshot and info about what features the AI file actually uses we can't really tell you much. And of course don't just check the raster DPI, but also the global document DPI. This stuff interacts sometimes in weird ways in AI. Also try to copy & paste your artwork to a new AI document with correct settings and use that.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 31, 2020 0
Explorer ,
Jul 31, 2020

Copy link to clipboard

Copied

The only thing left I could think of is your composition dimensions inside After Effects may be small.

If your AI file is 300x300 px and you dragged that into a new AE composition, it will create for you a comp that is 300x300 px. No matter how much you zoom into it, it will look pixelated because AE is not a vector-based software like AI.

So go to composition settings (CTRL+K) and change your comp dimensions to something like 1920x1080 px and then scale up the logo inside it with Continuously Rasterize on and you will get it clear and well. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 31, 2020 1
Adobe Community Professional ,
Jul 31, 2020

Copy link to clipboard

Copied

Raster Effects turn vectors into pixels so CR will not help that layer from AI. Simple as that. 

 

Try this:

  • Open the AI file in Illustrator
  • Set the document settings to pixels or points (they are the same when it comes to AE)
  • Check the artboard size and make sure it is at least the same size as your comp frame like 1920 X 1080
  • Position the logo in its hero position in AI and scale it up so that it looks the way you want it to in AE
  • Go to the View menu and turn on Pixel Preview
  • Set the AI Magnification to 100% and check, then 200% and check
  • If all is OK then save the file and import it into AE

You won't see much difference in the Raster settings from 300 to 72, especially when the view is set to 400% or more but you will see the aliased edges of the vector paths, and that's what they will look like in AE. All artwork prepared for video in AI should have Snap to pixel turned on and you should always test it with Pixel Preview turned on at 100% and 200%. 

Screenshot_2020-07-31 14.12.40_pHqtGW.pngScreenshot_2020-07-31 14.11.27_gP0lp3.pngScreenshot_2020-07-31 14.10.43_kjBEMk.png

 

If this were my project I would make the artboard at least fit the comp, make the logo bigger than it needs to be, and if possible, duplicate every layer with A raster effect, put it on a separate layer above the original, and delete the raster effects, then import as a comp and see if you can't do a better job of creating drop shadows or other raster effects in AE.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 31, 2020 1