Highlighted

Images from the illustrator jump and float as the camera moves. Collapse Transformation

Explorer ,
Nov 09, 2020

Copy link to clipboard

Copied

Hello! I created a Facebook page in Illustrator for a movie. When 3D cameras or 2D null objects move, the images just jump and float in different directions.

 

I am using latest CC 2019 builds for stable performance. I also tested this file in earlier versions of CC prior to 2015. And the result is the same. This happens when Collapse Transformation is enabled. And without him, everything is simply dull.

 

I have switched between CPU and CUDA, reset NVIDIA driver settings, but nothing helps. Apparently the problem is in Illustrator. I really hope for your help!

 

This is how it looks. Youtube link: https://youtu.be/VyULSIfAQe0

Enjoy the videos and music you love, upload original content, and share it all with friends, family, and the world on YouTube.
Adobe Community Professional
Correct answer by Rick Gerard | Adobe Community Professional

Are you scaling layers? Are you moving way in on the camera?

 

1.  I would make sure all AI layers are in the right order, make them all 3D, then add this expression to every AI layer in your comp.

 

[value[0], value[1], value[2] + index]

 

2.  Make sure Continuously Rasterize is turned on for all AI layers.

3.  Parent all AI layers to the top AI layer so you can move the group easily.

4.  Add your camera and animate the camera.

 

That workflow will guaranatee that your layers behave. 

 

The other simple option is to import the AI file as footage with merged layers, add the single AI file to the main comp, make it 3D, turn on Continuously Rasterize, then add your camera and animate the camera. 

 

If you need all AI layers on a separate layer and you are pushing way in then create a comp from your AI file, open up the comp settings and increase the size of the comp by 2 or 3 times, scale up all layers so they fill the frame, turn on Continuously Rasterize for all layers, then add this big comp to your standard main comp, add the camera and animate the camera.

TOPICS
Dynamic link, Import and export, Preview

Views

84

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Images from the illustrator jump and float as the camera moves. Collapse Transformation

Explorer ,
Nov 09, 2020

Copy link to clipboard

Copied

Hello! I created a Facebook page in Illustrator for a movie. When 3D cameras or 2D null objects move, the images just jump and float in different directions.

 

I am using latest CC 2019 builds for stable performance. I also tested this file in earlier versions of CC prior to 2015. And the result is the same. This happens when Collapse Transformation is enabled. And without him, everything is simply dull.

 

I have switched between CPU and CUDA, reset NVIDIA driver settings, but nothing helps. Apparently the problem is in Illustrator. I really hope for your help!

 

This is how it looks. Youtube link: https://youtu.be/VyULSIfAQe0

Enjoy the videos and music you love, upload original content, and share it all with friends, family, and the world on YouTube.
Adobe Community Professional
Correct answer by Rick Gerard | Adobe Community Professional

Are you scaling layers? Are you moving way in on the camera?

 

1.  I would make sure all AI layers are in the right order, make them all 3D, then add this expression to every AI layer in your comp.

 

[value[0], value[1], value[2] + index]

 

2.  Make sure Continuously Rasterize is turned on for all AI layers.

3.  Parent all AI layers to the top AI layer so you can move the group easily.

4.  Add your camera and animate the camera.

 

That workflow will guaranatee that your layers behave. 

 

The other simple option is to import the AI file as footage with merged layers, add the single AI file to the main comp, make it 3D, turn on Continuously Rasterize, then add your camera and animate the camera. 

 

If you need all AI layers on a separate layer and you are pushing way in then create a comp from your AI file, open up the comp settings and increase the size of the comp by 2 or 3 times, scale up all layers so they fill the frame, turn on Continuously Rasterize for all layers, then add this big comp to your standard main comp, add the camera and animate the camera.

TOPICS
Dynamic link, Import and export, Preview

Views

85

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 09, 2020 0
Most Valuable Participant ,
Nov 09, 2020

Copy link to clipboard

Copied

Impossible to tell the exact cause without seeing your timeline and composition, but most of the time it boils down to incorrect anchor point placement and scaling the artwork unnecessarily. You may need to dig again into the source compositions. Also in case of 3D of course make sure there is actual depth separation between the layers. It's probably also fair to say that you are not making things easier by mixing pixel-based content and vectors, though I'm not clear if you already included it in the AI file. You could have soem weird issue with masking or pixel-based effects liek drop shadows then.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2020 1
Explorer ,
Nov 09, 2020

Copy link to clipboard

Copied

Thanks for the quick response, Mylenium!
Here's my timeline. I am using AI files directly. Tried it single. The result is the same. This happens exactly when Collapse Transformations is enabled.

The 3D layers are also arranged in depth. If that's what you mean.

And also my text from AI file and native text in AE is blurred when I turn on the 3D layer. Even without a camera and Motion Blur.

 

234.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2020 0
Most Valuable Participant ,
Nov 09, 2020

Copy link to clipboard

Copied

Start by switching your project to 8 bpc or 16 bpc. AI files never are 32 bpc, so you could see bad antialaising and quantization artifacts just from that. Unless you really need this for soem special effects like glow, this only gets in the way. And judging from your position values, your scale cnter/ anchor point appears to be very far outside the comp area, which could also exacerbate any scaling issues simply due to limited precision. otherwise I would simply build a static comp at sufficient resolution and scale that one without CR/ CT. This may ultimately even yield better visual results.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2020 1
Explorer ,
Nov 10, 2020

Copy link to clipboard

Copied

Thank you very much for your answers! I appreciate your help! I did everything as you said, but the result is the same.

 

Here three layers are the second path. That video is just one file from Illustrator.

I even just set the Scale parameters for the AI file and the result is the same. Now, when I translated any bitmap through "Image Trace", then all the shaking and floating is gone. Everything is clear and smooth. But this is not an option for me.

 

Second point: When I take the AI file and add it to the pre-composition. And if I don't include Collapse Transformation, then there is no such jitter. Everything is smooth, but blurry.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2020 0
Adobe Community Professional ,
Nov 09, 2020

Copy link to clipboard

Copied

You have 3D layers representing a flat surface but all three of them are at different Z depth. When the camera moves the perspective between the layers will change. 100% normal behavior. The solution is to place all 3 layers on the same plane with a maximum of a 1-pixel offset, use scale, and X/Y position to line up the layers (which should have been lined up in Illustrator), and then animate the camera position. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2020 1
Explorer ,
Nov 10, 2020

Copy link to clipboard

Copied

Thanks! I answered above this post. I also noticed that everything is fine when I change the position of the camera or the file itself in X and Y. The problem is only with the zoom or zoom of the 3D camera along the Z axis

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2020 0
Adobe Community Professional ,
Nov 10, 2020

Copy link to clipboard

Copied

The problem is caused by 3D layers in the same plane. Offset the layers by 1 pixel and the problem goes away. You can move the camera any way you want.

 

An even easier solution is to leave all the AI layers 2D, pre-compose them, turn on Collapse transformations, then make the pre-comp 3D and animate the camera. This eliminates the interference caused when 3D layers share the same plane.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2020 1
Explorer ,
Nov 10, 2020

Copy link to clipboard

Copied

Thanks, Mr. Rick! Your last method works! I am doing this:

1. I add 2D AI layers to Pre-Comp.
2. Create a 3D camera in the main composition
3. Turning on the 3D layer on the Pre-Comp, right?
4. And only when I turn on Collapse Transformations on Pre-Comp, the layers stop responding to the 3D camera, but maximum clarity appears. And if you turn off Collapse on Pre-Comp, then everything is a little blurry. Can you tell me how to fix this? Inside Pre-Comp, Collapse is also enabled on all AI files. Thanks again!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2020 0
Adobe Community Professional ,
Nov 10, 2020

Copy link to clipboard

Copied

Are you scaling layers? Are you moving way in on the camera?

 

1.  I would make sure all AI layers are in the right order, make them all 3D, then add this expression to every AI layer in your comp.

 

[value[0], value[1], value[2] + index]

 

2.  Make sure Continuously Rasterize is turned on for all AI layers.

3.  Parent all AI layers to the top AI layer so you can move the group easily.

4.  Add your camera and animate the camera.

 

That workflow will guaranatee that your layers behave. 

 

The other simple option is to import the AI file as footage with merged layers, add the single AI file to the main comp, make it 3D, turn on Continuously Rasterize, then add your camera and animate the camera. 

 

If you need all AI layers on a separate layer and you are pushing way in then create a comp from your AI file, open up the comp settings and increase the size of the comp by 2 or 3 times, scale up all layers so they fill the frame, turn on Continuously Rasterize for all layers, then add this big comp to your standard main comp, add the camera and animate the camera.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2020 1
Explorer ,
Nov 13, 2020

Copy link to clipboard

Copied

Thanks a lot, Rick! Your solutions work great! But could you tell me exactly where to insert these expressions for AI files? The Position? Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 13, 2020 0
Adobe Community Professional ,
Nov 13, 2020

Copy link to clipboard

Copied

If you want to stack a bunch of layers in Z space adding this expression to the Anchor Point will put the top layer closest to the default camera and if you make the top layer the parent of the stack, the position of the other layers won't change. I have this saved as an animation preset. I use it all the time.

[value[0], value[1], value[2] - index]

If you want to use this technique to extrude a bunch of identical layers the edge may develop a moray pattern but that is easily fixed by adding an Adjustment layer to the top of the stack and then adding the default Bilateral Blur. Here is a screenshot showing 101 solid layers with a stroke, cast shadows have been turned on, and a spotlight and ambient light added to give depth to the scene. If your machine doesn't have a very good GPU extruding like this will render faster than it does if you used the C4D rendering engine and you still get to use effects and blend modes on 3D layers. 

Screenshot_2020-11-13 07.49.39_GlcQNu.png 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 13, 2020 1
Explorer ,
Nov 20, 2020

Copy link to clipboard

Copied

Thank you, Thank you, Thank you! Your advice works, Mr. Rick Gerard!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 20, 2020 0