Highlighted

Imported Illustrator files are blank

New Here ,
Mar 18, 2019

Copy link to clipboard

Copied

Every object is on its own layer. Saved with a compatible pdf. Imported as All Acceptable Files, Composition - Retain Layer Sizes. All of the layers appear as blank. Screen Shot 2019-03-18 at 9.21.19 AM.pngScreen Shot 2019-03-18 at 9.21.01 AM.png

Views

6.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Imported Illustrator files are blank

New Here ,
Mar 18, 2019

Copy link to clipboard

Copied

Every object is on its own layer. Saved with a compatible pdf. Imported as All Acceptable Files, Composition - Retain Layer Sizes. All of the layers appear as blank. Screen Shot 2019-03-18 at 9.21.19 AM.pngScreen Shot 2019-03-18 at 9.21.01 AM.png

Views

6.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 18, 2019 0
Adobe Community Professional ,
Mar 18, 2019

Copy link to clipboard

Copied

Open your AE file, so a save as and when the save options pop up make sure PDF compatible file is checked. That should solve the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 18, 2019 0
New Here ,
Mar 18, 2019

Copy link to clipboard

Copied

Hello Rick,

It has been checked every time. I originally had another artboard in the same project with other assets and never had these issues with those assets. I've tried re-saving as a new project but none of these layers will appear after importing. Let me know if you have any other suggestions.

Regards,

Courtney

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 18, 2019 0
New Here ,
Mar 18, 2019

Copy link to clipboard

Copied

I selected Illustrator PDF/EPS sequence when selecting the file to import and it seems to have imported the files (although in a different format).Screen Shot 2019-03-18 at 1.41.14 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 18, 2019 0
Adobe Community Professional ,
Mar 18, 2019

Copy link to clipboard

Copied

That is incorrect.

When you save a file in AI you get this option:

Screenshot_2019-03-18 14.07.17_GN1Wxs.png

Importing as a sequence with AI or PSD files is only to be used if you have hand drawn a bunch of animation cells like a traditional animator. That creates a video from a bunch of sequentially numbered files. If you have not checked Create PDF Copmpatible File After Effects will not recognize any of the paths in the AI file and you get a blank layer or comp.

You should take some time to learn about preparing graphics for video. It's not as simple as you think. Here's a fairly decent quick overview: https://www.austinsaylor.com/blog/illustrator-to-ae

Not everything was covered, but it should get you started.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 18, 2019 0
Guide ,
Mar 19, 2019

Copy link to clipboard

Copied

Rick Gerard​ You are correct about the settings, but if you would read properly, you find that this options was checked - not in the cleanest English, yet understandable: "Every object is on its own layer. Saved with a compatible pdf. Imported as All Acceptable Files ..."

RyanWing​ Could it be, that your artwork is simple not placed on the artbord, or the artboard is too small or something in this direction?

Also, make sure that your AI file is in RGB color space.

That's all I can think of right now.

Good luck!

*Martin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 19, 2019 0
New Here ,
Jan 29, 2020

Copy link to clipboard

Copied

You can't have more than one artboard in the AI file. You may notice that one of your files appears, while none of the others do. That's because AE is reading that artboard instead of the one(s) you want.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 29, 2020 1
New Here ,
Mar 15, 2020

Copy link to clipboard

Copied

Saved me. Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 15, 2020 0
New Here ,
Apr 02, 2020

Copy link to clipboard

Copied

Even though this is a one year old thread I never saw a definitive answer here. As I've had the same problem and have now found a solution that works for me I thought I would share. Just as Rick_Gerard suggested about making the Ai-files PDF compatible - that did not solve it for me. What ultimately solved it for me after hours of frustration and Googeling was to make the artboard in the Ai-file smaller so it only incorporate the graphics and doesn't have a lot of empty space (if that makes sense). I have no idea why that worked, almost seems like a bug - but hey I'm glad it works!  I hope this helps someone out there 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 02, 2020 0
New Here ,
Jun 21, 2020

Copy link to clipboard

Copied

Thank you!

 

This Solved my issue in AE 2020 as well. 

 

Had a logo with several layers on a larger artboard and everything was importing into AE but the screen was black.  I could see the individual layers in the composition and select them, but only the bounding box appeared, no graphic.  After reducing the AI artboard down to only encompass the area needed, they showed up when imported into AE as expected. 

 

Go figure.....

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 21, 2020 2
New Here ,
Aug 05, 2020

Copy link to clipboard

Copied

Thank you! Likewise, spent hours searching and simple issue of snapping all my layers to artboard.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 05, 2020 1
New Here ,
Aug 02, 2020

Copy link to clipboard

Copied

None of these solutions helped me. However after much try I figured that i had used textures in my AI file and upon removing them i was able to view my composition in after effects. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 02, 2020 1
Community Beginner ,
Sep 30, 2020

Copy link to clipboard

Copied

This has to be some sort of bug - maybe in AE. I'm experiencing this for the very first time since ver.1. I even created a PSD and PNG of the file and both of those come in blank. I've resized the artboard both up and down as well, checked the PDF compatible check box (which I believe is ticked by default) and still I don't see my eps logo. At this point I can see anything.

 

Very strange.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 30, 2020 0
New Here ,
Oct 01, 2020

Copy link to clipboard

Copied

I noticed some odd behavior in AE this morning after updating my Nvidia driver yesterday.  I was trying to resize an illustrator file I was working with and reloading them in AE after the updates were saved.  All I kept getting was a black screen after the files were reloaded in AE.  Could be a driver anomaly.......

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 01, 2020 0