Highlighted

Issues with key frames maintaining their values.

Community Beginner ,
Nov 28, 2016

Copy link to clipboard

Copied

Its not the wobble problem. I'll place a shape layer in one position,using a key frame to mark it, and continue moving my shape layer and marking the movements with key frames. When I go back to review my animation, the key frames at the beginning will have shifted in position from where I originally had them. When I edit these key frames back to where they belong, other key frame values are affected for some reason. I end up in a constant cycle of re-editing key frames. I read somewhere that time remapping may cause this problem but i haven't been able to find that forum again. Does anyone know why specifically this is happening and how i can fix my problem?

[Moved from The Lounge​ to a product-specific support forum - moderator]

Views

544

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Issues with key frames maintaining their values.

Community Beginner ,
Nov 28, 2016

Copy link to clipboard

Copied

Its not the wobble problem. I'll place a shape layer in one position,using a key frame to mark it, and continue moving my shape layer and marking the movements with key frames. When I go back to review my animation, the key frames at the beginning will have shifted in position from where I originally had them. When I edit these key frames back to where they belong, other key frame values are affected for some reason. I end up in a constant cycle of re-editing key frames. I read somewhere that time remapping may cause this problem but i haven't been able to find that forum again. Does anyone know why specifically this is happening and how i can fix my problem?

[Moved from The Lounge​ to a product-specific support forum - moderator]

Views

545

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 28, 2016 0
Adobe Community Professional ,
Nov 28, 2016

Copy link to clipboard

Copied

What do you mean by "marking the movements with key frames"? When you enable keyframing for any property in After Effects, any time you change the parameter, it will create a keyframe automatically. There is no need for you to do anything. My guess is that you are not marking keyframes, but are instead turning keyframing on and off and on and off every time you click the keyframe enabling button.

If that's not the case, some screenshots might help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 28, 2016 0
Community Beginner ,
Nov 28, 2016

Copy link to clipboard

Copied

That's not what is happening. What I'm saying is that I will place my shape layer where i want it to be in my comp at the specific time i want that shape layer in that particular position. As I continue to move my shape to different positions for my animation the other keyframes seem to be affected because when i go back to scrub through my animation they have moved from where i put them. If i edit them back to where they belong, all of the other keyframes for that layer are changed as well. I dont understand why this is happening.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 28, 2016 0
Adobe Community Professional ,
Nov 28, 2016

Copy link to clipboard

Copied

Shape layers can have several different position properties. One for the layer itself, one for the shape group inside the shape layer, one for the path itself, etc.

Again, screenshots (or a screen capture video) would be very helpful.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 28, 2016 0
Community Beginner ,
Nov 28, 2016

Copy link to clipboard

Copied

Im working on getting some screenshots together right now . Its difficult and may take some time as the changes occur sporadically and i only have access to MS Paint to edit down the screengrabs. I know what your taking about a layer having several positions. That of the entire layer and that of the shape itself within the layer. I am using multiple moving shapes within one layer I ran into this problem early on. I have confined myself to exclusively applying and editing key frames to the position variable that apply to the specific shape i am working with. So it shouldn't be that either

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 28, 2016 0
Most Valuable Participant ,
Nov 28, 2016

Copy link to clipboard

Copied

i only have access to MS Paint to edit down the screengrabs.

if you are on Windows 7 and Above you can use the snipping tool. it's very handy for getting parts of the screen

anyways, make sure you make full and clear screenshots of what is going on.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 28, 2016 1
Community Beginner ,
Nov 28, 2016

Copy link to clipboard

Copied

duckproblems.jpg@Roei Tzoref thanks for the heads up i already put the grind into this one but ill definitely check that out!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 28, 2016 0
Most Valuable Participant ,
Nov 28, 2016

Copy link to clipboard

Copied

Exact Ae version? full numbers please

I am sorry it's hard for me to understand what exactly is the problem here. save your project and reduce the project: one layer, one shape - see when it is most obvious when reduced to the most basic setup so we (and maybe you) can figure out what is wrong exactly. no need for fancy titles, just plain full screenshots before-after. these are the same values, so no idea right now why it appears different. I see it is attached to a null, maybe something was changed after you changed the second keyframe in that null. dissect the problem and you will find the answer for this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 28, 2016 0
Community Beginner ,
Nov 30, 2016

Copy link to clipboard

Copied

CS5 version 10.0.2.4

Windows 7 Professional

I'm not quite sure what you're asking me to show you. But you raise a good point about the null object. I remember adding a null to link all shape layers too be able to easily scale my character. However, I don't see the null layer anymore and i don't remember deleting it. How would i go about checking to see if my layer is still attached to a Null Object?

I noticed the values being the same even though they clearly appear to be different in the comp viewer. I feel like my problem may have something to do with that.

Later on Monday i was playing with the file trying to figure this out. One time I input coordinates for a Position key frame for right leg: Shape 1: and it changed every Position key frame for right leg: Shape 1: to the same coordinates. Today when i started at it again the same thing happened.

This doesn't happen every time i try to edit a value for the shapes position, just super often. Its impossible to finish the sequence without my all of my position key frames changing.

Before you ask, yes I have made sure to have only one key frame selected(highlighted) at a time when editing its value.

What else could I be doing wrong to change all of the key frames to the most recent input values at once?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 30, 2016 0
Community Beginner ,
Nov 30, 2016

Copy link to clipboard

Copied

This sounds nearly exactly like my problem.

Change multiple keyframe values.PNG

As i said before i have been sure to keep my selection (highlighted key frames) to the specific key frame I am currently editing. It seems I am still, somehow, selecting all of my key frames and editing them all with either an "absolute" or "relative" change. Another problem that was pointed out by Roei Tzoref  is how the Comp Preview Window will sometimes show two different positions for the same input Position Coordinate.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 30, 2016 0
New Here ,
Jan 19, 2018

Copy link to clipboard

Copied

Hi

still no answer?I'm getting the exact same problem on the keyframes of the Displacement map filter.

If I show the graph editor I clearly see huge spikes in values and entire groups of keyframes translated downward by a super hi value like over 450 units. Now I tried to select them all, to center them around zero again, I move them, and almost instantly I can see another group of keyframes, a few seconds later, changing position upward by another apparently random value like 20 Units.

This is driving me crazy!

The displacement effect is applied on a pre comp containing a project imported from premiere with an edit of a loooot of clips. The clips are in compressed .mov taken from a sony alfa 2s.

exactly like sabra "This doesn't happen every time i try to edit a value for the shapes position, just super often. Its impossible to finish the sequence without my all of my position key frames changing."

any help?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 19, 2018 0
Kai5F9F LATEST
New Here ,
Sep 29, 2020

Copy link to clipboard

Copied

Hi, I was having this same issue and searching for an answer and this thread gave me enough insight to (I think) figure out what the problem is/was. You, like me, probably had the "Path" of the shape keyframed, and when adjusting each new position, you were editing the "Path" keyframes. What you need to do is edit the "Transform>Position" key frames. This should allow them to not all continously be adjusted everytime you change position on one keyframe. I realize this thread is 4 years old, but hopefully if someone else comes across it this answer will help them.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 29, 2020 0