Highlighted

Lighting help

New Here ,
Mar 24, 2020

Copy link to clipboard

Copied

I'm fairly new to  Adobe After  Effects. I am trying to light a  3D object. When I add the lights, they aren't seen by the 3D object. I looked  on the forum and saw that it might be a Radius and Falloff problem, so I turned those up and still didn't see a change to my 3D text. My 3D text has Accept lights turned on. My lighting settings are:

Intensity: 100

Cone Angle: 90

Cone Feather: 50

Falloff: Smooth

Radius: 1776

Falloff distance: 2162 

Is there something that I am missing?

Topics

Error or problem, How to

Views

41

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Lighting help

New Here ,
Mar 24, 2020

Copy link to clipboard

Copied

I'm fairly new to  Adobe After  Effects. I am trying to light a  3D object. When I add the lights, they aren't seen by the 3D object. I looked  on the forum and saw that it might be a Radius and Falloff problem, so I turned those up and still didn't see a change to my 3D text. My 3D text has Accept lights turned on. My lighting settings are:

Intensity: 100

Cone Angle: 90

Cone Feather: 50

Falloff: Smooth

Radius: 1776

Falloff distance: 2162 

Is there something that I am missing?

Topics

Error or problem, How to

Views

42

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Mar 24, 2020

Copy link to clipboard

Copied

Questions like this without a screenshot showing us the modified properties of your layers are almost impossible to answer. Try this:

  • Create a new comp using one of the Composition presets that give you square pixels and make sure the comp is set to use the Classic 3D rendering engine
  • Add a light gray solid to the timeline and make the layer 3D then duplicate the layer
  • Select the bottom layer and press R to reveal the Rotation Property and rotate the layer 90º in X then move the layer down near the bottom of the composition
  • Select the Rectangle tool and create a vertical mask on the top copy of the solid so it now looks like a tall pole passing through the other solid
  • Add a point light or a spotlight to the scene 
  • Set up 2 views in the Comp Panel and set one of them to Custom 1 and make sure the other is Active Camera
  • If you don't see a shadow press UU to reveal all modified properties of all layers then fix the properties you see so they look like this:

Screenshot_2020-03-24 12.39.37_GpbcUy.png

This screenshot shows all of the modified properties of all layers. In order for a layer to cast a shadow, cast shadows must be turned on for the light and the layer casting the shadow. Cast Shadows is off by default, but if you turn it on AE will remember the setting next time you make a layer 3D or add a new light to the scene. The color of the layer that is receiving the shadow is also important.

 

I hope this helps. If you are new to AE I strongly suggest that you check the user guide tutorials: Learn AE. They are a lot more effective than about 80% of the tutorials you find on YouTube because the folks that posted them know what they are doing. I spend a bunch of time troubleshooting comps from forum users when they try and follow tutorials posted by well-meaning enthusiasts that don't really know what they are doing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 26, 2020

Copy link to clipboard

Copied

I followed your steps, and they work great in other files except in this particular file. Attached are the screenshots.  The problem is that I'm not seeing this light anywhere.

Screen Shot 2020-03-26 at 10.25.20 AM.pngScreen Shot 2020-03-26 at 10.26.08 AM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mylenium LATEST
Most Valuable Participant ,
Mar 26, 2020

Copy link to clipboard

Copied

Your timeline is set to "Draft 3D" which of course will not give detailed shading and only a simplified version. Turn it off and everything will be back to normal.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...