Highlighted

Masks no longer functioning [AE]

New Here ,
Oct 07, 2020

Copy link to clipboard

Copied

I have been working on an illustration seratically for about 3 months now, finally sat down to work on it agin after a month away, and all of the masks on my Shape Layer, turned 3D have stopped working! 

 

I have restared.

Emptied cashe and media dish.

Updated to 16.1.3 (was created in a 16. version)

Updated to 17.1.4

 

Nothing. Works.

 

I have even tried creating a new document, make a layer, add a mask, shift it a bit, then turn the layer 3D and BOOM! no more functioning mask.

 

[Not only that my layers that are guide layers inside of pre-comps are being seen outside, and no edges are smoothing out even on full res. ]

 

Seriously, I left it fine a month ago, and suddenly its a wreck!Screen Shot 2020-10-07 at 6.43.16 PM.pngScreen Shot 2020-10-07 at 6.43.25 PM.png

TOPICS
Error or problem

Views

110

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Masks no longer functioning [AE]

New Here ,
Oct 07, 2020

Copy link to clipboard

Copied

I have been working on an illustration seratically for about 3 months now, finally sat down to work on it agin after a month away, and all of the masks on my Shape Layer, turned 3D have stopped working! 

 

I have restared.

Emptied cashe and media dish.

Updated to 16.1.3 (was created in a 16. version)

Updated to 17.1.4

 

Nothing. Works.

 

I have even tried creating a new document, make a layer, add a mask, shift it a bit, then turn the layer 3D and BOOM! no more functioning mask.

 

[Not only that my layers that are guide layers inside of pre-comps are being seen outside, and no edges are smoothing out even on full res. ]

 

Seriously, I left it fine a month ago, and suddenly its a wreck!Screen Shot 2020-10-07 at 6.43.16 PM.pngScreen Shot 2020-10-07 at 6.43.25 PM.png

TOPICS
Error or problem

Views

111

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 07, 2020 0
Adobe Community Professional ,
Oct 07, 2020

Copy link to clipboard

Copied

Go to Composition > Composition settings. Under the 3D Renderer Tab check if you have selected the Cinema 4D renderer. In this case, change it to Classic 3D.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 07, 2020 0
New Here ,
Oct 07, 2020

Copy link to clipboard

Copied

Nope. It's at Classic 3D....

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 07, 2020 0
Adobe Community Professional ,
Oct 07, 2020

Copy link to clipboard

Copied

Can you share a project file that demonstrates the issue?

Does this file work? https://www.dropbox.com/s/qddvb6b21zdfrty/Masking%20shapes.aep?dl=0

 

Edit: I must say I'm curious why you're using masks for this and not using the merge paths options in shape layers...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 07, 2020 0
Adobe Community Professional ,
Oct 07, 2020

Copy link to clipboard

Copied

Your cropped screenshots do not show us anything. 

 

Select the layer with the mask, press 'uu' to reveal all modified properties, take a screenshot of the entire UI including the timeline showing everything on the layer. Make sure that the comp is selected in the Project Panel so we can see the settings and make sure that the switches and modes columns are both visible by selecting the first two icons at the bottom of the timeline. 

 

There's about a 90% chance this is a user error that will be obvious when you reveal the modified properties of the layer giving you problems.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 07, 2020 0
New Here ,
Oct 09, 2020

Copy link to clipboard

Copied

(Full time job wrapped up for the week so now I can turn back to my file...)

 

I downloaded the file from Szalam and I had no issue with the mask, but continued to have the issue with my file and when I created a new file.

 

Here are screen shots of it again.

 

Screen Shot 2020-10-09 at 7.24.34 PM.pngScreen Shot 2020-10-09 at 7.24.45 PM.png

(I did the UU thing, but the timeline doesn't really exist. It is only 1 frame long.)

 

Somehow the bland mode disappear when I make the layer 3D .... which does NOT happen in the file from Szalam so I think that is the issue, but I don't know why it is happening.

 

Litterally nothing else is changed, but this is an extreemly frustrating glitch that has popped into my AE.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2020 0
Adobe Community Professional ,
Oct 10, 2020

Copy link to clipboard

Copied

You lose masks and effects along with blend modes when you use the C4D rendering engine. The complete list of things that go away is shown when you enable that rendering engine. Go back to the Classic 3D rendering engine and all of the missing properties come back. 

Screenshot_2020-07-12 11.36.52_xN07vc.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 10, 2020 0
Szalam LATEST
Adobe Community Professional ,
Oct 10, 2020

Copy link to clipboard

Copied

I know you said earlier that your renderer was set to classic 3d and not the Cinema 4D renderer, but your screenshot shows that is IS, in fact, using the Cinema 4D renderer. As Rick said (and @Jose Panadero in the very first post was calling out), you need to change to the classic renderer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 10, 2020 0