Mocha AE 2019 Plugin - tracking fail

New Here ,
Dec 18, 2018

Copy link to clipboard

Copied

Hi!

I'm trying to track a footage in the new Mocha AE 2019 plugin. Everything seems fine until i try to import the track motion into After Effects.

When you hit the "Create Track Data" button, it was supposed to import the keyframes from mocha, into the layer you're trying to apply to, but nothing happens with my composition. I can apply an mask following the path i did in mocha, but the tracking just doesn't work.

What can i be doing wrong?

Views

5.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Mocha AE 2019 Plugin - tracking fail

New Here ,
Dec 18, 2018

Copy link to clipboard

Copied

Hi!

I'm trying to track a footage in the new Mocha AE 2019 plugin. Everything seems fine until i try to import the track motion into After Effects.

When you hit the "Create Track Data" button, it was supposed to import the keyframes from mocha, into the layer you're trying to apply to, but nothing happens with my composition. I can apply an mask following the path i did in mocha, but the tracking just doesn't work.

What can i be doing wrong?

Views

5.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 18, 2018 0
Adobe Community Professional ,
Dec 18, 2018

Copy link to clipboard

Copied

Once you have selected the tracker in the Create Track Data button, you must use the Export Option and Layer Export to options in order to use the tracked data in any of your layers and the click the Apply Export button.

Captura de pantalla 2018-12-18 a las 22.01.33.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2018 1
New Here ,
Dec 18, 2018

Copy link to clipboard

Copied

Thanks, Jose Panadero, but i might have not being so clear.

I saw this Boris FX video and when she creates "Track Data", the After Effects automatically imports the keyframes from Mocha, and then you can apply it in other layer to attach into your footage. But when i try to do the same, i have no single keyframe from the tracking and, even if i try to "Apply Export", my target would hold stand still, cause there's no parameters for it to follows.

This might be a strange error or i'm doing something wrong in the tracking process, but i've made no different thing from the older versions...  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2018 1
Adobe Community Professional ,
Dec 18, 2018

Copy link to clipboard

Copied

It's user error, not a bug. Mocha AE caught me the first time too. You have to make sure that you select the layer you have tracked and that the layer is active (gear is showing) before any data is copied.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2018 2
New Here ,
Feb 24, 2019

Copy link to clipboard

Copied

I have selected it propperly and it still won't export the tracking data, any other suggestions?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2019 0
Adobe Community Professional ,
Feb 24, 2019

Copy link to clipboard

Copied

Once you have selected the Tracking Data, you must select the Layer Export to and the type of data you want to add to the destination Layer and click the Apply Export Button. Check the image in my previous post

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2019 0
Most Valuable Participant ,
Mar 16, 2019

Copy link to clipboard

Copied

make sure your Ae is updated 16.0.1. and show us some screenshots of your timeline after you selected the layers and typed UU to reveal all modified properties. if you can record your process that will be better.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 16, 2019 0
New Here ,
Jul 30, 2019

Copy link to clipboard

Copied

This worked. Having the gear checked works.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 30, 2019 2
New Here ,
Sep 13, 2019

Copy link to clipboard

Copied

Hi! When I track in Mocha ae it does not transmit tracking with video

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 13, 2019 0
New Here ,
Apr 01, 2019

Copy link to clipboard

Copied

Yo brother! I found the answer!
When you export the tracking data, a new window open, you have to select the layer with the data, and CHECK the little engine at the left side of the box. That´s the secret!
I almost spend 2 days in this shit! Its simpler than we thought!

Greetings!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 01, 2019 2
Community Beginner ,
Apr 10, 2019

Copy link to clipboard

Copied

This is the answer! When you select the layer in the pop-up window you need to hit the blank space to the left of the layer to activate it ( make a gear icon appear), then press ok and it will behave as expected and populate the pins with tracking data keyframes.

It appears to be a design flaw, not human error, as finding that box was not intuitive at all. I'd like to request a ghosted gear if not activated in the next update, or a more intuitive menu in that pop-up.

That being said, I'm loving the new simplified mocha setup that is fully integrated into AE rather than the earlier setup.

Thank you Daniel for sharing this info! You saved me an unknown amount of frustration.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2019 0
New Here ,
May 25, 2019

Copy link to clipboard

Copied

Hi, Im having the same exact problem and mine is not as simple as clicking the gear icon. I have done this several times and nothing works. I am almost positive that this is a glitch as I have spent 3 hours now watching tutorials and I am FURIOUS!

So here are screen shots + steps.

1. Tracked my screen in mocha using spline tool.

2. Saved the tracking data, closed mocha.

3. Open AE, I see mocha tracking data in the original footage

Screen Shot 2019-05-25 at 5.10.20 AM.png

4. I click "Create Tracking Data", and I make sure the gear box is selected.

Screen Shot 2019-05-25 at 5.11.39 AM.png

5. Next I configure my settings, setting it up so that the tracking data is sent to the image im using to replace the screen with. And the replacement screen layer is selected under the output (the replacement screen layer as been pre comped and fit to frame size)

Screen Shot 2019-05-25 at 5.12.23 AM.png

6. I press, "Apply Export" then I rip my hair out because the key frame tracking data still is not inserted. WHAT THE HELL!!!

Screen Shot 2019-05-25 at 5.13.46 AM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 25, 2019 0
Explorer ,
May 28, 2019

Copy link to clipboard

Copied

When you select "Create Track Data" does it actually create keyframes? If you are still having issues, you may want to open a case at Boris FX support portal: https://borisfx.com/support/open-a-case/

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 28, 2019 0
Community Beginner ,
May 28, 2019

Copy link to clipboard

Copied

malcolmg83716917malcolmg83716917I had the same problem you did. Where you only get keyframes for the first frame. You can see mocha is tracking your object but it just isn't applying the keyframes to the rest of the clip. My clip was speed reversed in Premiere Pro. Once I brought it into After Effects I un reversed the speed. That messed everything up. Once I deleted the speed reverse in PPro and brought it back into After Effects everything worked. I noticed you are tracking a comp. I wonder if you have to track just the clip. Give that a go and let us know if it worked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 28, 2019 1
Community Beginner ,
Jun 03, 2019

Copy link to clipboard

Copied

I just spent a couple hours trying to stabilize a clip with Mocha AE CC.  Turns out that it won't work if you have time reversed a layer at any point before tracking, even if you un-reverse if before doing so.  I have to grab a fresh instance of the clip from my project panel.  Then it worked fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 03, 2019 1
Adobe Employee ,
Jul 30, 2019

Copy link to clipboard

Copied

Thanks for sharing your workaround, Oczkowski.

It would be great to have your issue raised over on User Voice.

If you have time to do so, that would be great!

After Effects: Hot (1794 ideas) – Adobe video & audio apps

Regards,
Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 30, 2019 0
New Here ,
Sep 22, 2020

Copy link to clipboard

Copied

my Captura de Tela 2020-09-22 às 17.21.53.pnglayer just doesn't appear, I've tried everything. But only that happens

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2020 0