Highlighted

My after effects preview stops playing sound part way through the preview

New Here ,
Aug 29, 2020

Copy link to clipboard

Copied

When I try and preview my edit, it will preview the video and the sound and then randomly, the audio will stop playing while the video continues. Some times if I take away effects it plays a tiny bit better. It will preview with sound and video, then stop playing the sound but continue playing the video, then after previewing for a little bit it will resume and play audio again till it eventually stops playing audio again. I have no idea whats up, does anybody have any suggestions? I have Mac book pro 8 GB ram. Any help is appreciated!!!

My version of After effects is 14.0.1.5 ( 2017 AE )

Topics

Audio, Preview

Views

86

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

My after effects preview stops playing sound part way through the preview

New Here ,
Aug 29, 2020

Copy link to clipboard

Copied

When I try and preview my edit, it will preview the video and the sound and then randomly, the audio will stop playing while the video continues. Some times if I take away effects it plays a tiny bit better. It will preview with sound and video, then stop playing the sound but continue playing the video, then after previewing for a little bit it will resume and play audio again till it eventually stops playing audio again. I have no idea whats up, does anybody have any suggestions? I have Mac book pro 8 GB ram. Any help is appreciated!!!

My version of After effects is 14.0.1.5 ( 2017 AE )

Topics

Audio, Preview

Views

87

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Aug 29, 2020

Copy link to clipboard

Copied

Did you tried to make preview in another computer? Perhaps you need more RAM to make a good preview if you are inserted too much effects.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 29, 2020

Copy link to clipboard

Copied

As Byron noted, you're scraping by on the minimum viable amount of RAM for After Effects, which means you're not going to get great performance. 

If you're not already, please take a look at reducing your preview resolution or frame rate - After Effects isn't necessarily intended to be blasting out full-quality previews all the time. You can change these settings in your Preview panel.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 29, 2020

Copy link to clipboard

Copied

Sounds like you're using Spacebar for your Previews at the default settings.

 

As Kyle suggested above, you'll want to customize the Preview settings in the Preview tab to better match your MacBook Pro's performance.  

 

Or leave the default settings and do the following when you're ready to do a preview:

  • Set your Comp Resolution to Half (command shift j) or to Quarter (command option shift j) then press Shift Spacebar to skip frames.  With this approach, you're trading image quality and smooth motion for longer Previews.
  • When you stop the preview, set the Comp Resolution to Full (command j) to make adjustments.

 

Since you only have 8GB of RAM, also make sure that as few other applications are open as possible while you're working in AE.

 

Also, consider creating a custom Output Module for rendering preview movies.  I like to use Apple ProRes422 Proxy for preview renders.  It renders quickly, has a very good image quality, a modest file size and plays back smoothly/

 

When you're ready to upgrade your MacBook Pro, try to get at least 16GB of RAM.  If you're using AE on a regular basis, try to go with a model that supports 32GB or more.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 30, 2020

Copy link to clipboard

Copied

Thank you for the replies! So i tried a little bit of everything meantioned by everyone. i set all preview to the lowest setting which is quater, and i set the frames to 8, and it is still giving me the same problem. at first it previewed just fine then i decided to play it again and then 4 seconds later the audio cut out again. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 31, 2020

Copy link to clipboard

Copied

Hello TSNBN:

 

I think I miss-read your issue.  Would it be correct to say that you're having intermittent audio issues with your Preview?  

 

It could still be a low RAM issue, but AE usually stops playing picture and sound rather than just sound.

 

If you export a movie file, does the audio export with it from start to finish as expected?

 

If you do a Preview with just audio (disable the Eye icon in the Preview panel or Solo the audio layer in the Comp and hide the video if needed), does the audio then play as expected?

 

Another troubleshooting step is to start a new project and import just the audio.  Add that to a Comp and see how that previews.  If that works, then you know there's something going on with the AEP.  If that does not work, then you know it's probably something with After Effects.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 31, 2020

Copy link to clipboard

Copied

You could also try converting your audio file format and replacing its use in the AE project.  So, if you're currently using MP3, try AIF.  There's less overhead for an AIF (no decompression).  There's a chance that that's enough to let AE devote resources to something else.  Of course, if it starts to play in the 1st place, you'd think it would always play.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 01, 2020

Copy link to clipboard

Copied

Yes intermediate audio is exactly it. Yes the file renders completly fine with the audio intact. And i tired disabliing the video for the preview and it still gave me the same problems. So i ended up starting a new project, then adding the same video/audio, and i did not put my own personal composition settings and it seems to be previewing just fine, so it must be something with my composition settings some how, i dont understand what it is about it, but so far... its working! And in your most recent reply, you meantioned converting my audio file formant, how would i do that? is that something to be down inside AE or via third party. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 01, 2020

Copy link to clipboard

Copied

I just added the time stretch to my audio file and then the preview started having the same issues, that is then a RAM issue correct? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...