Highlighted

Particules for a Synthesia video, please help!

New Here ,
Apr 16, 2020

Copy link to clipboard

Copied

Hello! 

I know this has been asked already but I am really struggling to make it work. I want to add particles to my synthesia video. Preferably they would emit when the blue synthesia tiles reach the the piano keys. https://www.youtube.com/watch?v=LSwXh1Y5thY

 

I tried different approaches, the first one was suggested by Rick_Gerard in this thread: https://community.adobe.com/t5/after-effects/particles-to-start-when-mask-hits/td-p/10168387?page=1

I tried to implement it but I'm not that well versed with AE. 

 

Screenshot (114).pngScreenshot (111).pngScreenshot (112).png

 

 

Then I tried towerguys solution: https://community.adobe.com/t5/after-effects/particles-with-synthesia/td-p/10014109?page=1&profile.l...

 

 

Screenshot (115).pngAnd this happensAnd this happens

 

Does anyone know a solution to this? I'm pouring so much time in and not getting anywhere, would really appreciate your help. 

 

 

Sheet music: https://www.musicnotes.com/l/M6gwp Click the 🔔bell to join the notification squad! ♫ Listen on Spotify: http://spoti.fi/2LdpqK7 ♫ MIDI: https://...
Adobe Community Professional
Correct answer by Rick Gerard | Adobe Community Professional

The emitter type Particular, should be set to Spotlight, you have it set to Layer Mask. 

 

The spotlight does not appear to be positioned over any of the piano roll notes so it is never going to have the intensity controlled by the color channel of the Piano Roll layer. 

 

I don't see a layer named "Piano Roll" for the light's intensity expression to look at. 

 

Position the light right over one of the moving blue lines, make sure the layer with the moving blue lines is named "Piano Roll" and Set the Emitter to use the Light by making sure that the name is correct and you should get a stream of particles emitting from the light when there are particles with a green value of greater than .5. I didn't sample the color of your piano roll and I don't know if the layer has transparency, so you might also need to change the expression to look at the blue channel by changing the expression so that Sample Point looks at blue. The edited expression would change to this:

target = thisComp.layer("Piano Roll");
sample = position;
point = [sample[0], sample[1]];
sw = target.sampleImage(point, radius = [.5, .5], postEffect = true, t = time)[2];
if (sw > .5) {100} else [0];

The [2] at the end of the line that begins with sw= refers to the Blue Channel. [0] is red, [1] is green, [2] is blue, and [3] is Alpha. 

 

These are the properties you will have to modify in Particular:

Screenshot_2020-04-16 11.32.55_AjkmQv.png

That should get you started.

 

One more thing. The lights do not have to be on to work as emitters. Turning them off will speed up render time if you have any other 3D layers in the Comp and it will keep them from fouling up the lighting on the other 3D layers. 

 

So, fix the light names to start with Emitter, change the Emitter and other properties for Particular as shown in the screenshot, make sure that there is a layer named Piano Roll in the comp that has moving patches of color that you can sample, and make sure that the light is positioned over one of the colors you want to sample and you should have it.

TOPICS
How to

Views

85

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Particules for a Synthesia video, please help!

New Here ,
Apr 16, 2020

Copy link to clipboard

Copied

Hello! 

I know this has been asked already but I am really struggling to make it work. I want to add particles to my synthesia video. Preferably they would emit when the blue synthesia tiles reach the the piano keys. https://www.youtube.com/watch?v=LSwXh1Y5thY

 

I tried different approaches, the first one was suggested by Rick_Gerard in this thread: https://community.adobe.com/t5/after-effects/particles-to-start-when-mask-hits/td-p/10168387?page=1

I tried to implement it but I'm not that well versed with AE. 

 

Screenshot (114).pngScreenshot (111).pngScreenshot (112).png

 

 

Then I tried towerguys solution: https://community.adobe.com/t5/after-effects/particles-with-synthesia/td-p/10014109?page=1&profile.l...

 

 

Screenshot (115).pngAnd this happensAnd this happens

 

Does anyone know a solution to this? I'm pouring so much time in and not getting anywhere, would really appreciate your help. 

 

 

Sheet music: https://www.musicnotes.com/l/M6gwp Click the 🔔bell to join the notification squad! ♫ Listen on Spotify: http://spoti.fi/2LdpqK7 ♫ MIDI: https://...
Adobe Community Professional
Correct answer by Rick Gerard | Adobe Community Professional

The emitter type Particular, should be set to Spotlight, you have it set to Layer Mask. 

 

The spotlight does not appear to be positioned over any of the piano roll notes so it is never going to have the intensity controlled by the color channel of the Piano Roll layer. 

 

I don't see a layer named "Piano Roll" for the light's intensity expression to look at. 

 

Position the light right over one of the moving blue lines, make sure the layer with the moving blue lines is named "Piano Roll" and Set the Emitter to use the Light by making sure that the name is correct and you should get a stream of particles emitting from the light when there are particles with a green value of greater than .5. I didn't sample the color of your piano roll and I don't know if the layer has transparency, so you might also need to change the expression to look at the blue channel by changing the expression so that Sample Point looks at blue. The edited expression would change to this:

target = thisComp.layer("Piano Roll");
sample = position;
point = [sample[0], sample[1]];
sw = target.sampleImage(point, radius = [.5, .5], postEffect = true, t = time)[2];
if (sw > .5) {100} else [0];

The [2] at the end of the line that begins with sw= refers to the Blue Channel. [0] is red, [1] is green, [2] is blue, and [3] is Alpha. 

 

These are the properties you will have to modify in Particular:

Screenshot_2020-04-16 11.32.55_AjkmQv.png

That should get you started.

 

One more thing. The lights do not have to be on to work as emitters. Turning them off will speed up render time if you have any other 3D layers in the Comp and it will keep them from fouling up the lighting on the other 3D layers. 

 

So, fix the light names to start with Emitter, change the Emitter and other properties for Particular as shown in the screenshot, make sure that there is a layer named Piano Roll in the comp that has moving patches of color that you can sample, and make sure that the light is positioned over one of the colors you want to sample and you should have it.

TOPICS
How to

Views

86

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 16, 2020 0
Adobe Community Professional ,
Apr 16, 2020

Copy link to clipboard

Copied

The emitter type Particular, should be set to Spotlight, you have it set to Layer Mask. 

 

The spotlight does not appear to be positioned over any of the piano roll notes so it is never going to have the intensity controlled by the color channel of the Piano Roll layer. 

 

I don't see a layer named "Piano Roll" for the light's intensity expression to look at. 

 

Position the light right over one of the moving blue lines, make sure the layer with the moving blue lines is named "Piano Roll" and Set the Emitter to use the Light by making sure that the name is correct and you should get a stream of particles emitting from the light when there are particles with a green value of greater than .5. I didn't sample the color of your piano roll and I don't know if the layer has transparency, so you might also need to change the expression to look at the blue channel by changing the expression so that Sample Point looks at blue. The edited expression would change to this:

target = thisComp.layer("Piano Roll");
sample = position;
point = [sample[0], sample[1]];
sw = target.sampleImage(point, radius = [.5, .5], postEffect = true, t = time)[2];
if (sw > .5) {100} else [0];

The [2] at the end of the line that begins with sw= refers to the Blue Channel. [0] is red, [1] is green, [2] is blue, and [3] is Alpha. 

 

These are the properties you will have to modify in Particular:

Screenshot_2020-04-16 11.32.55_AjkmQv.png

That should get you started.

 

One more thing. The lights do not have to be on to work as emitters. Turning them off will speed up render time if you have any other 3D layers in the Comp and it will keep them from fouling up the lighting on the other 3D layers. 

 

So, fix the light names to start with Emitter, change the Emitter and other properties for Particular as shown in the screenshot, make sure that there is a layer named Piano Roll in the comp that has moving patches of color that you can sample, and make sure that the light is positioned over one of the colors you want to sample and you should have it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2020 0
New Here ,
Apr 16, 2020

Copy link to clipboard

Copied

Hey Rick,

Thanks so much for answering, it really helped a lot. It seems like I got the emission of the particles to work. They start when the tile hits the piano Keyboard. I found a sweet spot for the spotlight where it works, however when I pull the spotlight down to the keyboard it stops emitting particles. 

 

Screenshot (117).pngScreenshot (118).png

 

Most of the particles are also being emitted in a ball shape, even though I changed it to directional (just a small amount gets emitted directionally). I tried to remedy that with the design feature but it's not really working. 

 

Screenshot (120).png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2020 0
Adobe Community Professional ,
Apr 16, 2020

Copy link to clipboard

Copied

Particular is a difficult plugin to understand until you have to spend a lot of time on the RedGiant site looking at the tutorials. You can make particles do just about anything you want, you just need to spend a couple of hours at the RG site looking at tutorials for Particular. Just do a search or spin down the selector and choose Particular.

Screenshot_2020-04-16 19.00.33_dLRnKf.png

If you copy the settings that I show for Particular that I show in the screenshot of the timeline you'll get the particles flying up the way they are in my earlier screenshots.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2020 0
New Here ,
Apr 16, 2020

Copy link to clipboard

Copied

Okay will do, Thanks a lot. Do you know how I can fix the spotlight problem? Is the part that samples the colours too small? It only works in that specific spot but doesn't spawn any particles if I pull it down to the keyboard.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2020 0
New Here ,
Apr 16, 2020

Copy link to clipboard

Copied

Right here it doesn't spawn particles even though the spotlight is right over the blue bar.

 

Screenshot (121).png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2020 0
Adobe Community Professional ,
Apr 17, 2020

Copy link to clipboard

Copied

Your expression is sampling the blue channel.  The very first thing you should do when an expression is not working is to turn the expression off and see what that does. Turning the expression off for the Intensity of the light should return the value to 100 and start the stream of particles. If setting the Spotlight Intensity to 100 does not start the stream of particles then the emitter is not properly set up in Particular. 

 

I suspect that the larger blue bars are the result of an effect and they may not be on the same layer as the Piano Roll. The layer could also have its position changed.

 

A few minutes with the User Guide will help you understand how the UI works and the section on expressions will help you understand what expressions are really doing. I am taking a mental health break from an extremely tedious project that is requiring hundreds of adjustments in several frames so I'll explain the expression to you and maybe that will help. I simplified the expression and set it to sample blue:

 

 

target = thisComp.layer("Piano Roll");//The layer where the color is
point = position;// This layer's position
sample = target.sampleImage(point, radius = [.5, .5], postEffect = true, t = time)[2];
if (sample > .5) {100} else [0];

 

 

This is a line by line breakdown of the expression:

  • The first line declares the target value by starting in this comp, then finding the layer named Piano Roll. 
  • The second line only needs to look at the current layer to define the point as the position of this layer. If you changed the definition of point to target.position the point value would be the position of the Piano Roll layer.
  • The third line defines the value of the sample by starting with the target, which is the Piano Roll layer, then pulls the color (the sampleImage method) the layer by looking at the point (this layer's position) averaging the color values in a 1-pixel diameter circle, after any effects are applied, at the current time, and returning the value of the blue channel. The array for color is [R, G, B, A] or [0, 1, 2, 3] and the normal range is a value between zero and 1. There is no provision in the sampleImage method to compensate for a change in the position of the target layer because the position of the sample is based on the layer's space in the comp, not the relationship between the target's position and the sample position. I hope that made sense.
  • the last line simply says if the value of the blue channel is greater than .5 the output should be 100, if it is not then the output is zero.

I hope that helps. I think your Piano Roll layer is just out of position or the emitter is not set up properly.

 

Just thought of another troubleshooting trick. Try applying the expression in this post to the Source Text property of a text layer, then move the layer around in the comp panel. You will be able to see exactly where the sample is being taken from as the text changes from zero to 100.

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 17, 2020 0
New Here ,
Apr 17, 2020

Copy link to clipboard

Copied

Hey Rick, I set it to [3] with a sensitivity of 0.65 since the darker blue colour has a value of .64. But it starts generating particles straight away, without it ever getting a sample. Even when it's on the black background (B value is at .01 there)  it is generating particles and it says intensity 100%

 

Screenshot (123).png

 

Thanks so much!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 17, 2020 0
Adobe Community Professional ,
Apr 17, 2020

Copy link to clipboard

Copied

You have set the color sample to the alpha channel. 0 is red, 1is green, 2 is blue, 3 is alpha. Alpha will always be white or 1.000 unless there is some transparency in the comp. That is the easiest explanation of the intensity being set to 100.

 

I would not set the threshold so close to the blue value. If the sampled value using the Info Panel is .64 and you set the threshold to .65 then the value never gets to 65 to make the change in values. Your light would always be off. A value of .5 or even .4 would do just fine. The threshold just needs to be higher than the Blue value of the background layer but lower than the average color of the blue line.

 

Here are other potential problems and the solution:

Your Piano Roll layer may be out of position. The fix is to Solo the Piano Roll, light, and Particular layers so they are the only layers visible in the comp panel, select all 3 and press the 'u' key twice to show all modified properties. Check the position of the Piano roll layer and reset it if it is not centered in the comp. If you still have problems turn off all effects in the piano roll layer. 

 

If the Piano Roll layer has been moved but you need it to stay where it is then you can fix the problem very quickly by just pre-composing the layer moving all attributes to the new composition. The position of the blue lines will now match up with the comp space position values.

 

Another thing that could go happens if you parent the light to another layer. That immediately changes the position value of the child layer to 0, 0. I'm assuming that Ohne means None so parenting is not the problem. If it is a problem and you need to keep the light the child of another layer then you need to apply layer-space transformations to the light layer's position to correct the problem. I won't go through that solution unless you have parented your light layer to another layer.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 17, 2020 0
New Here ,
Apr 17, 2020

Copy link to clipboard

Copied

Okay, I did everything you said but even though it's on [2] now and the colour value is way higher than the asked value it still doesn't spawn particles or only spawns them when I move the spotlight away to a different spot, weird. 

thx rick 

 

Screenshot (124).png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 17, 2020 0
Adobe Community Professional ,
Apr 18, 2020

Copy link to clipboard

Copied

If the spotlight intensity changes to 100 when it is not over a blue line then the Position, Ancor Point or Scale of the Piano Roll layer has been changed. Select the Piano Roll layer and press the 'u' key twice to reveal all modified properties. If Position, Scale, or Anchor Point show then you need to make sure the layer Piano Roll layer is selected and Pre-compose moving all attributes to the new comp. The position errors will go away.  I've explained this at least twice in this thread.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 18, 2020 0