Highlighted

Pixelated Text

New Here ,
Aug 14, 2017

Copy link to clipboard

Copied

Whenever I try to add a text layer to my composition it Is super pixelated and looks terrible!!

What can I do to fix this

Adobe Community Professional
Correct answer by Rick Gerard | Adobe Community Professional

If you are on a windows machine do this:

  1. Make sure the magnification ratio of the composition panel is set to 100%
  2. Make sure Comp Resolution is set to AUTO
  3. Select the text layer that is giving you problems and press the U key twice to reveal all modified properties
  4. Make sure that the character panel is active and shows the properties of the text layer
  5. Make sure your composition is selected in the Project Panel so we can see the settings
  6. PrintScreen
  7. Return to the forum and paste (Ctrl + V) to show us your screen shot.

If you are on a Mac create a screenshot by pressing Shift + Ctrl/Cmnd + 3 and drag it to the reply field.

Now we can see what you see and everything should be easy to diagnose and fix. The most likely cause of pixelated text is that the Magnification Ratio is set to something like 800% and you are using a very small font. If this is the case you don't understand the AE UI or how video works and you need to do some studying.

There are other problems with small fonts that can be caused by color values that are way out of spec, white text against a black background or small thin text not properly lined up with the pixel grid but these don't usually show up until you render. There are also problems with moving text when it is small and doesn't move precisely an whole number of pixels every frame.

If you don't know what I'm talking about in the instructions take some time to study and learn the user interface.

Views

6.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Pixelated Text

New Here ,
Aug 14, 2017

Copy link to clipboard

Copied

Whenever I try to add a text layer to my composition it Is super pixelated and looks terrible!!

What can I do to fix this

Adobe Community Professional
Correct answer by Rick Gerard | Adobe Community Professional

If you are on a windows machine do this:

  1. Make sure the magnification ratio of the composition panel is set to 100%
  2. Make sure Comp Resolution is set to AUTO
  3. Select the text layer that is giving you problems and press the U key twice to reveal all modified properties
  4. Make sure that the character panel is active and shows the properties of the text layer
  5. Make sure your composition is selected in the Project Panel so we can see the settings
  6. PrintScreen
  7. Return to the forum and paste (Ctrl + V) to show us your screen shot.

If you are on a Mac create a screenshot by pressing Shift + Ctrl/Cmnd + 3 and drag it to the reply field.

Now we can see what you see and everything should be easy to diagnose and fix. The most likely cause of pixelated text is that the Magnification Ratio is set to something like 800% and you are using a very small font. If this is the case you don't understand the AE UI or how video works and you need to do some studying.

There are other problems with small fonts that can be caused by color values that are way out of spec, white text against a black background or small thin text not properly lined up with the pixel grid but these don't usually show up until you render. There are also problems with moving text when it is small and doesn't move precisely an whole number of pixels every frame.

If you don't know what I'm talking about in the instructions take some time to study and learn the user interface.

Views

6.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Aug 14, 2017

Copy link to clipboard

Copied

The most common reason for this is the comp resolution setting.  It5 may be at Half, Third or Quarter.  Change it to Full and the text should look better.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 14, 2017

Copy link to clipboard

Copied

It's at full and it still is pixelated!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Aug 14, 2017

Copy link to clipboard

Copied

Are you in Draft mode?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 14, 2017

Copy link to clipboard

Copied

How do I check that?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Aug 14, 2017

Copy link to clipboard

Copied

Look at the layer in the timeline.  You see the switch that looks like a dotted backslash?  It needs to be a forwards slash

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 14, 2017

Copy link to clipboard

Copied

If you are on a windows machine do this:

  1. Make sure the magnification ratio of the composition panel is set to 100%
  2. Make sure Comp Resolution is set to AUTO
  3. Select the text layer that is giving you problems and press the U key twice to reveal all modified properties
  4. Make sure that the character panel is active and shows the properties of the text layer
  5. Make sure your composition is selected in the Project Panel so we can see the settings
  6. PrintScreen
  7. Return to the forum and paste (Ctrl + V) to show us your screen shot.

If you are on a Mac create a screenshot by pressing Shift + Ctrl/Cmnd + 3 and drag it to the reply field.

Now we can see what you see and everything should be easy to diagnose and fix. The most likely cause of pixelated text is that the Magnification Ratio is set to something like 800% and you are using a very small font. If this is the case you don't understand the AE UI or how video works and you need to do some studying.

There are other problems with small fonts that can be caused by color values that are way out of spec, white text against a black background or small thin text not properly lined up with the pixel grid but these don't usually show up until you render. There are also problems with moving text when it is small and doesn't move precisely an whole number of pixels every frame.

If you don't know what I'm talking about in the instructions take some time to study and learn the user interface.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 16, 2017

Copy link to clipboard

Copied

No need to be a douchbag.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 17, 2017

Copy link to clipboard

Copied

I will try to remember that giving a thorough explanation of how diagnose a problem, show us the problem and recommending some study if they don't understand what I have said makes me a "(deleted misspelled personal insult because I would not want to hurt anyone's feelings)."

Where do I send your participation trophy? Should I have pointed out the spelling error?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 17, 2017

Copy link to clipboard

Copied

No need. Since you do not seem to understand it, I will explain that forums such as this one exist in order for people to ask questions that they do not already know the answers to. In other words, they are fully aware that they lack some knowledge of this or that skill. That is why they are asking questions.

Telling them that they should study is, therefore, entirely redundant; they know that already. That is what they are here for - they are studying.

And, since you seem to new to the world of trolling, I might suggest that you do it elsewhere. This is the "grown-ups table," as it were. Perhaps you would be more rewarded in a YouTube comments section somewhere.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 19, 2017

Copy link to clipboard

Copied

Rick is one of the most respected contributors here in the Adobe After Effects forum. He often writes up extensive and detailed posts complete with screenshots, he creates video tutorials, and all-in-all goes above and beyond every day to help people learn how to use After Effects better. He is not a troll.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 12, 2019

Copy link to clipboard

Copied

Hi Rick,

How are you?

Thanks for your suggestions. I am having the same pixelated error and have carried out all the steps suggested by you and Dave.

Here is my printscreen of Composition settings(which are by default set to Full).

I don't know what I could be doing wrong. I have played around with the text settings. I am following a tutorial online and the only thing different is the fact that Fill Over Stroke is not included(I don't know how to turn this off).

Any ideas would be great.Thanks,Sinead

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jan 12, 2019

Copy link to clipboard

Copied

I'd like you to look at the Comp pane -- the one that shows the actual picture of the composition.  Look at the very bottom of that pane.  You'll find a part that's expressed in a percentage.  If it's set to more than 100%, set it to 100% and see how it looks.  If it's OK, you're good.  You had your Zoom set beyond 100%, and that's how things look when you're zoomed to a high percentage.

And if you did have it set to more than 100% -  I'd say it was set to about 800% -- and you're stumped by a simple setting like that, you really, Really, REALLY need to spend some quality time here:

After Effects tutorials | Learn how to use After Effects CC

You might be able to use Premiere Pro intuitively.  It's possible -- learning PP is like learning to drive the family car.

But you can NOT use AE intuitively.  Learning AE is like learning to fly an F-22 Raptor fighter for combat missions.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 12, 2019

Copy link to clipboard

Copied

Hi Dave,

Thanks for your quick response.

I will try your suggestion tomorrow when back at my PC.

The strange thing is , I am working on my AE on my MacBook Pro and have had none of these issues.

I have done nothing differently.

I am following tutorials on AE with Pluralsight, I don't think any of it is intuitive! I am only learning Photoshop too so its a bit of a whirlwind.

Thanks again and I will post and let you know how I get on.

Sinead

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Feb 12, 2019

Copy link to clipboard

Copied

This solved it for me. Thank you, Dave.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Subik04 LATEST
New Here ,
Apr 04, 2020

Copy link to clipboard

Copied

I think the resolution was changed.

Try this. go to view>resolution>full (ctrl+J)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...