Highlighted

"Invalid Menu Operation" When I try to do almost anything

New Here ,
Nov 02, 2020

Copy link to clipboard

Copied

So I have been working with Adobe After Effects for a while now and I have never encountered a problem until today. I opened it this morning no problem, did some work, closed that file. I then opened a new file and suddenly I am encountering this error everywhere. I can do everything fine when the program first starts, but when I open the file, after about 30 seconds to a minute, it suddenly gives me this error everywhere. Any keyboard shortcut or attempt to click on one of the dropdown menus at the top or right click the composition or footage or anything just brings up a dialogue box that says "AfterEffects Warning - Invalid Menu Operation". I can't do anything. Why the heck is this suddenly happening?

 

For specs, I am running an Intel i7, Nvidia GTX 1660 TI, and 64 gbs of ram. 

TOPICS
Error or problem

Views

164

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

"Invalid Menu Operation" When I try to do almost anything

New Here ,
Nov 02, 2020

Copy link to clipboard

Copied

So I have been working with Adobe After Effects for a while now and I have never encountered a problem until today. I opened it this morning no problem, did some work, closed that file. I then opened a new file and suddenly I am encountering this error everywhere. I can do everything fine when the program first starts, but when I open the file, after about 30 seconds to a minute, it suddenly gives me this error everywhere. Any keyboard shortcut or attempt to click on one of the dropdown menus at the top or right click the composition or footage or anything just brings up a dialogue box that says "AfterEffects Warning - Invalid Menu Operation". I can't do anything. Why the heck is this suddenly happening?

 

For specs, I am running an Intel i7, Nvidia GTX 1660 TI, and 64 gbs of ram. 

TOPICS
Error or problem

Views

165

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 02, 2020 0
Most Valuable Participant ,
Nov 02, 2020

Copy link to clipboard

Copied

Impossible to know, but since you're not the first to report this, I'd assume it's a genuine bug. the most likely cause is probably something going awry with hardware acceleration functions or the caching system going belly up. Start by updating your systems graphics driver, trash the prefs, flush/ delete the caches.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 02, 2020 0
New Here ,
Nov 04, 2020

Copy link to clipboard

Copied

Hey Mylenium,

 

Thanks for the insight. I have reset my prefs and my graphics driver is up to date but I'm still having the problem. I don't exactly know how to flush/delete the caches so if you could elaborate on that, I'll glady give it a try!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2020 0
Adobe Employee ,
Nov 03, 2020

Copy link to clipboard

Copied

Hi Cole5FE8,

 

Welcome to the Community and sorry for your issue with After Effects.

Is this happening specifically with that project or any project that you open? If so, would you mind sharing more details on this project? You can try resetting the preferences of After Effects. Here's how: https://community.adobe.com/t5/after-effects/faq-how-to-reset-trash-preferences-in-after-effects/td-...

Let us know how it goes.

 

Thanks,

Nishu

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2020 0
New Here ,
Nov 04, 2020

Copy link to clipboard

Copied

Hey Nishu,

 

Thanks for the response. I'm having the problem with any project I open. It works for a minute at most and then everything I do seems to trigger the pop up. I followed your link and reset the preferences but I'm still having the issue. If you'd like I can give more details on the projects I've tried, but they are all about the same - 1920 by 1080, either 24 or 30 fps, and default settings otherwise.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2020 0
Adobe Employee ,
Nov 05, 2020

Copy link to clipboard

Copied

Thanks for getting back.

Please try the suggestion mentioned in the following Community thread: https://community.adobe.com/t5/after-effects/error-quot-invalid-menu-operation-quot-when-scripting/t...

Let us know if it helps.

 

Thanks,

Nishu

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 05, 2020 0
New Here ,
Nov 06, 2020

Copy link to clipboard

Copied

Hey Nishu,

 

I looked at that community post but I'm not using scripts like they mentioned. Nonetheless, I did try what they mentioned and tried pre-composing one of my projects but I couldn't get the menu to do so. It just keeps giving me the error when I try to right click the layers or click one of the dropdown menus. I tried a project with less layers and it didn't change anything. However, the problem has changed slightly recently. 

After clearing my prefs like suggested and rebooting the computer, I was actually able to get a project working (a Team Project for school), but the problem is still intermittent. It works sometimes, and sometimes I still get the error in which case I have to reboot After Effects and I can sometimes get it to work again. Hope this new info helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2020 0
New Here ,
Nov 06, 2020

Copy link to clipboard

Copied

Update

 

Ok, so I'm beginning to understand the problem a little more I think. The majority of the time, the problem seems to happen if I try to open After Effects by opening a project. For example, if I try to open After Effects through a dynamic link from Premiere, the project opens but I immediately encounter the issue. Likewise, if I open After Effects first and then open the project I want from inside After Effects, the probability of the problem occuring drops dramatically. In this fashion, I am actually able to get some work done but this problem is still incredibly frustrating and hindering, so I hope this new info can help find the solution.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2020 0
New Here ,
Nov 10, 2020

Copy link to clipboard

Copied

This is also happening to me, but unfortunatley all buttons and actions lead to the error. I can't even use hotkeys without running into the error. I rolled back to 17.2 and that has fixed my issue so far.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2020 0
New Here ,
Nov 11, 2020

Copy link to clipboard

Copied

I'll have to give that a try and see if it works then. Thanks lastrachris

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 11, 2020 0
New Here ,
Nov 24, 2020

Copy link to clipboard

Copied

Solving the problem:

1 - Open your Creative Clound Desktop
2 - Search for After Effects
3 - Holding ALT + CTRL + SHIFT (win) or OPTION + SHIFT + CMND (mac), click "open"
4 - A message "Are you sure you want to delete your preferences file?" Will open. Click "OK".

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 24, 2020 1
New Here ,
Nov 25, 2020

Copy link to clipboard

Copied

Same issue, couldn't click a single thing without getting the popup, but this (deleting preferences file) worked for me!

 

Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 25, 2020 0