Highlighted

Rubberhose 2 Rubber Pin ROTATION EXPRESSION ERROR

New Here ,
Jul 10, 2019

Copy link to clipboard

Copied

HELP

I got this message when I tried to rubber pin my char arm:

This project contains expression error 1 of 2
First Error
After Effects warning: Expression Disabled
Error at line 1 in property "Rotation" of layer 11 ("Hose 2:::Wrist") in comp "Rita"
Object of type found where a Number, Array, or Property is needed

Second Error
After Effects warning: Expression Disabled
Error at line 1 in property "Rotation" of layer 11 ("Hose 2:::Shoulder") in comp "Rita"
Object of type found where a Number, Array, or Property is needed

I think I followed a right instruction, I put 3 puppet pin in it, then Rubber pin it, but then I got those expression errors, I cant get rid of it as I also try rig hand, the result is when I lift the wrist controller, the hand rotation didn't work at all. I also tried fixing the shape with round circle and nothing works, seems like the rotation bug or something?

Views

1.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Rubberhose 2 Rubber Pin ROTATION EXPRESSION ERROR

New Here ,
Jul 10, 2019

Copy link to clipboard

Copied

HELP

I got this message when I tried to rubber pin my char arm:

This project contains expression error 1 of 2
First Error
After Effects warning: Expression Disabled
Error at line 1 in property "Rotation" of layer 11 ("Hose 2:::Wrist") in comp "Rita"
Object of type found where a Number, Array, or Property is needed

Second Error
After Effects warning: Expression Disabled
Error at line 1 in property "Rotation" of layer 11 ("Hose 2:::Shoulder") in comp "Rita"
Object of type found where a Number, Array, or Property is needed

I think I followed a right instruction, I put 3 puppet pin in it, then Rubber pin it, but then I got those expression errors, I cant get rid of it as I also try rig hand, the result is when I lift the wrist controller, the hand rotation didn't work at all. I also tried fixing the shape with round circle and nothing works, seems like the rotation bug or something?

Views

1.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Guide ,
Jul 10, 2019

Copy link to clipboard

Copied

Have you tried to change the expression engine either back to Legacy or forward to Javascript? (You'll find the setting in File -> Project settings -> Expressions somewhat)

Are you using the latest version of Rubberhose?

*Martin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 12, 2019

Copy link to clipboard

Copied

OMG, Thanks Martin! I changed the expression engine from javascript to legacy and it works now. Thought this case might be useful for other beginner like me. Thank you too, OussK​ !

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 10, 2020

Copy link to clipboard

Copied

Wow thanks! I have a trouble with the RubberHose v2's Auto Rotate Start/End function, and it's been perfectly resolved by your suggestion.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 10, 2019

Copy link to clipboard

Copied

As martin say you must change the expression settings to legacy, also you can try the new script that come with AE Update legacy Expression you can find by going to File/Scripts. i'm not sure if this script can fix rubberhose issue so give it a try.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Apr 14, 2020

Copy link to clipboard

Copied

Thank you! Both methods are working!! The problem is that your method is only working with the existing lines - it doesn't apply to any hoses taht you gonna create after running the script..

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...