Highlighted

Text Disappears when converted to a 3D layer

Community Beginner ,
Jan 25, 2018

Copy link to clipboard

Copied

I don't have much experience with After Effects, but been teaching myself a lot over the past few months via templates and YouTube videos.  I'm working on making a lyric video.  The text of the song has been typed in individual layers and a 3D camera has been added to the composition.  When I click to convert the text layers into 3D, all of my text disappears.  I've also tried going to "Animation > Animate Text > Enable Per Character 3D" but that also makes the text disappear.

Any help would be appreciated.

Currently using After Effects CC 15.0.0 (Build 180)

Adobe Community Professional
Correct answer by Rick Gerard | Adobe Community Professional

You have to be looking at Active Camera and the text must be properly distributed in AE's 3D space. The best way to check is to open up 4 views and check the position of each layer. You should also be using the Classic 3D rendering engine. If you don't immediately figure out what is going on the select all the layers giving you problems and press the U key twice. This will reveal all modified properties of the layers. Start turning effects off and resetting values until layers start showing up.

If you are still stuck then PrintScreen and paste a screenshot of the entire UI here so we can see what you are dealing with.

Watch out for YouTube tutorials, more than half of them are produced by amateurs that don't know what they are talking about and they present dead-end workflows and in many cases promote ideas and techniques that do not work. Vet your trainers. Anyone starting to use AE should spend some time on the Adobe AE product page and use the links to some decent vetted training there. You'll save a lot of time if you start here: Basic AE

Views

9.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Text Disappears when converted to a 3D layer

Community Beginner ,
Jan 25, 2018

Copy link to clipboard

Copied

I don't have much experience with After Effects, but been teaching myself a lot over the past few months via templates and YouTube videos.  I'm working on making a lyric video.  The text of the song has been typed in individual layers and a 3D camera has been added to the composition.  When I click to convert the text layers into 3D, all of my text disappears.  I've also tried going to "Animation > Animate Text > Enable Per Character 3D" but that also makes the text disappear.

Any help would be appreciated.

Currently using After Effects CC 15.0.0 (Build 180)

Adobe Community Professional
Correct answer by Rick Gerard | Adobe Community Professional

You have to be looking at Active Camera and the text must be properly distributed in AE's 3D space. The best way to check is to open up 4 views and check the position of each layer. You should also be using the Classic 3D rendering engine. If you don't immediately figure out what is going on the select all the layers giving you problems and press the U key twice. This will reveal all modified properties of the layers. Start turning effects off and resetting values until layers start showing up.

If you are still stuck then PrintScreen and paste a screenshot of the entire UI here so we can see what you are dealing with.

Watch out for YouTube tutorials, more than half of them are produced by amateurs that don't know what they are talking about and they present dead-end workflows and in many cases promote ideas and techniques that do not work. Vet your trainers. Anyone starting to use AE should spend some time on the Adobe AE product page and use the links to some decent vetted training there. You'll save a lot of time if you start here: Basic AE

Views

9.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 25, 2018 0
Community Beginner ,
Jan 25, 2018

Copy link to clipboard

Copied

I have updated to 15.0.1 (Build 73) but still have the same issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 25, 2018 1
Adobe Community Professional ,
Jan 25, 2018

Copy link to clipboard

Copied

You have to be looking at Active Camera and the text must be properly distributed in AE's 3D space. The best way to check is to open up 4 views and check the position of each layer. You should also be using the Classic 3D rendering engine. If you don't immediately figure out what is going on the select all the layers giving you problems and press the U key twice. This will reveal all modified properties of the layers. Start turning effects off and resetting values until layers start showing up.

If you are still stuck then PrintScreen and paste a screenshot of the entire UI here so we can see what you are dealing with.

Watch out for YouTube tutorials, more than half of them are produced by amateurs that don't know what they are talking about and they present dead-end workflows and in many cases promote ideas and techniques that do not work. Vet your trainers. Anyone starting to use AE should spend some time on the Adobe AE product page and use the links to some decent vetted training there. You'll save a lot of time if you start here: Basic AE

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 25, 2018 0
Community Beginner ,
Jan 25, 2018

Copy link to clipboard

Copied

Thanks!  I really have no idea what happened.  I have ended up completely restarting the project from scratch and everything is working fine now.  Don't know what I missed or what I pressed that was incorrect, but at least I know it was user error on my end.  Thanks for your help and advice.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 25, 2018 0
Community Beginner ,
Jan 16, 2019

Copy link to clipboard

Copied

Check if your monitor is set at "Active Camera". It should be like this for you to see it properly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 16, 2019 0
New Here ,
Jun 10, 2019

Copy link to clipboard

Copied

I know you have already solved this problem but I wanted to elaborate for future readers who find this discussion due to similar problems.

I often get this issue when working with cameras that I've imported from other 3D software. When I convert graphics into 3D objects they seem to disappear. I learned that they are always somewhere off of the canvas in 3D space, I'm not sure why they end up there but that's why they seem to disappear. The solution is to zoom way out and hopefully they will appear, sometimes I will have to switch to 4 views to find the layer.

Once I've found the object, I will grab it and snap it to a 3D object that's within my canvas. Then I can zoom back in and scale and position the item where it needs to be.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2019 0
CS5-CC LATEST
New Here ,
Jun 10, 2020

Copy link to clipboard

Copied

Hello,

I am an Identity/Graphic Designer that has been working within After Effects for a couple of years now. I'm not a professional in motion what so ever but I have to set up some AE projects within the entertainment industry. This was perplexing me when building out a tool kit but I found a simple solution.

 

If you are utilizing a text layer and make it 3D with transparency simply select the "T" box between Trikmat and blending mode. This makes the text object stop disappearing and preserves underlying transparency.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 0