Highlighted

The plugin doesn't receive PF_Event_KEYDOWN in some cases

Community Beginner ,
Jun 23, 2020

Copy link to clipboard

Copied

Hey everyone,

 

I noticed that After Effects plugin doesn't receive keyboard events if it is selected in Effects Controls window. The plugin does receive events if it is selected in the Timeline window or the Composition window (video preview) is selected.

Is there any solution to receive keyboard events when the plugin is selected in Effects Controls window?

 

--

Thanks,

Roman

Adobe Community Professional
Correct answer by shachar carmi | Adobe Community Professional

i vaguely remember running into this issue years ago. if memory serves, i think the reason was that i had to have an ECW custom UI exposed to receive keyboard evetns.

i.e. at least one param with an ECW custom UI needs to be untwirled. (not twirled up in itself or it's containing topics)

 

but that's only what i vaguely remember...

TOPICS
SDK

Views

45

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

The plugin doesn't receive PF_Event_KEYDOWN in some cases

Community Beginner ,
Jun 23, 2020

Copy link to clipboard

Copied

Hey everyone,

 

I noticed that After Effects plugin doesn't receive keyboard events if it is selected in Effects Controls window. The plugin does receive events if it is selected in the Timeline window or the Composition window (video preview) is selected.

Is there any solution to receive keyboard events when the plugin is selected in Effects Controls window?

 

--

Thanks,

Roman

Adobe Community Professional
Correct answer by shachar carmi | Adobe Community Professional

i vaguely remember running into this issue years ago. if memory serves, i think the reason was that i had to have an ECW custom UI exposed to receive keyboard evetns.

i.e. at least one param with an ECW custom UI needs to be untwirled. (not twirled up in itself or it's containing topics)

 

but that's only what i vaguely remember...

TOPICS
SDK

Views

46

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 23, 2020 0
Adobe Community Professional ,
Jun 23, 2020

Copy link to clipboard

Copied

i vaguely remember running into this issue years ago. if memory serves, i think the reason was that i had to have an ECW custom UI exposed to receive keyboard evetns.

i.e. at least one param with an ECW custom UI needs to be untwirled. (not twirled up in itself or it's containing topics)

 

but that's only what i vaguely remember...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 23, 2020 1
rkudinov LATEST
Community Beginner ,
Jul 21, 2020

Copy link to clipboard

Copied

Thank you for the tip. I added an invisible ARB parameter with custom UI and it fixed the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 21, 2020 0