Highlighted

Track matte doesn´t seem to work

Community Beginner ,
Sep 06, 2018

Copy link to clipboard

Copied

I have problems with alpha matte. I want a text move from left to right.With the pencil i made a line that i want the text to come out from. Shape 1 is the line. Shape two is the box where i want med text to reveal. Between the two shapes i have a text. With the text layer i choose track matte alpa. But it´s not working. It looks like the line is stopping the animation and no text is reveled in the shape 2. I have black background with white text. What am i doing wrong? I have tried it also with video at the background with the same result.

Kindly Regards Jensine

Adobe Community Professional
Correct answer by OussK | Adobe Community Professional

From this picture, everything look right, just try to check the opacity of the "squere"layer must be 100% also same for text layer

one more question, if you remove the  track matte, than turn on the "squere"layer are you able to see everything in the right place?

anyway here's a file include what you'r doing, you can check it, 

Dropbox - title.aep

Views

1.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Track matte doesn´t seem to work

Community Beginner ,
Sep 06, 2018

Copy link to clipboard

Copied

I have problems with alpha matte. I want a text move from left to right.With the pencil i made a line that i want the text to come out from. Shape 1 is the line. Shape two is the box where i want med text to reveal. Between the two shapes i have a text. With the text layer i choose track matte alpa. But it´s not working. It looks like the line is stopping the animation and no text is reveled in the shape 2. I have black background with white text. What am i doing wrong? I have tried it also with video at the background with the same result.

Kindly Regards Jensine

Adobe Community Professional
Correct answer by OussK | Adobe Community Professional

From this picture, everything look right, just try to check the opacity of the "squere"layer must be 100% also same for text layer

one more question, if you remove the  track matte, than turn on the "squere"layer are you able to see everything in the right place?

anyway here's a file include what you'r doing, you can check it, 

Dropbox - title.aep

Views

1.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Sep 06, 2018

Copy link to clipboard

Copied

TrkMat uses the layer above it as the matte.  So your "box" needs to be directly above your text.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Sep 06, 2018

Copy link to clipboard

Copied

Gutterfish  wrote

So your "box" needs to be directly above your text.

Or use the Set Matte effect, and pick any layer you want.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 06, 2018

Copy link to clipboard

Copied

Thank you. But the shapelayer where i want the text to reveal is above the text layer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 06, 2018

Copy link to clipboard

Copied

Please post a screenshot so we can get better idea where is you issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 06, 2018

Copy link to clipboard

Copied

I will do that as soon as im home from school

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 06, 2018

Copy link to clipboard

Copied

After Effects.png

The text is invisible to the left as it should be. The text has an animation from left to right. The text is meaning to look like it comes out from the line but it´s invisible. What is wrong?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 06, 2018

Copy link to clipboard

Copied

From this picture, everything look right, just try to check the opacity of the "squere"layer must be 100% also same for text layer

one more question, if you remove the  track matte, than turn on the "squere"layer are you able to see everything in the right place?

anyway here's a file include what you'r doing, you can check it, 

Dropbox - title.aep

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 06, 2018

Copy link to clipboard

Copied

yes, if i turn of the track matte i see the the whole text animation yes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 06, 2018

Copy link to clipboard

Copied

I see the order in which you have the timeline but I don't see where the box is. If the box is to the left of the line, you need to have your track matte on Alpha Inverse. If your box is to the right, Alpha works for you. Make sure you have a fill set for your shape layer and that it is set to 100 % opacity. Other than that, try creating a Solid layer and duplicate (or create) a mask to solve the issue. Hope that helps.

   - Robert

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 06, 2018

Copy link to clipboard

Copied

It´s work right now. The problem was at my box was not filled with any colour. I changed to white like you showed me Oussk, thank you very much.  I did not think it was necessary to have a filled shape layer

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 06, 2020

Copy link to clipboard

Copied

thank you man! needed this 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
raviroxu LATEST
New Here ,
Jun 09, 2020

Copy link to clipboard

Copied

I was struggling for hours not knowing what was wrong. This helped! thanks, man.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...