Trim Paths on shape layer converted from Illustrator

New Here ,
Sep 26, 2020

Copy link to clipboard

Copied

Hi, I am very new to AE! What I'm trying to do is trace the line of a drawing that was done in illustrator. I converted the layer into a shape but within the shape are 25 different groups that I put into one larger group (side note: I don't know what a group is versus a shape). I'd guess I need to fix something within the groups because the trim path tool won't even move along any portion of the line? In all honesty, I am not even sure if converting the layer into a shape added paths. I need to learn how to do this for an assignment, but I am starting at level zero with After Effects and am so lost!! Screen Shot 2020-09-26 at 7.50.25 AM.pngScreen Shot 2020-09-26 at 7.50.43 AM.png

TOPICS
How to

Views

475

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Sep 26, 2020

Copy link to clipboard

Copied

In order to see the Trim Paths in action you must add a Stroke thickness, I only see the path but I don't see Stroke, give it more thickness and have a test modifying the start and end parameters of the Trim Paths. If you don't want so many groups, try to have a single complete path from Illustrator, not several pieces of paths.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Sep 26, 2020

Copy link to clipboard

Copied

If the number of groups is alright then I don't mind, but I'm not sure what to do about the stroke thickness. When I add anything from 10 to 100 px nothing changes. I'm not sure if I'm adding it in the wrong way, if I should be doing anything with the keyframes, or maybe the contents are out of order? My apologies I don't quite know where everything is in the program yet. Screen Shot 2020-09-26 at 12.24.21 PM.png

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Sep 26, 2020

Copy link to clipboard

Copied

It looks like you want to just apply Trim Paths to the outlines of the face. If that is the case your Illustrator document should have all of the lines you want to reveal on a separate layer and there should be no brushes applied to any paths and no fills. Just a simple stroke. 

 

When you import as a comp you should only convert the layer with the paths you want to animate to a shape layer. When you convert a vector path to a shape layer you can end up with a lot of extra junk in the layer that is not needed. If you start by pressing 'uu' and looking for a way to simplify things. If all you want is to animate a stroke and the stroke is the same size and color for every path you can eliminate everything but the paths and the stroke.

 

 I see this kind of question fairly often so I threw together a very quick tutorial on the process. 

There is nothing preventing you from adding a separate new stroke for one or more of the paths, adding individual Trim Paths or making groups, but most of the time, just eliminating everything but the paths, one stroke and adding a shape layer animator like Trim Paths is all that is necessary.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Sep 26, 2020

Copy link to clipboard

Copied

I followed everything in the tutorial but still, nothing is showing up. No stroke ever comes up after I put in the keyframes for the trim path tool

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Sep 26, 2020

Copy link to clipboard

Copied

Solo the layer, make sure the stroke is below Trim Paths. Your screenshots show Vector layers above the outlines. They may be blocking the layer you are trying to animate. If it is still not working you need to post a screenshot with the modified properties of the layer revealed. Select the soloed layer, press uu, and show us what you have got.

 

Spend some time in the Learn workspace and spend some time with the User Guide. There are some basic tutorials on basic workflows you should check out.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Sep 28, 2020

Copy link to clipboard

Copied

I'm not sure what to do about the vector above the outline, but this is the layer right nowScreen Shot 2020-09-28 at 6.10.56 PM.png

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Sep 28, 2020

Copy link to clipboard

Copied

What happens if you solo the layer? 

 

I could tell a lot more if he screenshot wasn't cropped. 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Oct 01, 2020

Copy link to clipboard

Copied

Nothing shows up. It's just a blank screen.

My previous screenshot is as much as I could fit onto my computer screen length-wise

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Oct 01, 2020

Copy link to clipboard

Copied

Let's go back to the source of the problem. Try this:

  • Open your original AI file
  • Save a copy of the file and name it Face Outlines
  • Delete every layer in the AI file that does not contain the face outlines you are having problems with
  • Only the face outlines should remain
  • Select all and make sure there are no brushes or fills on any path (object) by
    • turn off all fills using the toolbar
    • turn off all strokes using the toolbar
    • with all paths selected use the toolbar to add color only to the stroke on every layer
    • make the stroke is set to 1 point (pixel)
    • make sure you release all compound paths by selecting all and going to the Object/Compound paths menu
  • With all layers selected expand the Layer in the Layer panel and look for groups
  • If there are any groups use the Object menu to ungroup them or drag them around in the Layer Panel so there are no groups in the drawing
  • Carefully examine all paths and make sure they are all simple paths by changing the View to Outlines (Ctrl/Cmnd + y)
  • If you find a path that has parallel sides then that path will be too thick when it the View is changed back to Preview (Ctrl/Cmnd + y) so the path needs to be opened up and one side of the path needs to be deleted
  •  Back in preview mode set the stroke width to 2 pixels or more (you never want 1-pixel strokes in a video) and choose the right color
  • Make sure that the paths are arranged in the layer in the order you want them to be revealed
  • Save the file, import into AE as footage, add the Face Outlines file to the timeline, convert it to Outlines and check the shape layer for groups
  • Every path should be in a separate group, if you have more than one path in a group then you missed something in AI but we can fix it now
  • Type Path in the timeline search field
  • Ctrl/Cmnd + select all paths in showing in the timeline and drag them above group 1
  • Press the U key twice to clear the search and reveal all modified properties of all layers and make sure you did not leave any paths in a group
  • Select all remaining groups and delete them
  • Select all of the paths and press Ctrl/Cmnd + g to group them in a new Group 1
  • Use the Add menu to add a stroke and Trim Paths

The goal is one group with 1 stroke. All that is left is to add Tim Paths and select the sequential option The stroke should be below Trim Paths. In the end, your timeline should look like this:

Screenshot_2020-10-01 09.49.53_4Ib4vx.png

If you want some paths to animate on at the same time, group the paths by selecting them and using the Group shortcut, then arrange them so all the groups, trim paths, and strokes are under contents and not nested in another group.

 

If this does not work, share the AI file and let me take a look. 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more