Highlighted

Unusable preview playback in After Effects CC 2019 (16.1.1)

Explorer ,
Jun 12, 2019

Copy link to clipboard

Copied

The latest version of After Effects has become near unusable for me, as I cannot get my RAM preview to play realtime (30fps) despite any changes I make to the settings, and what I believe is an otherwise well-spec'd system configuration. 


With 1080x1920 sequences, the best I ever seem to get is around 9fps... which just seems absurd.

I've gone through past posts about similar issues (which seem to rear their ugly head every few updates), and have tried all the various recommendations to no avail.

Any tips/tricks/insight/etc. would be greatly appreciated. I'm hoping there might be a solution I'm missing beyond reverting back to CC 2018, which would be very disappointing and problematic.

Thanks in advance,

b


System specs: After Effects CC 2019 (16.1.1)

Windows 10 Pro

AMD Ryzen Threadripper 2990WX 32-Core 3.00 GHz

128 GB RAM

Samsung 2TB 970 EVO SSD (x2)

100 GB After Effects Disk Cache

Nvidia RTX 2080 Ti (x2)

GeForce Driver 430.86 (05/27/2019)

Screen shot attached with most relevant settings visible:

AFX-NonRealtimePlayback.png

Adobe Community Professional
Correct answer by justintaylor | Adobe Community Professional

A few things to check:

- Update GPU Drivers
- Clear Memory (Edit > Purge > All Memory and Disk Cache)

- Reset Prefs / Rename Prefs folder (Edit > Preferences > General > Reveal Preferences in Explorer > then rename that folder to something else so AE creates a new one on re-launch)

- Restart your Computer

Did the same type of project playback in real-time on CC 2018? What does you comp look like, what effects and footage types are you using?

Are you letting the timeline cache before playing back?

Views

3.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Unusable preview playback in After Effects CC 2019 (16.1.1)

Explorer ,
Jun 12, 2019

Copy link to clipboard

Copied

The latest version of After Effects has become near unusable for me, as I cannot get my RAM preview to play realtime (30fps) despite any changes I make to the settings, and what I believe is an otherwise well-spec'd system configuration. 


With 1080x1920 sequences, the best I ever seem to get is around 9fps... which just seems absurd.

I've gone through past posts about similar issues (which seem to rear their ugly head every few updates), and have tried all the various recommendations to no avail.

Any tips/tricks/insight/etc. would be greatly appreciated. I'm hoping there might be a solution I'm missing beyond reverting back to CC 2018, which would be very disappointing and problematic.

Thanks in advance,

b


System specs: After Effects CC 2019 (16.1.1)

Windows 10 Pro

AMD Ryzen Threadripper 2990WX 32-Core 3.00 GHz

128 GB RAM

Samsung 2TB 970 EVO SSD (x2)

100 GB After Effects Disk Cache

Nvidia RTX 2080 Ti (x2)

GeForce Driver 430.86 (05/27/2019)

Screen shot attached with most relevant settings visible:

AFX-NonRealtimePlayback.png

Adobe Community Professional
Correct answer by justintaylor | Adobe Community Professional

A few things to check:

- Update GPU Drivers
- Clear Memory (Edit > Purge > All Memory and Disk Cache)

- Reset Prefs / Rename Prefs folder (Edit > Preferences > General > Reveal Preferences in Explorer > then rename that folder to something else so AE creates a new one on re-launch)

- Restart your Computer

Did the same type of project playback in real-time on CC 2018? What does you comp look like, what effects and footage types are you using?

Are you letting the timeline cache before playing back?

Views

3.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 12, 2019 0
Adobe Community Professional ,
Jun 12, 2019

Copy link to clipboard

Copied

A few things to check:

- Update GPU Drivers
- Clear Memory (Edit > Purge > All Memory and Disk Cache)

- Reset Prefs / Rename Prefs folder (Edit > Preferences > General > Reveal Preferences in Explorer > then rename that folder to something else so AE creates a new one on re-launch)

- Restart your Computer

Did the same type of project playback in real-time on CC 2018? What does you comp look like, what effects and footage types are you using?

Are you letting the timeline cache before playing back?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2019 1
Explorer ,
Jun 12, 2019

Copy link to clipboard

Copied

Thanks.

  • The drivers listed above are the latest
  • I've done the purge all disk/cache
  • I've got "cache before playback" turned on
  • I've restarted my PC (multiple times)
  • The issue occurs across all projects, independent of number of layers, effects, or footage type... I just tried with a simple sequence of 1080 .jpg images, and got the same results (no effects, no layers, nothing "special")

I'll try renaming the Prefs folder, and let you know!

Edit: I forgot to mention that, no, I was not having this issue in CC 2018

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2019 1
Explorer ,
Jun 12, 2019

Copy link to clipboard

Copied

Resetting the Prefs seems to have solved the issue!

Talk about a "goose chase"! Maybe this tip should be stickied at the top of the forum?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2019 1
Adobe Community Professional ,
Jun 12, 2019

Copy link to clipboard

Copied

Awesome, glad to hear that worked!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2019 0
New Here ,
Oct 24, 2019

Copy link to clipboard

Copied

I had a similar issue with After Effects CC. I could not hear audio. I wasn't sure if it was related to installing the SmartSound Sonicfire Pro 6 plug-in. However, I renamed the preferences folder. Upon reatrting AE, everything worked perfectly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2019 0
Explorer ,
Jul 09, 2019

Copy link to clipboard

Copied

Have run into this problem a number of times since, and while renaming the prefs folder seems to help for a bit, it doesn't seem to be a long-lasting solution. 

I just ran into this again today, with the attached file dropping down to 9 frames per second.

I renamed the prefs folder, restarted the machine, and FPS went back up to 30.

However... This was only the case when After Effects was maximized to one of my two monitors. If I extended the interface across both monitors, the FPS dropped down to around 15fps.

I checked task manager while doing this, and didn't see any spikes in memory, cpu, or graphics card usage. I'm not sure what's going on here, but it definitely seems something isn't behaving as it should.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2019 0
Adobe Community Professional ,
Jul 09, 2019

Copy link to clipboard

Copied

Strange, just tested and multi-screen workspace doesn't affect Ram preview on my end. What's your memory allowance look like in Edit > Preferences > Memory?

Also, do you have a lot of scripts running in the background?

If you can try and reset your prefs, and then test periodically as you change your prefs back they way you like them, you might be able to find what is causing the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2019 0
Explorer ,
Jul 09, 2019

Copy link to clipboard

Copied

Hey Justin,

My memory looks like this:

     RAM reserved for other applications: 16 GB

     RAM available for After Effects: 111.9 GB

My installed scripts are these, but I don't think they should be running at startup (and none are used in this comp):

AFX-Scripts.png

I'll keep poking around, and see if I can nail down the actual root of the issue...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2019 0
Adobe Community Professional ,
Jul 09, 2019

Copy link to clipboard

Copied

Gotcha, seems like the workspaces could be part of the issue. When you wipe your prefs, are you re-creating your workspaces or copying and pasting old ones?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2019 0
Explorer ,
Jul 09, 2019

Copy link to clipboard

Copied

I've just been leaving the workspace default, as it's recreated.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2019 0
Adobe Community Professional ,
Jul 09, 2019

Copy link to clipboard

Copied

But what panels are you putting on your secondary screen that's causing the slowdown?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2019 0
Explorer ,
Jul 09, 2019

Copy link to clipboard

Copied

Oh, I'm just "minimizing" the After Effects window, then extending the bounds to the second monitor, so that timeline, composition window, etc. span across the full, double screen width.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2019 0
Adobe Community Professional ,
Jul 09, 2019

Copy link to clipboard

Copied

Hmm, I mean it could be using more GPU power which takes longer to render, but with your setup, I can't imagine you would feel that much of a performance hit.

Sounds like it might be a bug, check out the User Voice​ to see if anyone else is having the same issue that you can vote for. If not, then create a new issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2019 0
Explorer ,
Jul 09, 2019

Copy link to clipboard

Copied

I was wondering the same thing, which is why I kept an eye on my task manager while fiddling with the window dimensions. Didn't see any change in CPU, memory, or GPU utilization, even though I could see the frame rate drop real-time between the two configurations (maximized to one window vs. spanning two). 


Thanks for the User Voice suggestion, I'll give it a go.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2019 0
Explorer ,
Jul 09, 2019

Copy link to clipboard

Copied

Well, that was quick!

Here's the issue: Ram preview plays back slow on 4k monitor unless I hide timeline panel – Adobe video & audio apps

I just tested it. Spanned the interface across both monitors, hid timeline, and it played like butter!


What the...

Please Adobe, get this sorted!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2019 2
Adobe Community Professional ,
Jul 10, 2019

Copy link to clipboard

Copied

Cool, always good to know you're not the only one experiencing the issue. Thanks for posting the link for others to find, I went ahead and voted on it too.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 10, 2019 2
Explorer ,
Sep 23, 2019

Copy link to clipboard

Copied

Hey Adobe! 

Can you please sort this out? It's been months, and multiple After Effects updates, without any apparent progress...😩

Working in the timeline, then having to close it every time I want to preview a change has a significant impact on my productivity and positive mental attitude, and I'm not sure how much longer I can continue to work like this!

Thanks,

b

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 23, 2019 2
Explorer ,
Oct 15, 2019

Copy link to clipboard

Copied

I have the same problem! Have you found some solution?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2019 1
Explorer ,
Oct 15, 2019

Copy link to clipboard

Copied

Unfortunately, no. I did notice your other post, and am disappointed to see that others think this is normal behavior... it's not. It's also not just some "quirk" we shouldn't ask questions about. It's a reproducible issue, where cached playback IS BROKEN when the timeline is visible. Closing the timeline restores normal, expected, full-speed playback, but but this is not a practical work-around, at all, and the underlying bug needs to be acknowledged and resolved!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2019 1
Community Beginner ,
Oct 15, 2019

Copy link to clipboard

Copied

Hi Brittnell, I'm having the same issue and it's killing me. How are you "hiding" the timeline? If I close the timeline the comp viewer gets closed as well. If I open it in the comp viewer, the timeline automatically opens. Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2019 0
New Here ,
Oct 16, 2019

Copy link to clipboard

Copied

I am experiencing the same problem and i am quite disapointed. With clients we run in situations that are unexceptable.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 16, 2019 0
New Here ,
Oct 16, 2019

Copy link to clipboard

Copied

Hello Guys,

i also have simular playback problems, After Effects CC 2019 (16.1.3) 

RAM preview is filled, green render bar, but still not realtime playback.

I did the prefs and cache thing and also update drivers.  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 16, 2019 0
Explorer ,
Oct 16, 2019

Copy link to clipboard

Copied

The only solution I've found is to come back to AE CC 2017!! And I think that's absurbs!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 16, 2019 0
New Here ,
Oct 24, 2019

Copy link to clipboard

Copied

The same here...

I have 4k monitor, all interface is slow after last update.

The only way to solve this is to change the resolution to fullHD.

But, I don't want to work at fullHD at 27 inches. Very blurry!

Before that worked!

 

Can anyone at Adobe fix this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2019 0
Explorer ,
Oct 18, 2019

Copy link to clipboard

Copied

Hey anyone who's following along! 

 

I've been doing a bunch of condition testing, and believe I have found something (at least in my case).

 

The issue seems to only occur when the timeline spans two monitors. So, anything you can do to avoid that condition should help (which is why closing the timeline seems to work).

 

The simplest solution I've found, is to undock the timeline panel, and have it in one monitor only.

 

If you want to test this on your own, undock the timeline panel, shrink it into one monitor only, hit spacebar to intiate the preview, then start expanding the timeline window into your second monitor. If it's similar to what I'm seeing, you should notice your playback framerate drop significantly as the panel gets about halfway into the other monitor.

 

Curious to hear how it works for you all.

 

Edit: Here's an example of what I'm seeing: https://youtu.be/ReK62OTs_cg

When the timeline panel is constrained to one monitor only, playback is realtime, at 30fps. Extending to the second monitor drops playback to just over 20fps (sometimes dipping even lower). Reducing the panel brings the framerate back up again. 

 

 

After Effects has an issue where preview playback drops to lower than real-time if the timeline spans across two monitors. Regardless of CPU, GPU, or RAM (I'...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 18, 2019 0
Adobe Employee ,
Oct 24, 2019

Copy link to clipboard

Copied

Britnell,

Thanks for reporting back. For someone that likes such a long timeline, I suggest one of those newer widescreen panels that are popular right now. My office mates have them (sadly, I do not!). 

 

I'd say that you're probably not alone in wanting to span a Timeline across a dual screen surface. I've seen that in a few cases in the Premiere Pro realm, as well. That said, it isn't common. Most of us use a single monitor for our timelines, I think. I would definitely suspect performance issues if you didn't keep your panels nice and tight, if not at default.

 

You may want to make a feature request on User Voice, though.

 

Regards,
Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2019 0