Highlighted

Using the loopOut() expression always leaves the last frame blank, no matter what I do

Community Beginner ,
May 30, 2013

Copy link to clipboard

Copied

The problem:

I've enabled Time Remapping on a composition and am using the loopOut() expression to repeat a 16 second animation until the end of the video.

When I apply the expression, it places a keyframe at the beginning of the clip and at the 16 second mark. When I look at the single frame at the 16 second mark, the composition is not visible. (The object boundaries are visible to scale/move but the image is not.) This also occurs at the 32sec mark, 48sec mark, 64sec mark...

The solution I found (that's not working for me):

  1. Create a new keyframe one frame before the 16 second mark
  2. Delete the keyframe at the 16 second mark

What happens instead:

Once I delete the keyframe at the 16 second mark, the keyframe at 15;29 becomes blank. The last keyframe will always be blank, no matter where it was placed, before or after the original.

If I have four keyframes and delete the last one (#4), the third keyframe will become blank. If I then delete the third keyframe, the second keyframe will become blank.

Any troubleshooting help would be appreciated.

Community Beginner
Correct answer by Teighe | Community Beginner

The solution to this problem, that I found, was ridiculously simple. I just had to turn on the "continuously rasterize" icon (the little star burst) next to the "shy" icon. I hope that's helpful to anyone reading this post now.

TOPICS
Expressions

Views

34.8K

Likes

Translate

Translate

Report

Report
This conversation has been locked.

Using the loopOut() expression always leaves the last frame blank, no matter what I do

Community Beginner ,
May 30, 2013

Copy link to clipboard

Copied

The problem:

I've enabled Time Remapping on a composition and am using the loopOut() expression to repeat a 16 second animation until the end of the video.

When I apply the expression, it places a keyframe at the beginning of the clip and at the 16 second mark. When I look at the single frame at the 16 second mark, the composition is not visible. (The object boundaries are visible to scale/move but the image is not.) This also occurs at the 32sec mark, 48sec mark, 64sec mark...

The solution I found (that's not working for me):

  1. Create a new keyframe one frame before the 16 second mark
  2. Delete the keyframe at the 16 second mark

What happens instead:

Once I delete the keyframe at the 16 second mark, the keyframe at 15;29 becomes blank. The last keyframe will always be blank, no matter where it was placed, before or after the original.

If I have four keyframes and delete the last one (#4), the third keyframe will become blank. If I then delete the third keyframe, the second keyframe will become blank.

Any troubleshooting help would be appreciated.

Community Beginner
Correct answer by Teighe | Community Beginner

The solution to this problem, that I found, was ridiculously simple. I just had to turn on the "continuously rasterize" icon (the little star burst) next to the "shy" icon. I hope that's helpful to anyone reading this post now.

TOPICS
Expressions

Views

34.8K

Likes

Translate

Translate

Report

Report
May 30, 2013 3
Adobe Community Professional ,
May 30, 2013

Copy link to clipboard

Copied

This is normal behavior. Don't delete the keyframe at 16. Let me explain.

Let's say you have 2 keyframes for transparency. Frame 0 is 0 and frame 10 is 100. Adding the loop out expression to these keyframes will give you the following:

Frame Opacity

0 = 0

1 = 10

2 = 20

3 = 30

4 = 40

5 = 50

6 = 60

7 = 70

8 = 80

9 = 90

10 = 100

11 = 10

Then frame 19 will be 90 and frame 20 will be 0 and so on. This is because the animation loops between frame one and frame 10 which means it only reaches the value of frame 10 the first time through the loop. Every time after that the loop starts over at the first frame of the loop (frame 10, 20, 30 and so on).

This is normal. If you want frame 11 to be 0 then you'll need to add a keyframe there so you have an 11 frame loop instead of a 10 frame loop.

To solve your problem try backing up 1 keyframe from the end, inserting a new keyframe, and then leaving the last one. Now you have a seamless loop of all of your keyframes.

Does that make sense? The loopOut() method loop is exactly the same length as the keyframes to therefore the next frame after the loop has the same value as the second frame after the start of the loop and all subsequent loops will end one frame before the last keyframe. To make a continuous loop from 0 to 100 you need 3 keyframes. One at 0, two at 100 and 3 at 0.

You can also change the loopOut method from the default "cycle" to "pingpong" by writing loopOut("pingpong"). This would give you a smooth fade up and fade down between 0 and 100 because the loop goes back and forth between the first and last keyframes.

This is the way looping functions work in Java, 3D apps, and everywhere else that I have used them.

Likes

Translate

Translate

Report

Report
May 30, 2013 1
Community Beginner ,
May 30, 2013

Copy link to clipboard

Copied

When I put a new keyframe 1 frame before the end, there are no visible changes. The last keyframe is still blank.

I can assign the last keyframe the timecode 00;01 instead of 16;00 and then the second-to-last keyframe becomes blank.

This feels like a bug more than anything. I understand where you're coming from, but After Effects isn't giving me the logical result.

Likes

Translate

Translate

Report

Report
May 30, 2013 0
Community Beginner ,
May 30, 2013

Copy link to clipboard

Copied

Ok, I might be on to something...I need to do a little more testing but I think I've solved it. I'll report back in 30 minutes.

Likes

Translate

Translate

Report

Report
May 30, 2013 0
Community Beginner ,
May 30, 2013

Copy link to clipboard

Copied

I found out I can use the loopOut() expression on another composition with the new keyframe method outlined above, and it fixed the blank frame.

The same method does not work on the original composition in question, for whatever reason.

Fortunately, the loopOut("ping-pong") expression you mentioned will work for this animation, and that does remove the blank frame.

Likes

Translate

Translate

Report

Report
May 30, 2013 0
Most Valuable Participant ,
May 30, 2013

Copy link to clipboard

Copied

Well, time-remapping means time-remapping not frame-remapping. Everything happens on genuine time calculations and if your values are off by a fraction, sampling the discrete frames may simply end up in a blank area. This may not show up in the first few iteration cycles, but may become apparaent later as those minute discrepancies accumulate. Well, whatever, without seeing your project it's just guessing around...

Mylenium

Likes

Translate

Translate

Report

Report
May 30, 2013 1
Community Beginner ,
Dec 19, 2018

Copy link to clipboard

Copied

If you are still experiencing a blank frame even after creating a new keyframe back one frame from the end and then deleting the last one, try to "Purge All Memory & Disk Cache...".

This fixes the problem for me when I have a stubborn comp that keeps the blank frame even after setting up the loop correctly as other users have stated.

Likes

Translate

Translate

Report

Report
Dec 19, 2018 3
New Here ,
Jan 27, 2020

Copy link to clipboard

Copied

This really helps! Thank you!

Likes

Translate

Translate

Report

Report
Jan 27, 2020 0
New Here ,
Mar 18, 2020

Copy link to clipboard

Copied

IT WORKS! THANKS A LOT

Likes

Translate

Translate

Report

Report
Mar 18, 2020 0
New Here ,
Jun 17, 2020

Copy link to clipboard

Copied

it works..T_T finally~~thank you very much~

Likes

Translate

Translate

Report

Report
Jun 17, 2020 0
New Here ,
Jun 11, 2014

Copy link to clipboard

Copied

In my case, moving time remapped frames resulted the last frame before 00:00:00 being blurred."Toggle hold keyframe" couple frames before the last worked for me.

Likes

Translate

Translate

Report

Report
Jun 11, 2014 0
Community Beginner ,
Oct 30, 2015

Copy link to clipboard

Copied

The solution to this problem, that I found, was ridiculously simple. I just had to turn on the "continuously rasterize" icon (the little star burst) next to the "shy" icon. I hope that's helpful to anyone reading this post now.

Likes

Translate

Translate

Report

Report
Oct 30, 2015 39
New Here ,
Dec 04, 2016

Copy link to clipboard

Copied

omfg I've been looking for like 30 mins for this! ughh. so stupid. thanks!!

Likes

Translate

Translate

Report

Report
Dec 04, 2016 1
Participant ,
Jan 24, 2019

Copy link to clipboard

Copied

THANK YOU!!!!!!!!!!!!!!!!!!!!
THIS IS THE BEST SOLUTION HERE AND SHOULD BE CONSIDERED AS CORRECT ANSWER!!!

Likes

Translate

Translate

Report

Report
Jan 24, 2019 1
New Here ,
Oct 11, 2019

Copy link to clipboard

Copied

I agree.this is the right answer. I thought this was a glitch in AE for years. never thought to press the continuous rastersize layer. Thanks Teighe

Likes

Translate

Translate

Report

Report
Oct 11, 2019 0
New Here ,
Oct 11, 2019

Copy link to clipboard

Copied

Thank you.

Likes

Translate

Translate

Report

Report
Oct 11, 2019 0
New Here ,
Jan 12, 2020

Copy link to clipboard

Copied

Thank you soooooooooomuch !!!!!!!!!!!

 

Likes

Translate

Translate

Report

Report
Jan 12, 2020 0
New Here ,
Jan 25, 2020

Copy link to clipboard

Copied

Worked for me as well, thank you!

Likes

Translate

Translate

Report

Report
Jan 25, 2020 0
Community Beginner ,
Mar 17, 2020

Copy link to clipboard

Copied

YOU'RE A HERO!

Likes

Translate

Translate

Report

Report
Mar 17, 2020 0
New Here ,
Mar 31, 2020

Copy link to clipboard

Copied

Thank you so much! This is a life saver!

Likes

Translate

Translate

Report

Report
Mar 31, 2020 0
New Here ,
Jul 04, 2020

Copy link to clipboard

Copied

yesss

Likes

Translate

Translate

Report

Report
Jul 04, 2020 0
Participant ,
Jan 27, 2017

Copy link to clipboard

Copied

Just to confirm, I'd be messing about with keyframes for the last hour. I had a 24 frame animation had tried every which way... described in tutorials on YouTube in other threads on here. Using the pingpong method worked. But I wanted to get the cycle working as well.

As soon as I turned on the 'continuously rasterise' icon it worked like a charm.

Likes

Translate

Translate

Report

Report
Jan 27, 2017 2