Highlighted

Weird behaviour: Laggy scrubbing, unless path is selected

Community Beginner ,
Jul 27, 2020

Copy link to clipboard

Copied

Hey there,

I experience a weird behaviour in After Effects.

I'm currently working on a character rig with many shape layers and expressions, so scrubbing the timeline is quite laggy and uncomfortable. Unless .... I select a path. It seems like After Effects is able to render quicker, but it only does so when a path is selected. Why is that? Could Adobe slightly tweak the scrubbing code to massively gain performance?

 

Here's a video of the behaviour.

 

 

Best,

Martin

TOPICS
Expressions, Performance

Views

79

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Weird behaviour: Laggy scrubbing, unless path is selected

Community Beginner ,
Jul 27, 2020

Copy link to clipboard

Copied

Hey there,

I experience a weird behaviour in After Effects.

I'm currently working on a character rig with many shape layers and expressions, so scrubbing the timeline is quite laggy and uncomfortable. Unless .... I select a path. It seems like After Effects is able to render quicker, but it only does so when a path is selected. Why is that? Could Adobe slightly tweak the scrubbing code to massively gain performance?

 

Here's a video of the behaviour.

 

 

Best,

Martin

TOPICS
Expressions, Performance

Views

80

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 27, 2020 0
Most Valuable Participant ,
Jul 27, 2020

Copy link to clipboard

Copied

Selecting a path changes the rendering context due to having to draw the overlays for the paths. And that in itself could be the answer: You are adding overhead by relying on hardware acceleration/ Fast Draft, which adds another display step. Ergo simply switching everything to software-only rendering modes might have the same effect as dsoes selecting something. Evaluating the expression is slower than any benefits you gain from GPU display functions, anyway.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 27, 2020 1
Community Beginner ,
Jul 27, 2020

Copy link to clipboard

Copied

Ah, that sounds logical.

Where can those settings be found?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 27, 2020 0
Most Valuable Participant ,
Jul 28, 2020

Copy link to clipboard

Copied

Check the preferences and the various flyout menus in the top right corners of the comp viewer, preview panel and so on.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 28, 2020 1
Community Beginner ,
Jul 28, 2020

Copy link to clipboard

Copied

Thank you Mylenium! I fiddled around with all the settings in the preferences, project settings and various flyout menus (CUDA on/off, adaptive resolution, preview preferences, render options, ...), but it doesn't make a difference. I still have to select a path to gain that performance boost. It's strange.
Is there Adobe staff around, that could give an insight in this behaviour?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 28, 2020 0
Community Beginner ,
Jul 30, 2020

Copy link to clipboard

Copied

Okay, it has nothing to do with the rendering. Even if the timeline is rendered (green indicator) the scrubbing is still choppy, as long as no path is selected. So I assume it is a UI display problem.

I tried the Hardware Acceleration settings in Preferences-->Display, but that also did not change anything.

 

Are there more hidden settings like this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 30, 2020 0