• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
13

No longer able to submit app to iTunes.

Community Beginner ,
Sep 24, 2014 Sep 24, 2014

Copy link to clipboard

Copied

Today I am trying to submit a new version of an app to iTunes with the application loader but keeps coming up with the following error. The app was submitting fine last Friday. Any help or fixes will be much appreciated.

Package Summary:

1 package(s) were not uploaded because they had problems:

  /var/folders/cc/4b5fjzqn0_n34cll1wzkbk49jhjcnt/T/404743731.itmsp - Error Messages:

  ERROR ITMS-9000: "Invalid Segment Alignment. This app does not have proper segment alignment and should be rebuilt with the latest version of Xcode. Please contact Developer Technical Support if you need further assistance."

TOPICS
Air beta

Views

77.3K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Sep 25, 2014 Sep 25, 2014

It seems there have been changes in way Apple expects the apps to created. We investigated this deeper, and found that the output of our linker (in our toolchain) is no longer being accepted by Apple.

We are working on this to upgrade our toolchain, including the linker. For the time being,  we would suggest you to try using the ‘linker’ available on the system. We have done tests with a couple of apps and it seems to be fixing the problem. Please give it a try and see if it can unblock you. Ple

...

Votes

Translate

Translate
replies 283 Replies 283
Explorer ,
Oct 04, 2014 Oct 04, 2014

Copy link to clipboard

Copied

Sorry about the ignorance. I am really a novice to all of this.

I use some ANEs provided by other developers. Is there anyway I can fix this problem myself? Or am I stuck? Thanks for any advise.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 04, 2014 Oct 04, 2014

Copy link to clipboard

Copied

I'm also getting this minimum OS error, my suspect is distriqt's IAP-extension, will try another extension tonight.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Oct 04, 2014 Oct 04, 2014

Copy link to clipboard

Copied

For example:

You download latest AIR SDK 15.0.0.302 and compile your app with it. Automatically this SDK enable MinimumOSVersion=4.3

If you add some ANE that will require MinimumOSVersion=6.1 - you must set in application decription xml actually MinimumOSVersion the same as use that ANE.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 04, 2014 Oct 04, 2014

Copy link to clipboard

Copied

Okay, thanks.

It also worked when changing the ANE to Milkman's.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 04, 2014 Oct 04, 2014

Copy link to clipboard

Copied

I'm using ANEs for my projects and runs well, sent an update yesterday and I had not problem, I am using SDK 15.0.0.302 with Flash Pro CC 2014.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 04, 2014 Oct 04, 2014

Copy link to clipboard

Copied

Yes I knew all that I changed the minimum to 6.1 and I was able to submit the app.  I was hoping to keep the minimum at 4.3 though -- I have successfully submitted apps using this ANE before and had no issues until now.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 05, 2014 Oct 05, 2014

Copy link to clipboard

Copied

Thanks, worked for me. Also for Flash

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

I just got the same problem.

Yesterday it was working fine.

But I got this problem after regenerating the certificate and provisioning profile. I did that because apple has introduced new "TestFlight" system for beta testing. And as a solution they are asking developers to regenerate the certificate and provisioning profile to include "TestFlight" entitlement in the package.

After using the new certificate with new profile, I got this error.

I am also waiting for the solution to this problem as soon as possible.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 05, 2014 Oct 05, 2014

Copy link to clipboard

Copied

If you're looking for a solution to the TestFlight "Beta Entitlement" issue, please refer to this blog post:

http://www.flashdeveloper.co/post/99200413877/enabling-testflight-testing-in-itunes-connect-for-adob...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

I m having the same issue , and i m using Flash Professional CC and the latest SDK , i'm using an ANE everything is working perfectly in My device and any other device also on IOS Simulator . and today i got that error when i submited my IPA .

We have a serious problem and the client is waiting for long time the app to be on the Store 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

Hi 

The same problem has also occurred me.

Withdrawal your own app, I was up again.

Could it be that might be the difference in the display version and build version.

Ver2.0.0(2.0.0) -->Ver2.0.0(2.0.1)  

I feel like can only Xcode to this(build version).

I have changed the info.plist in Xcode5 of MAC.

Then, sign and was up in ApplicationLoader but it's the same.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 08, 2014 Oct 08, 2014

Copy link to clipboard

Copied

There was a problem can be resolved in an environment of 15.0.0.302 + FlashCS6 (Winodws7) AIR.

Thank you everyone.

The direction of users of CS6, in addition to the body XML and the PNG of iOS7 icon, please sure you have read-only XML files.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

I'm having the same problem, I'm using Flash CC 2014, AIR 15.0.0.289 and Application Loader version 3.0 (620) - X-code version 6.0.1 (6A317).

Please can you give more details about the workaround? I dont know how to modify the linker, or even where to look.

Thanks Steve

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

Steve, I'll know later if my approach worked ok. If it did then it would be possible to do the work around just in the Finder, without involving Terminal.

Whether you do this in Terminal, or Finder, you'll need to track down where the files are located. If you downloaded the AIR SDK and left it in your Downloads folder, the original ld64 file will be here:

/Users/steve/Downloads/air15_sdk_mac/lib/aot/bin/ld64

So, in the command line instruction above your first line would be:

cd /Users/steve/Downloads/air15_sdk_mac/lib/aot/bin/ld64

Assuming you are "steve" as a user name!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

Thank you for your reply Colin, I'll give that a go

Steve

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

We're seeing this now too.

The really annoying thing is that we submitted the app 3 days ago, got accepted for an expedited review and then during the review they updated their requirements and rejected the binary!

Now we can't even upload a binary due to this error.

Last week we had an app accepted using the exact same Air SDK etc....

This is SO frustrating...as you can imagine even more so with a client being told they have an expedited review and then this with no clue how to fix it.

Hmmmmm will keep an eye here but I suspect we need a new release of Air SDK?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

Dave, read all of this thread, especially Pahup's work around, and my additional notes.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

Thanks Colin...sorry, not sure how I missed that specific reply! Thank you all.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

I'm having the same problem. Any estimate on a timeframe of when it will be resolved?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

Hi @ljb2411 - Pahup has posted a workaround above (for OSX users, using the

system linker), and said they're working on the toolchain fix.

Thanks, Pahup and team!

My app is in the queue (submitted last Thursday before this became a

requirement), so I'm likely to be rejected. I'll post back with an update.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

BTW guys, I had fun finding the Xcode  ld file...for me it's in this location:

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

I expect that one will work, but I used the one that Pahup pointed to. You can get to it in the Finder by choosing Go/Go to Folder... and typing in:

/usr/bin/ld

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

Can anyone explain in simple language how to fix this then? I use Flash CC and the latest AIR15 beta on Windows

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

My client's app successfully uploaded with the work around. I'm waiting to here if it's now in the review queue, but there's hope.

For Windows users it might just be that taking the Apple linker and replacing the Adobe one will work, but I'm not sure if that file is code, or just data. Also it may not be legal to give people bits of Apple code, no matter how small it is.

Are you at the stage of needing to submit an app?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

yes i am

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines