Highlighted

64 bit Flex based Desktop application

Explorer ,
Dec 09, 2018

Copy link to clipboard

Copied

How to create a 64 bit desktop application using Flash builder and Flex SDK ?

I guess the problem is your SDK version. You said you're using Flex 4.6.0. This version does not support 64-bit targeting.

Get the latest Apache Flex from http://flex.apache.org/installer.html

That should do the trick.

TOPICS
Development

Views

2.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

64 bit Flex based Desktop application

Explorer ,
Dec 09, 2018

Copy link to clipboard

Copied

How to create a 64 bit desktop application using Flash builder and Flex SDK ?

I guess the problem is your SDK version. You said you're using Flex 4.6.0. This version does not support 64-bit targeting.

Get the latest Apache Flex from http://flex.apache.org/installer.html

That should do the trick.

TOPICS
Development

Views

2.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 09, 2018 0
Adobe Employee ,
Dec 10, 2018

Copy link to clipboard

Copied

Hi,

Please refer Combined Windows 32-bit and 64-bit AIR SDK on Release Notes Flash Player 29 AIR 29 . For mac osx all applications are 64-bit by default.

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 10, 2018 0
Explorer ,
Dec 10, 2018

Copy link to clipboard

Copied

Hi,

I have updated AIR_WIN_ARCH value to 64 but even after that the flash builder is able to create 64 bit application on action script project only.

We however have a Flex project. When I export the flex project it is always created as a 32 bit application.

Can I somehow export a Flex project as a 64 bit application ?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 10, 2018 0
Explorer ,
Dec 12, 2018

Copy link to clipboard

Copied

Can someone please respond to this ?

Please confirm if this is not feasible. We need to take a decision on the applications fate.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 12, 2018 0
Explorer ,
Dec 13, 2018

Copy link to clipboard

Copied

I haven't had issues generating a 64-bit Flex application from Flash Builder. There are a few requirements like opting for captive runtime, setting the aforementioned environment variable and using the right SDK version (29+).

So it is definitely possible and not that hard. You're probably missing something simple.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2018 0
Explorer ,
Dec 13, 2018

Copy link to clipboard

Copied

Hi, I follow really simple steps as mentioned below:

Updated environment variable.

New -> Action Script project -> Project will use AIR SDK 31 -> Finish -> Right click Export -> Release build -> Signed application with Captive runtime -> Finish -> Creates a 64 bit setup

New -> Flex project -> Select Desktop & use default SDK(currently Flex 4.6.0) -> Finish -> Right click Export -> Release build -> Signed application with Captive runtime -> Finish -> Creates a 32 bit setup

I want to build a 64 bit setup with second case that is on creating new Flex project. What is it I am missing here ? Please help.Attached images for reference

DummyFlexProject.PNGDummyActionScriptProject.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2018 0
Explorer ,
Dec 13, 2018

Copy link to clipboard

Copied

1.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2018 0
Explorer ,
Dec 13, 2018

Copy link to clipboard

Copied

Hi mingtianjian​, I have the AIR_WIN_ARCH set to 64 please see below screen. Still the flex project is packaged only as 32 bit.

config.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2018 0
Explorer ,
Dec 14, 2018

Copy link to clipboard

Copied

step1:

1.png

restart you computer

step2:

<architecture>64</architecture>

step3:

1.jpg

download the demo application

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 14, 2018 0
Explorer ,
Dec 14, 2018

Copy link to clipboard

Copied

Hi mingtianjian

Adding <architecture>64</architecture> to flex project gives below error on exporting:

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 14, 2018 0
Explorer ,
Dec 14, 2018

Copy link to clipboard

Copied

I use Flex Builder 4.7,    AIR30.0

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 14, 2018 0
Explorer ,
Dec 14, 2018

Copy link to clipboard

Copied

Hi

The Flash builder is 4.6 and AIR 31.0

Do we need to have Flash builder 4.7 ?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 14, 2018 0
Explorer ,
Dec 14, 2018

Copy link to clipboard

Copied

you  try Flash builder 4.7

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 14, 2018 0
Explorer ,
Dec 14, 2018

Copy link to clipboard

Copied

I guess the problem is your SDK version. You said you're using Flex 4.6.0. This version does not support 64-bit targeting.

Get the latest Apache Flex from http://flex.apache.org/installer.html

That should do the trick.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 14, 2018 1
Enthusiast ,
Dec 14, 2018

Copy link to clipboard

Copied

see the Authoring Guidelines in the Adobe AIR release notes
Release Notes Flash Player 31 AIR 31

eg.

Add "-swf-version=42" to the 'Additional compiler arguments' field.

it will work with any SDK, either Adobe Flex SDK, Apache Flex SDK, Adobe AIR SDK, etc.

you can also check the loaderInfo.swfVersion to be sure the correct SWF version is used

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 14, 2018 0
Explorer ,
Dec 24, 2018

Copy link to clipboard

Copied

Thanks gfantiniAqua​ the application is a 64 bit when I used updated apache SDK

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 24, 2018 0
Enthusiast ,
Jul 27, 2020

Copy link to clipboard

Copied

Was this Flex?
I'm really struggling to get a 64-bit flex .apk package from Flash builder.

I've done all the above...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 27, 2020 0