Highlighted

64bit AIR Native Extension for iOS

Community Beginner ,
Dec 26, 2014

Copy link to clipboard

Copied

Hello,

I created a native extension to support ARM64 for iOS. The problem is I get the following error when packaging an ad-hoc build:

"Error: libgameCenter.a are required to have universal iOS libraries. Please contact the ANE developer(s) to get the same."

As I understand I need both armv7 and arm64 libraries. So I build for both of them using "xcodebuild" and then merge with "lipo -create" command.

However I think there is a step I'm missing. Please advice. Thank you.

AIR SDK: 16.0 beta

Xcode: 6.1.1

TOPICS
Development

Views

974

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

64bit AIR Native Extension for iOS

Community Beginner ,
Dec 26, 2014

Copy link to clipboard

Copied

Hello,

I created a native extension to support ARM64 for iOS. The problem is I get the following error when packaging an ad-hoc build:

"Error: libgameCenter.a are required to have universal iOS libraries. Please contact the ANE developer(s) to get the same."

As I understand I need both armv7 and arm64 libraries. So I build for both of them using "xcodebuild" and then merge with "lipo -create" command.

However I think there is a step I'm missing. Please advice. Thank you.

AIR SDK: 16.0 beta

Xcode: 6.1.1

TOPICS
Development

Views

975

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 26, 2014 0
Adobe Employee ,
Dec 26, 2014

Copy link to clipboard

Copied

Well the change you need to do is inside your Xcode project, under Build Settings -> Architectures , make sure that you have selected "Standard Architectures (armv7, arm64)". One last thing to ensure that Valid Architectures should also contain arm64 entry along with other armv7 entries.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 26, 2014 0
dr_handy LATEST
Community Beginner ,
Dec 27, 2014

Copy link to clipboard

Copied

Thank you but I have already selected "standart architecture". When i check the created library with "lipo -info" I get "armv7 arm64". The library size is also 2x greater from the old one.

Are there any other steps to compile universal anes? Do we need to change extension.xml, platform.xml or adt command?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 27, 2014 1