Highlighted

Adobe AIR iOS app doesn't run in background

Explorer ,
Aug 22, 2014

Copy link to clipboard

Copied

I have an iOS app made with Adobe AIR. It doesn't run in background even though I have done the following things I can think of,

1.  NativeApplication.nativeApplication.executeInBackground = true;

This is the first thing I did. I had another app which runs in background without problem, and this is the only trick I know I used there.

2. Experimented with <renderMode>direct</renderMode>, <renderMode>gpu</renderMode>, and <renderMode>auto</renderMode>. None worked.

3. Added,

<key>UIBackgroundModes</key>

  <array>

  <string>audio</string>

  </array>

Didn't work either.

Whenever I switch the app to background, no matter how short the time is, it always starts from the beginning when switched back. The only exception is when I take a phone call, in which case it seems to continue from where it left off. Can someone please tell me what is going on? Is there still hope left for me? Thanks a bunch.

BTW, the same app packaged for Android has no problem running in the background, and I didn't do anything to enable it.

I forgot to update there after I figured out the problem.

There is a key UIApplicationExitsOnSuspend which was for some reason set to true in my application.xml file.

TOPICS
Development

Views

393

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Adobe AIR iOS app doesn't run in background

Explorer ,
Aug 22, 2014

Copy link to clipboard

Copied

I have an iOS app made with Adobe AIR. It doesn't run in background even though I have done the following things I can think of,

1.  NativeApplication.nativeApplication.executeInBackground = true;

This is the first thing I did. I had another app which runs in background without problem, and this is the only trick I know I used there.

2. Experimented with <renderMode>direct</renderMode>, <renderMode>gpu</renderMode>, and <renderMode>auto</renderMode>. None worked.

3. Added,

<key>UIBackgroundModes</key>

  <array>

  <string>audio</string>

  </array>

Didn't work either.

Whenever I switch the app to background, no matter how short the time is, it always starts from the beginning when switched back. The only exception is when I take a phone call, in which case it seems to continue from where it left off. Can someone please tell me what is going on? Is there still hope left for me? Thanks a bunch.

BTW, the same app packaged for Android has no problem running in the background, and I didn't do anything to enable it.

I forgot to update there after I figured out the problem.

There is a key UIApplicationExitsOnSuspend which was for some reason set to true in my application.xml file.

TOPICS
Development

Views

394

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 22, 2014 0
Community Beginner ,
Oct 14, 2014

Copy link to clipboard

Copied

omgallnamestaken,

did you ever get anywhere on this?  Im trying to do the same thing on ios with air app running in the background.  thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 14, 2014 0
Explorer ,
Oct 15, 2014

Copy link to clipboard

Copied

I forgot to update there after I figured out the problem.

There is a key UIApplicationExitsOnSuspend which was for some reason set to true in my application.xml file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2014 0