Highlighted

Adobe Air SDK and Apache Flex: Air problems

Community Beginner ,
May 18, 2016

Copy link to clipboard

Copied

     Hello all. I have a few problem with publication on itunes and playmarket, and ios devices.

     I tried to use flex 4.14.1 and 4.15.0 with air 17, 20, 21, 22 beta.

     The problem's link is next. Air 17 has a problem with open ssl on playmarket(http://support.google.com/faqs/answer/6376725) so it's solved by using newer air sdk. In addition i'm using some ANE that requires air sdk 20 and newer.

     Adobe air sdk 20 and 21 have problems with itunes publications(email from apple with message about  Invalid Signature). There no problems with that on air sdk 22 beta. And it was fine and I was happy for a few days. But today new problem came. Its a new iOS 9.3.2. And the problem is called URLmonitor.available. Its always returns false value on air sdk 20-22 but device is connected to Internet and it works. By the way with air sdk 17 it works fine and returns true.

So can anybody to answer what is that and the ways to solve it?

as3 code:

     urlMonitor:URLMonitor = new URLMonitor(new URLRequest('http://www.google.com/'));

     urlMonitor.addEventListener(StatusEvent.STATUS, urlMonitorHandler);

     urlMonitor.start();

     private function urlMonitorHandler(event:StatusEvent):void {

       trace("code = " + event.code);

       trace("status = " + urlMonitor.available);

     }

result:

     code = Service.unavailable

     status = false

Thanks for your attention and time.

TOPICS
Performance issues

Views

935

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Adobe Air SDK and Apache Flex: Air problems

Community Beginner ,
May 18, 2016

Copy link to clipboard

Copied

     Hello all. I have a few problem with publication on itunes and playmarket, and ios devices.

     I tried to use flex 4.14.1 and 4.15.0 with air 17, 20, 21, 22 beta.

     The problem's link is next. Air 17 has a problem with open ssl on playmarket(http://support.google.com/faqs/answer/6376725) so it's solved by using newer air sdk. In addition i'm using some ANE that requires air sdk 20 and newer.

     Adobe air sdk 20 and 21 have problems with itunes publications(email from apple with message about  Invalid Signature). There no problems with that on air sdk 22 beta. And it was fine and I was happy for a few days. But today new problem came. Its a new iOS 9.3.2. And the problem is called URLmonitor.available. Its always returns false value on air sdk 20-22 but device is connected to Internet and it works. By the way with air sdk 17 it works fine and returns true.

So can anybody to answer what is that and the ways to solve it?

as3 code:

     urlMonitor:URLMonitor = new URLMonitor(new URLRequest('http://www.google.com/'));

     urlMonitor.addEventListener(StatusEvent.STATUS, urlMonitorHandler);

     urlMonitor.start();

     private function urlMonitorHandler(event:StatusEvent):void {

       trace("code = " + event.code);

       trace("status = " + urlMonitor.available);

     }

result:

     code = Service.unavailable

     status = false

Thanks for your attention and time.

TOPICS
Performance issues

Views

936

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 18, 2016 0
Adobe Employee ,
May 18, 2016

Copy link to clipboard

Copied

Hi ,

In iOS9, Apple has introduced App Transport Security (ATS) which blocks unsecure connections between App and Web services.  Due to this change, all connections made to unsecure web sites via Loader and URLLoader are now blocked by default and will not work due to App Transport Security.

Could you please go through Flash Player Help | Release Notes | Flash Player® 20 AIR® 20 for more details.

Thanks,

Ankit

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2016 0
New Here ,
Sep 01, 2016

Copy link to clipboard

Copied

Hi. Which SDK version is for Android Apps (.apk) for Flash Professional CC? Please help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 01, 2016 0
Community Beginner ,
May 18, 2016

Copy link to clipboard

Copied

good morning.

according to documentation i finally found

iOS SDK Upgrade (Starting 20.0.0.206)

"AIR Runtime is now built with iOS 9 SDK which enables AIR developers to use ANEs built with iOS 9 APIs without using the –platformSDK switch while packaging with ADT. App Transport Security (ATS) is being introduced from Apple in iOS9, which doesn’t allow unsecure connections between App and Web services. Due to this change all the connections which are made to unsecure web sites via Loader, URLLoader will discontinue and not work due to App Transport Security. Please specify exceptions to the default behavior by adding keys to InfoAdditions tag of application descriptor of your app."

so we need to add this to application.xml in your project

<key>NSAppTransportSecurity</key>

<dict>

<key>NSAllowsArbitraryLoads</key><true/>

</dict>

more details you could find on:

https://forums.adobe.com/thread/1970746

http://fpdownload.macromedia.com/pub/labs/flashruntimes/shared/air20_flashplayer20_releasenotes.pdf

URLRequest - Adobe ActionScript® 3 (AS3 ) API Reference

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2016 0