Highlighted

ADT cannot list connected iOS devices.

Explorer ,
Sep 17, 2015

Copy link to clipboard

Copied

After updating to iTunes 12.3 today I can no longer list connected devices and can't deploy to them.

After running adt -devices -platform ios all I am getting is:

iIPA.exe[3044:1be0] CFNetwork module LOADED!

If I try to use the iIPA.exe directly I will get the correct list, I also see all my devices inside iTunes.

Any help?

Hi All,

You can check this issue with the Rankin Beta build 20.0.0.178 and we believe that all the issues in this thread has been solved.

We also have collected the list of issues that you can face in this blog: Troubleshooting common Adobe AIR installation errors with iOS applications.

Please let us know if you are still facing some issues. We are happy to solve them.

Thanks

Adobe AIR Team

TOPICS
Development

Views

3.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

ADT cannot list connected iOS devices.

Explorer ,
Sep 17, 2015

Copy link to clipboard

Copied

After updating to iTunes 12.3 today I can no longer list connected devices and can't deploy to them.

After running adt -devices -platform ios all I am getting is:

iIPA.exe[3044:1be0] CFNetwork module LOADED!

If I try to use the iIPA.exe directly I will get the correct list, I also see all my devices inside iTunes.

Any help?

Hi All,

You can check this issue with the Rankin Beta build 20.0.0.178 and we believe that all the issues in this thread has been solved.

We also have collected the list of issues that you can face in this blog: Troubleshooting common Adobe AIR installation errors with iOS applications.

Please let us know if you are still facing some issues. We are happy to solve them.

Thanks

Adobe AIR Team

TOPICS
Development

Views

3.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 17, 2015 3
New Here ,
Sep 18, 2015

Copy link to clipboard

Copied

Exactly the same problem

(Flash Builder 4.7. SDK Apache Flex 4.14.1 FP 16.0 AIR 16.0 en_US)

Help please...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2015 0
Adobe Employee ,
Sep 18, 2015

Copy link to clipboard

Copied

Hi,

We have also found this issue with AIR SDK and latest itunes version 12.3 and we have logged an internal bug for the same.

Our team is looking at it. I will keep you posted here.

-Adobe Air Team

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2015 4
New Here ,
Sep 20, 2015

Copy link to clipboard

Copied

Ok, Mac OS does not seem to be affected:

Screen Shot 2015-09-20 at 14.49.43 .png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2015 0
New Here ,
Sep 20, 2015

Copy link to clipboard

Copied

Also does install ok.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2015 0
New Here ,
Sep 23, 2015

Copy link to clipboard

Copied

Same problem

Widnows 8 64 bit

iTunes 12.3.0.44

when I try:

adt -devices -platform ios

2015-09-23 17:00:03.222 iIPA.exe[6660:1144] CFNetwork module LOADED!

Some news or fix?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 23, 2015 0
New Here ,
Sep 25, 2015

Copy link to clipboard

Copied

No news?

At the moment I manually upload the file by calling iIPA in the following way:

iIPA.exe -uninstall mypackage 1 1

iIPA.exe -install myApp.ipa 1 1

I enqueue this to my build script.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2015 0
Participant ,
Sep 25, 2015

Copy link to clipboard

Copied

what's this iLPA.exe?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2015 0
Participant ,
Sep 25, 2015

Copy link to clipboard

Copied

nvm found in lib/aot/bin/iosbin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2015 0
Explorer ,
Sep 25, 2015

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2015 1
Community Beginner ,
Sep 30, 2015

Copy link to clipboard

Copied

I can confirm that fix by Eric Pascal works for me for SDK 18 & 19

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 30, 2015 0
Explorer ,
Nov 06, 2015

Copy link to clipboard

Copied

I was having problems with the solution on twitter.  I finally looked at the included .bat file and noticed there was a space between "2 >".

It needs to be "2>" for it to work properly.  At least in the version I downloaded.  Was banging my head all day, but working fine now directly from Flash Builder.

Good luck

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2015 1