Highlighted

AIR 25 BUG: unsupported address encoding of personality function in CIE for architecture arm64

Explorer ,
Jun 26, 2017

Copy link to clipboard

Copied

I am trying to build an app using AIR 25 + heyzap with facebook audience network sdk on windows and got the following message:

ld: in C:\\Users\\Yaroslav\\AppData\\Local\\Temp\\11360509-d29b-41fb-a6ce-de352cab81be/FBAudienceNetwork.framework/FBAudienceNetwork(FNFLoopingAsset.o),

unsupported address encoding (39) of personality function in CIE for architecture arm64

And then build fails. I tried with latest 26 beta too with the same result.

I have also found that there was a similar issue in AIR17 (issue 3950027 : ld error “ld: in , unsupported address encoding (13) of personality function in CIE for architecture arm64 Compilation failed while executing : ld64" when packaging with WIN SDK. )

So it seems that it is an old bug which was fixed but then return back.

Is there any way to solve this problem now?

TOPICS
Performance issues

Views

1.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

AIR 25 BUG: unsupported address encoding of personality function in CIE for architecture arm64

Explorer ,
Jun 26, 2017

Copy link to clipboard

Copied

I am trying to build an app using AIR 25 + heyzap with facebook audience network sdk on windows and got the following message:

ld: in C:\\Users\\Yaroslav\\AppData\\Local\\Temp\\11360509-d29b-41fb-a6ce-de352cab81be/FBAudienceNetwork.framework/FBAudienceNetwork(FNFLoopingAsset.o),

unsupported address encoding (39) of personality function in CIE for architecture arm64

And then build fails. I tried with latest 26 beta too with the same result.

I have also found that there was a similar issue in AIR17 (issue 3950027 : ld error “ld: in , unsupported address encoding (13) of personality function in CIE for architecture arm64 Compilation failed while executing : ld64" when packaging with WIN SDK. )

So it seems that it is an old bug which was fixed but then return back.

Is there any way to solve this problem now?

TOPICS
Performance issues

Views

1.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 26, 2017 0
Explorer ,
Sep 19, 2017

Copy link to clipboard

Copied

ping

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 19, 2017 0
New Here ,
Nov 28, 2017

Copy link to clipboard

Copied

Elegar, did you find how to solve the problem?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 28, 2017 0
Explorer ,
Nov 28, 2017

Copy link to clipboard

Copied

I had a long conversation with heyzap support about it, that's what they recommended:

"If you build the application on a Mac, there is a known workaround, where you must replace the `ld` linker provided by Adobe AIR's SDK with the one provided by the Mac OS."

Though I don't have a Mac, so this problem is still unsolved for me

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 28, 2017 0
New Here ,
Dec 04, 2017

Copy link to clipboard

Copied

It's so sad. Anyway, thanks for the update. It looks like Adobe doesn't hurry to solve the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 04, 2017 0
Adobe Employee ,
Dec 11, 2017

Copy link to clipboard

Copied

Hi

I tried using heyzap with facebook audience network in sample app on windows with AIRSDK 25+ but could not reproduce the issue.

Could you please share a sample project where this issue is reproducible.

Thanks

Prakash | Adobe AIR Engineering

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 11, 2017 0
Community Beginner ,
Dec 11, 2017

Copy link to clipboard

Copied

It got fixed in AIR 26 or 27 SDK, so its old ticket. Thanks anyway.

Sargis

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 11, 2017 0
Explorer ,
Dec 11, 2017

Copy link to clipboard

Copied

svetlanam53747991

Are you able to create an ios app with Heyzap + FBAN? Can you tell which version of FBAN and Heyzap are you you using and where did you get it? Because I'm still suffering from this issue

pravishtis

You just have to compile  very basic project for IOS with Heyzap SDK + Facebook Audience Network SDK downloaded from here: Ane Setup and Requirements Docs • Heyzap to reproduce this issue. I don't know how to share buildable sample project, there is a lot of configs which are specific to the machine or account

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 11, 2017 0
Community Beginner ,
Dec 12, 2017

Copy link to clipboard

Copied

Sorry, my message was posted at wrong discussion, it wasn't suppose to be here. Please disregard it and sorry for the confusion.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 12, 2017 0
Community Beginner ,
Dec 12, 2017

Copy link to clipboard

Copied

Elegar, i just looked into that issue that i was experiencing long time ago. Actually i don't use heyzab but only the FBAudianceNetwork.framework in native extension in ios app. So i get that error when compiling on windows but works fine when compiling on mac. Also it works only when i include the <option>-lxml2</option> flag right after <option>-framework FBAudienceNetwork</option> in the platform-ios.xml for ANE compiling. Not sure if that will help you and if your case is similar like mine but i got it working with it some time ago. Also currently i use AIR28 sdk and still getting the error on windows only.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 12, 2017 2
New Here ,
Dec 13, 2017

Copy link to clipboard

Copied

svetlanam53747991

hey, your solution helped me. Thank you very much! But this is strange as far as there was <option>-lxml2.2</option> in my platform.xml

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2017 0
Explorer ,
Dec 13, 2017

Copy link to clipboard

Copied

@prakasku yes, sorry, I forget to mention that this IOS-only issue, android is ok

svetlanam53747991​ so you solution is mac-only, right? No way for windows build?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2017 0
Community Beginner ,
Dec 13, 2017

Copy link to clipboard

Copied

Elegar, yes, unfortunately I couldn't make it to work in Windows, once it worked on mac i just started compiling it on mac because I didn't have much time to play with it but it will be super helpful if it worked in Windows.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2017 0
Community Beginner ,
Dec 13, 2017

Copy link to clipboard

Copied

Great, I am glad that it helped you. I think the lxml2 flag is framework specific so it has to be right after the exact framework in the platform xml, may be that is why it didn't work with your other lxml2.2 flag? Not sure though, i am just guessing, its not really clear to me either.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2017 0
Adobe Employee ,
Dec 13, 2017

Copy link to clipboard

Copied

Hi,

We are investigating this issue on iOS, however it is working fine on Android using windows.

Thanks

Prakash | Adobe AIR Engineering

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2017 0