Highlighted

AIR Android Java 6

Contributor ,
May 31, 2015

Copy link to clipboard

Copied

I wasted a lot of time trying to rebuild an ANE after format my Mac and install the most updated version of my tools.

The problem was that ANE for Android requires specific Java 6 and only Java 7 and 8 (the most recent version) are available for Mac.

Ultimate I was able to download a version of JDK 6 from Apple web site however this is not the desire solution.

Btw I'm using Flex 4.14.1 + AIR 17.

Please update AIR to support Java 8 !

TOPICS
Air beta

Views

915

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

AIR Android Java 6

Contributor ,
May 31, 2015

Copy link to clipboard

Copied

I wasted a lot of time trying to rebuild an ANE after format my Mac and install the most updated version of my tools.

The problem was that ANE for Android requires specific Java 6 and only Java 7 and 8 (the most recent version) are available for Mac.

Ultimate I was able to download a version of JDK 6 from Apple web site however this is not the desire solution.

Btw I'm using Flex 4.14.1 + AIR 17.

Please update AIR to support Java 8 !

TOPICS
Air beta

Views

916

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 31, 2015 1
Adobe Employee ,
Jun 09, 2015

Copy link to clipboard

Copied

Hi Hferreira,

Can you tell us which Java version did you use, and at what point of ANE packaging (or any other step) you faced the problem ?

-Tushar,

Adobe AIR Team

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 09, 2015 0
Contributor ,
Jun 09, 2015

Copy link to clipboard

Copied

Hi tdwivedi,

"Can you tell us which Java version did you use"

Tried with Java 8, them Java 7 from official Oracle setups.

"what point of ANE packaging (or any other step) you faced the problem"

At runtime of Android AIR (complains like if there is no native code).

Workaround:

Install Java 6 from Apple web site and point the compiler to that specific version.

Regards,

Hugo.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 09, 2015 0
Adobe Employee ,
Jun 11, 2015

Copy link to clipboard

Copied

Hi,

We tried reproducing it with Adobe Vibration ANE, but found it to work correctly with Java 1.7 .

We will need some more information to reproduce this issue at our end.

Can you provide a sample ANE code in which you can reproduce this error with the steps to reproduce it, for example your device information, development environment (IDE etc) and the ADT command used to package the ane.

We will try few other ANEs to see if it gets reproduced, by the time, I would suggest you to log a bug in Adobe Bugbase (Here‌) regarding this issue with above information, for more efficient tracking of the issue.

- Tushar Dwivedi,

Adobe AIR Team

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 11, 2015 0
Contributor ,
Jun 11, 2015

Copy link to clipboard

Copied

Environment:

OS: Mac OSX 10.10

IDE: IntelliJ (last production version)

Java 7 and 8 from Oracle website

SDK: AIR 17

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 11, 2015 0
Contributor ,
Jun 11, 2015

Copy link to clipboard

Copied

Build script (exactly as it is, except the name of the ANE and also a thirty party JAR library):

# path to Android SDK

export AIR_ANDROID_SDK_HOME="/Volumes/Data/SDK/Android/"

# path to Flex SDK ADT tool

ADT="/Volumes/Data/SDK/Flex/bin/adt"

#===================================================================

echo "****** preparing ANE package sources *******"

rm build/MyAne.ane

rm -rf ./build

mkdir -p ./build

mkdir -p ./build/Android-ARM

mkdir -p ./build/Android-ARM/res

mkdir -p ./build/Android-x86

mkdir -p ./build/Android-x86/res

mkdir -p ./build/default

# copy resources

cp -R ./Source/Android/res/* ./build/Android-ARM/res

cp -R ./Source/Android/res/* ./build/Android-x86/res

# create the JAR file

jar cf ./build/Android-ARM/MyAne.jar -C ./Source/Android/bin .

jar cf ./build/Android-x86/MyAne.jar -C ./Source/Android/bin .

# extract the content of the external jar file

rm -rf ./OtherLibrary

mkdir ./OtherLibrary

cd OtherLibrary

jar -xf ../Source/Android/libs/OtherLibraryFree.jar

cd ..

# add the content of the external jar file

jar uf ./build/Android-ARM/OtherLibrary.jar ./OtherLibrary/android

jar uf ./build/Android-ARM/OtherLibrary.jar ./OtherLibrary/other

jar uf ./build/Android-x86/OtherLibrary.jar ./OtherLibrary/android

jar uf ./build/Android-x86/OtherLibrary.jar ./OtherLibrary/other

# grab the extension descriptor and SWC library

cp ./Source/AIR/src/extension.xml ./build/

cp ./Source/AIR/bin/*.swc ./build/

unzip ./build/*.swc -d ./build

mv ./build/library.swf ./build/Android-ARM

cp ./build/Android-ARM/library.swf ./build/Android-x86

cp ./build/Android-ARM/library.swf ./build/default

echo "****** creating ANE package *******"

"$ADT" -package -target ane \

  build/MyAne.ane \

  ./build/extension.xml \

  -swc ./build/*.swc \

  -platform Android-ARM -C ./build/Android-ARM/ . \

  -platform Android-x86 -C ./build/Android-x86/ . \

  -platform default -C ./build/default library.swf

echo "****** ANE package created *******"

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 11, 2015 0
Community Beginner ,
Jul 14, 2015

Copy link to clipboard

Copied

Hi,

    "work correctly with Java 1.7"?

It will compile all right,but it will cause error when runtime.I have changed the JDK to 6,then no error on runtime.

Bug#3966813 - ADT targeting ane will not work for Java7

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 14, 2015 0